[RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

Just one more follow-up before I return the CT-30. I installed the Device code and the smart app. I linked the thermostat to smartthings without issue. When looking at my list of things, it displays the temp but it is not in green like it used to be before the updated device code. Do once in the “thing”, i can change the temp and see the current temp using the thing buttons. It however still reports as offline to Google Home. It has rights to manage it and can see the dame of the thermostat, but cannot make changes to it. Thermostat also does not follow the schedule I created. I assigned this thermostat to this schedule after I unlinked the ZWAVE and reset the device using the reset button.

Any ideas? Should I just go pick up and Ecobee? Thanks!

ST has changed the color scheme, the new DTH’s now match the ST recommended color scheme which is mostly Blue and Gray

Don’t know, you’ll have to contact Google Home for that. If it’s showing up as offline in ST then it could be the new Device Health feature. It has some issues still being looked into by the ST staff. Once a device goes offline the only way to being it back online is to exclude it and repair it again. If it’s offline also report it to ST so they can track it.[quote=“rock99rock, post:179, topic:6780”]
cannot make changes to i

Again don’t know about Google Home, but if it’s due to the device heath offline issue I would suggest exclude and re pair it with the hub.

If the thermostat is having trouble communicating with the hub the schedules won’t work (obviously). Again see above if the device health issue is at play here then it could be fixed, if it’s a thermostat issue you should probably replace it, it could be just a bad piece.

1 Like

Thank you. The device itself shows as online; it was only Google Home that saw it as offline. Taking Google Home out of the equation and seeing the screenshot above (online, checking in, healthy), where else would I look to see if the thermostat is having issues communicating with the hub? The device auto sets the time and date after initial linking, and I can set the temps from things. Just the schedule will not work. Is there an error log for the schedule?

Thank you!

If there is a communication issue you won’t see an error, infact the opposite your Live Logging will show that the SmartApp is sending the command to set the temperature to the device (your device logging should also show it receiving the command from the SmartApp and possibly sending it to the device) but the device won’t respond. That’s how you can diagnose the comms issue. Never hurts to exclude the device, reboot the hub and repair it and if not try to have it exchanged.

1 Like

Is there a way to set 1 temperature instead of 7 days worth? Currently I have to set all days to the same temp and change all of them if i wish to tweak it. I do use remote sensors to detect the temp, just want to simplify a single temp change.

There are only three “days” worth of settings you can enter here, weekday and Sat/Sun. So you have the same schedule for each work day. We could provide an option of use the same setting for all 7 days if that’s what you’re looking for.

Meanwhile, have you checked out the other apps which may meet your needs?

The option would be great. My heat schedule is a weekday / weekend, but my a/c schedule doesn’t change.

Tis the season for vacations!
Is there something in this scheduler that would hold the setting while I’m away for some time? Like, if l were to go on vacation for a week, I would like to set the stat to some temp and have it hold that setting and disregard the programatic changes. Then on the way home, log in and have it resume. Now it seems I have to change every day’s settings to keep the A/C from coming on.

This is the app you’re looking for:

When in different modes you can customize the temperature levels (independently for each thermostat), set your regular 5-2 day thermostat to run only when in Home mode and for all other modes use the above app to define the “maintenance” levels.


I just subscribed to your apps and installed this 5-2 thermostat app. My ST system is fairly simple, just a Zen Thermostat and a few remote temperatures sensors and leak detectors. The Zen is controlled a gas central heating system, we have no central cooling system.

Up until this point I’ve just been switching the Zen between Off and Heat when we come home/go to bed etc.

With this SmartApp it seems that it assume the thermostat is in an Auto or Heat mode? ie. I installed it whilst at work, told it to set the heat point to 20C at 5:50PM (and set the cooling to 25C as it was required?). When I got home to a cold house I realised it was because despite your app setting the heat set point to 20C correctly, the Zen was still in Off (how I left it this morning).

Now, this all makes sense I guess - I can live with setting an imaginary cooling set point and setting the heat to 20 when home and 14 at night or when ‘leaving’. But I noticed that there’s an optional fan control for each time. Could there be an optional mode setting as well? In my case I’d use ‘Heat’ and ‘Off’. Does that even make any sense to anyone else? I’m from the UK, living in Australia so perhaps we’re used to different things…

The app doesn’t change the mode, it only sets the temperature (like you said if your thermostat doesn’t support cool, it’ll just ignore it). Why don’t you just leave your thermostat set to heat and set the temperatures to turn the heat on/off. So set it to 20 when you’re at home and set it to 10 when you’re away. It’s best not to mess with the modes in our experience since it creates other issues. The ideal way would be to set the temperature ranges. E.g. when you’re away you don’t want the house to freeze over right? So set it to 5C for the times you aren’t at home.

I realised the other reason I stuck with turning the mode on and off with ST + Zen is that the integration between the two of them isn’t working too well for me. Changing the mode works fine, but changing the heating setpoint via ST is randomly over-written seconds or minutes later most of the time. Sometimes it works. This morning I tapped the Up arrow on the default Zen DTH to go from 16 to 17 to 18 and before my eyes it flicked back to 16. I think yesterday the 5+2 smart app change from 14 to 20 actually stuck, but it’s pretty rare.

It’s like there’s another ghostly device in my system that has other ideas about what the setpoint should be. It may be the Zen itself I guess. When I stood in front of it and tapped its screen to wake it up and check the setpoint it worked. I have contacted Zen support but have yet to hear back from them.

You’ve likely got more than one SmartApp controlling your device which is conflicting with each other. Open your IDE -> My Devices -> click on your device and list the events and see which apps are sending commands to your devices.

###5-2 Day Thermostat with Remote Sensor - Version 03.04.02

  • Added support for temporary hold for all modes (with and without remote temperature sensors)
  • Added support to manually reinitialize the thermostat schedule by clicking on the Arrow next to the SmartApp name

The SmartApp detects if the user changed the temperature manually and will not override the temperature until the next scheduled temperature change.

Please open the SmartApp click Next and then Done for the “Arrow” to show up. (this only needs to be done once after updating the code).

Thanks RBOY,
Looking forward to using this new feature.

1 Like

No, I checked that.

In talking with Smartthings support they say they’ve seen this before with Zen (if that was documented publically I may not have bought one…). Zen support say there is a new firmware (for the Zen?) out ‘in a month’ but in trying to get more out of both ST and Zen support I’ve not been able to ascertain how that will be deployed or if it’s possible to get it earlier. At the moment I’ve simply deleted your app as it’s useless for me at the moment :frowning:, not that it’s your fault. In about 8 weeks I won’t even need the heating again for around 7 months…

1 Like

Hi there,

I am a new user and having a problem with the remote sensor feature. I tried searching the forum, but can’t seem to find a similar problem.

So, I have a downstairs thermostat (GoControl using the Enhanced Z-Wave Thermostat device handler) and an upstairs temperature/motion sensor (Monoprice using the Monoprice PIR Motion Detector with Temperature Sensor device handler). Whenever I try to use the option to use a remote temperature sensor to control the thermostat, it sets the cooling set point to 90. This problem does not occur if I decline the option to use a remote temperature sensor, and just use the thermostat as the temperature sensor.

For example, I have it programmed to cool to 68 using the remote sensor to monitor the temperature. The current temperature in the upstairs remote sensor is reading 70, and the downstairs thermostat reads 71. The thermostat cooling set point adjusts to 90. Now, when I go back to the app and unselect the option for remote sensor (and use the thermostat to read temperature), it correctly adjusts the cooling set point to 68.

Any thoughts?

That’s normal behavior when you’re using a remote sensor.

Detailed Explanation: When using a remote sensor the temperature is measured at the remote location and not where the thermostat is located. The thermostat is set to 50 degrees when cooling and 90 degrees when heating and vice versa to turn the HVAC off when the desired remote temperature is reached.

Thanks for your quick reply!

Your response makes sense to me if the desired temperature was reached. In my case, the set point I defined in the app (68) is lower than the temperature in the house at both the remote sensor (70) and downstairs thermostat (71). Therefore- it should trigger the thermostat to cool, but rather it seems to be going in standby mode (cooling set point at 90- so AC is not on) or it won’t trigger a thermostat change at all.

It seems like it is not using the information from the remote sensor properly. Because, once I select the app to only use the thermostat temperature as the sensor, it works perfectly.

It’s working fine here in the labs, check your settings again. You may have defined operating modes or your remote sensors isn’t reporting to the SmartApp what you think it’s showing.

Also note that if you’re using multiple remote sensors it uses the average of all the remote sensor temperature readings.