Recommendations for a humidity sensor

The dehumidifier I have has a pretty poor humidity sensor, which results in it running quite often. Does anyone have any recommendations for an accurate humidity sensor? I’m thinking about the Zooz ZSE40 4-1. Any other suggestions?

Naturally I’m going to use a smart outlet with my dehumidifier and turn it on and off based on the humidity sensor.

1 Like

Been using the Smartthings model and so far I’ve been pretty happy. We have it switching a humidifier on/off during the winter.

I don’t think they sell this anymore. I wasn’t able to find it at least.

I use this one and have had good luck with it. The zooz was not available, and the Aeotec’s driver is native in ST. Downside is you need to buy batteries or plug it into a USB,

The Zooz was not out when I bought it. I would consider the Zooz but the way it reports lux (in percentage) is not standard. Not sure if it will work with rules.

1 Like

The zooz is battery powered as well, but if I can plug in the aeotec that’s a definite advantage.

Also use the Aeon Multi 6 & like it, FWIW :+1:

Difficult to measure but how accurate is it?

Mine was within a percent of the only other reference I had, albeit not a precision reference. Have three currently installed at two locations/hubs. Seems OK for “relative” humidity!

1 Like

There is Aeon if you want zwave, which @desertblade mentioned and then there NYCE ceiling if you like zigbee. I have both and they work well. A NYCE variant is used by Control4.

I just got one but my hub can’t find it, any tips?

Sorry to break it to you, but you just got yourself in a nightmare. I meant to warn @Bjomesphat , that had a hell of a time trying to pair one couple of weeks ago. And I have 150+ devices. I ended up using a custom handler.

Thanks, I’ll just send it back, life’s too short…

1 Like

In that case I’ll probably stick with zooz or aeon multi. Thanks for the suggestion though.

The aeon multi 6 is the one my hub can’t find.

The hub didn’t at least find it as a thing?

I used a custom handler at first, but went back to the stock handler.

Here is what I did awhile back:

Delete all the custom device handlers you have and unpair the device. Reset the device:

“At some stage or your primary controller is missing or inoperable, you may also wish to reset all of your MultiSensor’s settings to their factory defaults. To do this, press and hold the Z-Wave Button for 20 seconds and then release it. Your MultiSensor will now be reset to its original settings, and the LED will stay solid for 2 seconds and then turn off as a confirmation.”

Then re-add it to smartthings using the default device handler that shows up.

1 Like

Maybe I’ll try that tomorrow, hiiting the sack now. Nope never even found it as a thing

Do a general exclusion first. Then reset the device. Try the stock option like @desertblade said. But if that doesn’t work, or your sensor doesn’t show the motion capability but picks up on the others (that’s what happened to mine) then use @erocm1231 handler. I had no problems with it since I paired it.

1 Like

Ok at the risk of seeming like an idiot this is what I see when I hit ‘general device exclusion’ so I just hit done?

You need to press the sensor button, like you want to include it. It should say exclusion successful.

If nothing happens, after you press the sensor, it means your sensor is not associated with a controller, so you are good to go…

1 Like

Ok if I got it straight when in exclusion mode press the action button on the sensor, thanks for the help.