Pixel phone doesn't work as presence sensor


#1

I recently upgraded to a Google Pixel XL android phone, and registered it as a presence sensor in ST (while at the same time removing my old Galaxy S7 Edge phone from all of my rules, and replacing it with my new one). The problem is, ST seems to be completely unaware of when I come and go. It always thinks the phone is “present,” even when I’ve been away, or at work all day. My phone has location enabled, and it is accurately reporting my location in the Maps app. I’ve even used it to navigate me somewhere (so the phone has been awake, with a GPS lock for more than 20 minutes) and the app still doesn’t know I’ve left my house. I double checked the permissions, and location is enabled for that app. Any ideas?


Can the Google pixel phone connect to Samsung SmartThings?
(jkp) #2

One alternate option to try… install the Life360 app on your Pixel and the Life360 smartapp in ST, then authorize the connection between them.


(Joe) #3

I just added mine and it says present. Haven’t left yet to see if it works when I leave.


#4

I have been using my pixel with location set to battery saving and it has been working perfectly fine for me leaving and coming home.


#5

I had this same problem with my Pixel. My girlfriend’s Pixel was working perfectly as a presence sensor but mine said I was always present. Here’s what worked for me to fix it:

  • Removed my Pixel from all smartapps
  • Removed my Pixel from Smartthings
  • Deleted myself (my name) from Smartthings
  • Removed the Smartthings app from my phone
  • Reinstalled Smartthings
  • Added my name back to Smartthings
  • Added my Pixel as a presence sensor
  • Associated the Pixel with my name in Smartthings
  • Added my Pixel back to smartapps

It’s kind of a tedious process and I don’t know exactly which step fixed it for me. Hopefully this helps. Sorry I don’t have a definitive answer!


#6

Thanks for the detailed instructions, wschwa! What do you mean by adding/removing “my name” from smartthings? You didn’t actually delete your account or anything, did you? The only place I see my name is the name of the presence sensor itself. I went through all of the steps except removing and adding my name. I will probably have to wait until tomorrow to see if it worked.


#7

So under “My Family” I have my name and my girlfriend’s name and they’re each assigned a presence sensor. So I deleted my name in addition to the presence sensor.

What’s weird is this worked all day yesterday and today and then this evening now my phone is stuck as not present. So I’m not sure how to fix it at this point.


(Jake K) #8

Hey everyone,

If you’re running into issues with your Pixel not working as a Mobile Presence sensor, first check the IDE and make sure the Mobile Presence Sensor has a presence state. If it doesn’t reach out to Support with your Android build number.

If it does show a presence state, do the typical trouble shooting: GPS High Accuracy, Doze turned off, SmartThings App has permissions to location, etc. If things are still acting weird, reach out to Support and let them know what steps you’ve taken and they’ll dig into it for you.

Edit: I just side loaded the Verizon Build, NDE63P and no longer can get presence states from my mobile presence sensor after removing and re-adding my phone. Make sure to hit up support so that they can make some noise to the developers about this issue.


(Ansel Santosa) #9

Yep, I have this exact same issue on two Google Pixel XL phones. I’ve tried everything. Reinstalling, Rebooting, force closing, logging in and out, clearing data, removing and re-configuring the phones in the app, turning off battery optimization, high accuracy location, turning location permissions on and off, enabling wifi, wifi scanning and bluetooth scanning, etc. Nothing works. I have reached out to SmartThings support with the issue.


#10

I have the non-XL Pixel. I haven’t had a problem. You do need to remove your old presence sensor for your last phone and re add yourself with your new phone as a presence sensor.

That’s true any time you replace a phone on smart things I’ve noticed. At least with my prior Nexus devices.


(David) #11

I just upgraded to the pixel xl. It’s on back order right now. Is everyone’s phone working correctly now?


#12

Mine is. I have no explanation as to why. It must’ve been either an OS update, or a smartthings app update, because I wasn’t able to fix it with a setting or anything.


(Joe) #13

Mine works just fine.


(David) #14

Thanks guys!


(Gianni Latorre) #15

I’m having the same issues, but the problem is that it works with lots of delays. How did you guys solve this?