Particle Photon/Spark Core RGB WS2812B

Yes in the SmartThings ide you will need to create the device. If you have created the device handler you should be able to choose that device type in the the device creation.

Then go into the phone app and there should be a new device that needs to be setup.

In the device settings (the gear) you will need to set your device ID (found in the photon ide next to the device there is an arrow you can click to unhide). You will also need to set the access token this is found on the photon settings on the photon ide.

OK - I have created the device handle and then the device.
What are the values for these fields? - please let me know if mine is correct, or not:

Name: Kitchen RGB
Label: (???)
Zigbee Id: (???)
Device Network Id * : - I got this and can put it on there
Type: RGBW light (???)
Version: Published (???)
Loc, Hub, group…etc - I have the first two values here.

Where do I put the “Access token” in ?

Name: Kitchen RGB
Label: I usually make this the same as name
Zigbee Id: n/a
Device Network Id this is not the device ID you can make up a random number like 12341234
Type: this should be the device type you created from the github code
Version: self published
Loc, Hub, group…etc - I have the first two values here.

Ok, I did a rescan of my devices in the phone app and it found “Kitchen RGB” as ON. It is not on - no LED is light.
When I click on, it it says 'turningoff" - but it times out - nothing happens.
When I click on the name - I can see the controls, changing the colors, etc - but nothing turns on…ideas?

I am still not sure now where to specify the device ID and access token.
AS I click on the gear in the app, next the Kitchen RGB, it only asks me to change the name, and turning it on and off - and done - no device ID/access token…
GAWD - I am so close

Yes you are. In the app click on the device and then click on the gear (settings). This is where you enter device ID and access token.

nope…as I click on the device and then on the gear - I can only:
turn device on or of (it say it’s on)
“give your device a name” and "update icon"
and click done - it never asked me for the ID and access token

you are talking about the mobile app, right, not the ST IDE??

Yes I was, but I think you have the wrong device type. Device type should be Kitchen Spark/Photon WS2812b.

You did create the device handler using the device type code in github?

So in ide verify in device handler you have Kitchen Spark/Photon WS2812b. Then switch the device type to that.

YES!!!

THANK YOU ! THANK YOU!..
It as the TYPE…
The moment I select TYPE - Kitchen RGB/… it asked me for the id and access token!

YES!

**

THANK YOU!

**

You are welcome. It is really a great setup. They work perfect too. I use them in the home theater as accent lights that dim when the movie starts and then brighten up on pause and stop. Oh I also setup an ifttt channel that will do different effects for different scenarios. Like if the Bears score a touchdown they alternate blue and orange. Oh and tornado warning is red. Enjoy and if you come up with anything clever feel free to give feedback.

I do want to update this code so status is accurate on the app, but I don’t use the phone app much.

Just another question - how do you control your other colors? How do you even control yours since you mention you are not using the ST app?

With the ST app, it does not always work correctly - sometimes when I turn it off, it goes back to the previous selection and other times it leaves a part of the string on (although the OFF - signal went all the way from beginning to end, a part will still be lighten up).

Any idea what I must do to get Amazon Alexa discover this? - I deleted all my device in Alexa, run a re-discovery but she still cannot find it (although I must admit, the LED string were not ‘on’ when I run the discovery.

Thanks!

For my basement kitchen I am using SmartThings I interact through an enerwave 7 button scene controller that I have a modified device type for. The device type will take it through the assigned colors. For the home theater I use a combination of SmartThings, ifttt and curl command initiated by kodi cinemavision(dim level on movie start).

The Amazon echo should not have a problem with on and off commands. Make sure you install the Amazon echo app inside of SmartThings choose the devices you want then gave the echo discover the devices.

Justin

I am not sure I understand what you mean by '…install the Amazon echo INSIDE of Smarthings" ?
My Amazon echo already can control all my other smarthings devices - when I deleted all and did a re-discovery it only picked up all the original devices, not the new Spark/RGB thingy…
ideas?

You need to go into the Amazon Echo smartapp and check the checkbox for your new photon device to give Alexa access to it. After that, go do the device discovery and it should discover your new device.

Yes if you go to smartapps inside of the SmartThings app there should be an Amazon echo smartapp. Here you setup the endpoints the echo can discover.

Thank you!

I think I missed that step…

Thanks - I must have missed that step…WOW - so much to remember…LOL
I do appreciate all your help and getting me through this setup.

Now my next step is getting the LED string fixed under the top counters…and then onto the blinds (and I know you’re and expert on this too!..LOL)

Bert

Blinds are harder from the diy perspective. You’re going to need a bolt cutter. ;-). But coding I think is about the same.

Bert did you say you were having lights stay on after you turn them off? If so that might be a memory leak and if it is I would double check your pixel count number on the photon and make sure that matches your actual number of pixels on your LED strip.

Hi
I got home early today and thought to give this a try, Well - not much luck.
Inside the ST app I added the Amazon Echo app.
Clicking on “next”- takes me to the device discovery and all it tells me is to ask “Alexa, discover new devices”
(the same as going straight the the Alexa app, smarthome, discover new devices" - which I have done before.
Which I did - Alexa does not pick up the WS28128B device.

I tried everyhting, remove all my device from Alexa, remove Alexa from the ST app - no luck.
Add everything back in, let Alexa re-discover my devices.
She get’s everything else, but not the photon.

How do I get her to see this device? - I do not see where you guys are referring to:
"…setup the endpoints the echo can discover.“
nor
”…and check the checkbox for your new photon device to give Alexa access to it."

Please help

On Android you go into the SmartThings app. In the upper right corner there are 3 lines if you press on that it will give you a drop down and smartapps will be a selection. Choose this and Amazon Echo should be one of the apps. Select Amazon echo app and you should be taken to a screen with your current devices in blue. Touch anywhere on the listed devices and it will take you to a device selection menu. Add a check mark next to kitchen rgb and press done at the top. Press next and you will go to the discover devices screen. Discover devices on the echo and you should be done.