[OBSOLETE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

I got my first Sonoff flashed and working last night. 6 more to go. Hopefully will take only about 10 minutes as opposed to the 2 hr learning experience :neutral_face:. I want to say a big thanks to @erocm1231 for putting all this together and keeping on it.

Is there anyone that has tried the low voltage yet? Any idea if that would work with say a garage door opener? I saw someone mention that earlier in the thread. Great idea if possible.

Im also interested in hearing what everyone is using these for. I have 1 controlling a lamp. But since I have smart switches or bulbs that dim I don’t find that as practical. I plan on using 2 others for floor fans for when sleep mode is triggered (because everyone sleeps with a fan right?) I just want some ideas :slight_smile:


I believe he is working on the power monitoring feature, so as of now it can be used as a standard switch.

Update, I have managed to resolve my issue but not sure what is the cause.
I managed to change the name of my device using an Android tablet, but it would not work on an iPhone 7.
Not sure if it helps, just thought it is interesting.

Hmm, that is interesting. I might have to find an iOS device to test that on. Also, you can go into the actual device in the Things list and rename it from there (if the SmartApp isn’t working for you).

@cozdabuch I would love for someone to write up a section for flashing these things. I have been too busy to do it myself. Your outline looks really great. If anyone wants to tackle that project I would be so thankful.

Also, I have been working on the POW. It has been back burnered right now though, but I am close to cracking it. There is no documentation on the power module and when I asked Sonoff for support, they said they would be unable to help. It would be in there best interest, so I’m not sure why.

I am currently working on some bug fixes that have priority.

@Drew650 A few posts up are some instructions on how to make this a dry contact relay. Requires some hackery though.

1 Like

I must be blind :see_no_evil: I cant seem to find anything on making it a dry contact relay. That’s exactly what I’d need to do as the bell wire for the garage door is ~18v (within the Sonoff sv parameters.) I assume make the device type as a simulated button?

Oops, sorry, it was posted in my H801 thread:

1 Like

Thanks @erocm1231

Hi, wonder if anyone can help. Finally got this firmware uploaded to my Sonoff as per the instructions at the top of this thread. But when I power on the Sonoff I get a wifi access point with the name ESP_0 and not “Sonoff” as suggested in the instructions. I tried connecting to it with the suggested password “configme” but it doesn’t connect.

Can anyone help with this? I’m stuck and can’t progress until I manage to connect to wifi.

Don’t know if it’s relevant but the esptool application does not run on my laptop (a black window flashes up but immediately disappears). I ran the “flash” file instead and managed to upload the firmware that way.

This since how it’s supposed to work. I thought the same thing at first, but the flash is the command prompt used to enter the file and the ESP tool is loaded from that.

You may not have flashed correctly because the wifi name should be Sonoff.[macaddress] I believe. I saw something somewhere on the web about their device coming up with that name I’ll try to find it again and repost.

Thank you Drew. At least I know I’m using the correct process to flash the firmware. It would be great if you could find the link again as I really am stuck. I tried removing the firmware (by flashing the “blink” sketch to the sonoff using the Arduino ide) and reflashing it but still no good. I still get the wrong name for the wifi access point.

Do you have the firmware image in the same folder that you extracted the file to?

I did find something, it was using the standard espeasy firmware, the SSID came up with the same yours did and the password would be configesp. If that works then there must be something wrong with the flash. Which I’m no expert as I just did my first one yesterday.

Rather than just double clicking the file, I suggest opening a command prompt as an administrator (in start menu type cmd, then right click and choose run as admin). Then navigate to your folder of choice where the exe and flash file are.

This way you will see status and error message rather than just a flash of a black screen, as it sounds like it’s either not on the right com port or flashing fails for another reason

1 Like

Drew650 yes the firmware is in the same folder as the all the other files I downloaded and extracted. And you were right, the password is configesp just as you suggested. I can connect to the ESP_0 access point with that password, and can then get the sonoff to connect to my home wifi network but I don’t think things are working correctly as the Sonoff is not detected in the ST app (even though I have added the custom app and device type handler).

Cjcharles I don’t think that is the problem. I can flash to the sonoff without issue but once the new firmware is running it does not work as expected. I’ll see what running from an administrator command prompt tells me though.

Thank you for helping guys, but I am still stuck!

If you can join it to your wifi network, try to access it via your web browser at: http://the_device_ip/

Take a screenshot of what you see.

Hmm…could you help me find the device ip Eric? Sorry to be rather inexperienced in this area!

Hi Eric, I found the ip of the sonoff. Here’s the screen shot:

Ok, that looks like the wrong firmware. The good news is that I believe you can go to http://ip_address/update , choose my firmware “Sonoff.ino.generic.bin” and hit the update button.

I think I may have found a fix for the iOS device renaming issue. If you get a chance, check it out.

Ah, thank you Eric, a simple answer! I’ve now uploaded the correct firmware. Do you have the link for the firmware download as I used the link in your first post originally and it would seem it points to the incorrect firmware.

Thank you for this project and helping me out with it. Great work!

Edit: No hang on, I did download the correct firmware and put it in the folder where I unpacked the firmware flashing tool. But by using the flashing tool it seems to choose the wrong firmware. I think my lack of understanding at using these tools is probably to blame here!

Eric, thanks for trying. Tested but it didn’t help, can change it on my android but not on my iPhone.