[OBSOLETE] SHM Delay Version 2.0

There is a modefix profile but no, I am not using the Rboy DTh.

I’m using the Mitch Pond DTH. Since the ULM smartapp which was referenced in your thread before your release of SHM delay 2.0 will properly follow the arming modes of SHM, I assumed your app SHM delay 2.0 would do the same. Am I making an incorrect assumption?

Thank you for replying so quickly.

I don’t own a XHK1-UE keypad so I am unable test with the device. I thought this device would not work with Mitch Pond’s DTH. But if the proper lights work when arming from the keypad…

Please go to the IDE->My Devices->click on the keypad’s name (first column) and post (you can send a PM should you prefer) a screen shot of the fields: data thru current states.

Please send a link to the ULM being used. if this was ethayer’s smartapp used in version 1 of SHM Delay, was the conversion process completed?

1 Like

I will do that. I didn’t use your initial delay app. When I originally tried delay 2.0 I had issues so went back to the beginning and started reading looking for answers, all 1000+ posts. That’s where I saw ULM and loaded it up to see what it would do. ULM and Mitch Pond seemef to work very well together. Based on my testing (and a cursury review of the ULM code at lines 1372) it looks like ULM is reading the alarm state directly and then updating the keypad lights accordingly. I only know enough groovy to be dangerous.

What testing I have done with SHM delay 2.0 and Mitch Pond when my wife is not home has shown that if I arm and disarm from the keypad, the keypad will show correct status. If arm/disarm from other methods, the keypad will not update it’s status.

[Update] Mar 27, 2019, 11:10PM EDT

Enhancements and Changes

  1. Added: Delay profiles may be set to function only when SmartThings arm state is Away or Stay. Default is to function when armed in Away and Stay, as was done in prior versions. Tag: @illumatti @Pantheon

  2. Corrected: Keypad arming status lights not properly set when using ModeFix profile and multiple modes are defined for a SmartThings arm state, then a user defined mode is set. Tag: @oldcomputerwiz

  3. Added: the pound sign # may be used as a delimiter when entering multiple phone numbers into an SMS field. Tag: @Showard

  4. Added: Debug messages may now be turned on or off for modules SHM Delay and SHM Delay Child. Default is Off.

I urge everyone to stay up to date, please update your system,

How to Install
There are two (2) modules associated with this update.

  1. SHM Delay (v2.2.8). Module should be Saved, Published, then Installed with the Smarthings app (must be done first)
  2. SHM Delay Child (v2.1.4) Should be Saved, do not publish or install.
  • Install via the repository (preferred), from the following repo.
    Owner: arnbme (in upper case that is ARNBME)
    Name: SHMDelay
    Branch: Version2

Post Installation
No settings changes are required unless implementing a new feature.



I’ve had this in use for quite a while now, and to be honest, never had a problem other than the odd, annoying double-chime when alarm is enabled or disabled.

Recently I decided to take a peek to see if I could sort things out. I presumed the annoyance was due to router issues, or my android box having a hickup, or lannouncer just being old and generally unsupported…the list goes on.

Apparently not.

Basically, if I use big talker to speak on event (SHM status change) I get an instantaneous stutter-free indication of where SHM is at.

If however, I use SHM Delay to say “You have 60 seconds to exit” or, on entering “you have 30 seconds to disable alarm”, the performance is horrible. Back to the old double-chime, double-speak, delayed or non-materialising spoken message,

If I disable the spoken aspects from within SHM delay, I can instead use BigTalker to announce things perfectly. This does however mean messing about with a few talk rules to allow me to have it say “you have xx seconds to disable”, but this would get triggered only if both (a) SHM is away and (b) the front door has opened.

Any ideas? I’m sure at some point it worked just fine.

Further info - I checked all this out (and verified it to be the case both before and after realising you’d pushed an update in march, which I am now running to the exact same effect).

Cheers !

I totally understand the lost speech message issue as it impacted my system, and I recently found my answer. However, I have no idea why messages from SHM Delay don’t work, but those from BigTalker do. I did not have that issue. Part of the problem may be the ST Cloud is having issues.

You mention you are using LanNouncer, therefore I assume you are using Android devices or Amazon Fire tablets. What I found was the Amazon OS was putting Lannouncer to sleep and I could not stop it.

The solution should also be running the Fully Kiosk Browser, is using the Fully Kiosk Browser Controller for sounds and TTS.

Same basic setup as LanNouner, create a virtual device for each target device, then connect to whatever does the sounds and talking. On my system it never misses a spoken message, because there seems to be a speech queue in Fully, but no queue for sounds.

I hope this helps, because my only other suggestion is to reboot the speech device when things get bad.

Hi, thanks for the reply. I don’t get a lot of free time to be honest, last night was something of a rarity. I’m quite keen to avoid introducing anything else into the mix for now, although I’m sure I’ll have a go at some point so thanks for the heads up.

Just wanted to stress that the issues are actually immediate and 100% replicable. No amount of reboots, restarts etc matter. If I watch the log window inside of lannouncer, the speech / chime initiated by SHMDelay takes around 10 seconds (or more) to show, at which point it actually arrives in duplicate or even triplicate.

The following event generally doesn’t come at all.

Since swapping to using big talker alone. I. E.

Setting alarm on the way out = big talker event on shm status change is “alarm set, you have xx secs to exit”

Reentry = Big talker event on door open (on condition shm status is set to away) is “you have xx secs to disable shm”


Not a flicker of a problem.

I am unable to reproduce your system setup without a huge change to my system. However at one time it was similar. When I first setup my system speech worked well, over time with changes to the Amazon OS things deteriorated.

Now my system is a hybrid, most sensors on Hubitat, keypads on ST, both talking to 2 Amazon Fires, and 1 older Smartphone, all with Fully and ActionTiles. I have BigTalker in Hubitat, and SHM Delay in ST. Prior to switching to the Fully TTS method on HE ant ST, things were dicey, messages lost, choppy, and cut off. Now 100% reliable and messages are queued, messages are no longer chopped off when a new message arrives when device is speaking.

You mentioned not wanting to “change the mix”. The reality of using the Fully TTS DTH is it reduces the “mix” by eliminating an app on the target device. Install the ST Fully device, set it up, change the Shm Delay and Big talker speech device, try it, it it does not immediately cure the problem, change the device back to LanNouncer.

BTW one other thing I did on the Fires that helped and is currently set, completely shutdown Alexa, at a minimum turn off Alexa from listening.

However, you found a workaround, by all means use it.

Ah, righto. You may have convinced me. I have a free bit of me time tonight, I may take a peek. Shall report back =)

1 Like

Look forward to your “report”.

I had one additional thought on your issue. I feel it may be due to SHM Delay issuing commands that are delayed for a couple of seconds. For example: on entry delay it optionally issues a siren beep as a warning shot, that by design is delayed by 2 seconds, allowing people to walk into the home and actually hear it. However, I occasionally hear the beep after disarming my system, perhaps 10 seconds later. The issue is the remote ST cloud sometimes super delays executing delayed commands. Speech messages issued by SHM Delay also have delays. The standard version of BigTalker does not support message delays.

What this means. I feel the Fully DTH will improve speech reliability, but it can’t cure ST Cloud processing delays, internet delays, or local network delays.

1 Like

I’m having problems getting SHM Delay 2.0 installed and configured correctly. I have followed the instructions (publish & install SHM Delay; save but don’t publish Chlid, ModeFix and User). I’ve installed SHM Delay on my iPhone using classic Smart Things. When I go into the app to configure settings, and tap SAVE, I get UNEXPECTED ERROR messages. I don’t see anything like the screenshots above–no options for modefix profiles or delay profiles.

I’ve uninstalled and deleted the apps and have re-run the setup instructions. Still same “Unexpected Error” message. Any suggestions, please??

I understand, it is infrequently reported, and I have occasionally encountered that exact problem on this and other apps. What it seems to be is some sort of cpu processing loop on a bad or missing setting, but the error log does not provide any information.

My only suggestion is to setup and save Global Settings first, before any profile settings. Should that not work, you will have to contact support, hope they don’t say they don’t support user provided apps, then if they try hope they can catch the issue as it occurs.

Edit: please post which profile or information you are attempting create and confirm you are using the Classic (old) phone app

I developed this app on Android and experience has provided some rude lessons that the iOS app fails on something that works on Android.

Hey arnb,

Hope you didn’t take anything I said negatively, I find your posts on this subject pretty informative, I’m taking a peek at the browser etc now. Sounds like it may be a lot more versatile than lannouncer alone, thanks for the heads up!

I can honestly say I was not in any way negatively impacted by anything you wrote. I hope you feel likewise.

I appreciate your positive feed back. I attempt to provide my honest opinion and share my personal experiences with home automation.

It been an interesting and challenging path for me. I’m also aware of how difficult it can be for people new to home automation to set up the SmartThings platform, then jumping into smartapps, Groovy, WebCore, Speech and more. It’s a huge learning challenge.

Agreed, it’s daunting. I’m barely fiddling through myself. I think I picked up that you were in some way mildly offended by something I’d said (wouldn’t be the first time!), but glad to hear I’d simply misread, good good!

I’ve installed the apps and done a quick test, but it was getting late and didn’t want to wake up the love goblin so I’ll have a proper crack tomorrow. On first look it’s easy to essentially swap out lannouncer for kiosk/etc, which I’ve done. Can’t see how to use smartthings events to trigger a sound.mp3, but haven’t had much to play with tonight, I’ll have a proper read later on

WebCore is the answer. Use the FKSB device’s beep, chime or playSound command

Hi arnb,

I have everything setup but running into a couple of problems. I am using ActionTiles to arm and disarm my alarm. The issue I am running into is that when I enter my house while its on away mode the alarm goes off because of my motion sensors. I also set it where it ignores those sensors but it still goes off. Am I doing something wrong?

Hello. I’ve spent hours trying to understand and follow these instructions to install my IRIS Keypad and it still isn’t working. I’m using the newer smartthings app on my phone. I’m not a developer. I know very little about writing code, and following these instructions is making me feel like a toddler. I’m usually really good at fixing things, following along, and getting things to function. I really want my keypads to work. I loved being able to press in a code and turn my system on and off. I liked that it beeps when my door sensors are triggered, acting as a deterrent prior to the siren turning on. Is there an easy button somewhere or maybe a set up IRIS keypad for dummies? I’d really appreciate it. Thanks. :blush:

Assuming the motion sensor is defined in a delay profile, it must be removed from Smart Home Monitor. Please confirm the settings.

SHM Delay works only in the Classic (old) phone app.

Hang in there, ask your questions. Everyone on these forums, including me will do our best to help getting your system up and working.