[OBSOLETE] SHM Delay Version 2.0

I doubt it.

WebCore, maybe. Not sure.

1st. Arn: thanks for the SHMDelay. It’s great.

Having said that, I’m having a minor problem that I hope can be solved with a setting. I am using Smartthings Classic, SHMDelay V2, Iris Keypad V2, and Pond/Cornelius CentraLite/3405-L V2. All things are working great, except I cannot figure out how to turn off the Push Notifications for Arming/Disarming the Smart Monitor Security with the Iris V2 Keypad. I have tried multiple settings and combination of settings to get this to stop, but I always get a push when the Alarms are Armed or Disarmed.

Any help would be appreciated. Thanks, in advance, for your assistance. And, thanks again for all the hard work on SHMDelay. It’s amazing.


I do not remember coding anything like this in SHM Delay, and a review did not find any settings that would do this, unless a specified contact sensor is open when arming.

However, it is possible to have a user pin code send a message when it is entered on a keypad. This could be set either as a Global setting or a user pin override. If is is not this, then perhaps it’s another smartapp, or a WebCore piston causing the issue.

Should you need additional assistance, please post the exact message being received.

Thank you for the positive feedback.

Screenshot of Global Settings for pin messages follows.

Hi Arnb,

You seem to be helping a lot of people with their keypads and I was hoping to maybe get some help. I’m new to ST and getting into it now since Iris is shutting down. I have a ST hub 3rd generation and a V2 Iris keypad. I’ve read multiple threads, including this one and have spent countless hours just trying to get the keypad to pair and I can’t get it to pair correctly.

In IDE, I’ve installed the device handler you’ve recommended (mitchpond), and I’ve installed all the smartapps you’ve recommended (published SHM Delay V2, installed but not published the other ones: Delay Child, Delay ModeFix, Delay User).

Now when I try to add the keypad, I can’t get it to pair. I hold the tamper, put in one battery and see the network light blink twice slowly. In the ST classic app, i search for new devices, it finds it and I click save. The network light on the keypad blinks rapidly, and I press and release the tamper button (hold it for 1 second before release). Then I wait…and wait…and wait…The network light never goes solid. I’m literally right next to my ST hub. I will retry and remove the device in the ST app, take out the battery, repeat, and I’ve done this probably 15 times. I always end up with a rapidly blinking network signal. I’ve tried hitting the tamper button twice after the network light blink rapidly, but that doesn’t seem to help either. Please advise. Thanks in advance.

Hi! At the moment I’m quoting, it might help to enter a random 4-digit code and press ‘Arm’. Don’t know why, but this has done the trick for me when pairing the last ten times. The keypad will do some angry beeping, after which it will be properly paired. Don’t forget to add the keypad to SHM Delay, preferably directly after adding it as a thing.

1 Like

I understand, I’ve had my own issues getting these devices to properly pair.

This thread link has suggestions.

Thanks for a great app. Will be happy to make a donation. Your documentation is superb, so it was easy to get it all working. The hardest part was finding an Xfinity 3400 keypad. They seem to be unavailable and I only found V2 on eBay. V3 has disappeared. Lowes has dropped Iris. That’s probably been mentioned in this thread.

One question: in global settings I don’t seem to be able to log pin entries on a keypad but suppress notification pushes. The sliders under the log pin entry slider are always on. I can turn them off but they revert to on the next time I open global settings and the behavior is always on, i.e. I always get push notifications.

1 Like

Thank you for the positive feeback.

Yeah you right! It appears the Centralite keypad is no longer available on Amazon, and the Iris is about gone, leaving sites like ebay and craigslist as the source for these devices. The keypad also no longer shows in the Centralite store

I just set the ‘Log Pin to Notifications’ slider on and off with my Android 9(Pie) phone and it functioned normally. Please insure the Save button on the top right is tapped/clicked after tapping/clicking ‘Next’ in Global Settings or it won’t update. Should it continue to fail, it’s likely a Support issue.

Unfortunately, on my iPhone XS, I did indeed select “Done” in top right corner after sliding “Send Pin Push Notification” to off, and then “Save” in the top menu. The changes aren’t saved.

This worked perfectly! Thank you so much KoreT! Saved me so much time. Paired no problem after I did this.

1 Like

I apologize, but I am unable to do anything (AFAIK) to fix this.

I have some suggestions:

  1. Contact support, report the problem. Probably won’t get you where you want to go, but it’s worth a try.

  2. Try overriding the options in the User (Pin) Profile by setting ‘Override Pin Msg Defaults’ to on/true, then setting the override options (off/false) on the following screens.

  3. Give the code an ‘attitude adjustment’, by changing the logic and killing the pin messages.
    In module SHM Delay version 2.2.6 at line 1560
    if (globalPinMsgs)
    change to
    if (1==2)

  4. Edit. A wild guess, In module SHM Delay version 2.2.6 at line 302
    required: false, defaultValue: true, submitOnChange: true,
    required: true, defaultValue: false,

Please post any results.

Same problem here, I’ve sort of solved it by turning off logging pins (correct or bad) all together. The slider for ‘Send Bad Pin Push Notification’ isn’t working on an iPhone or iPad. I’ll try your suggestions asap.

[Beta Test Release For Apple Devices] Feb 12, 2019, 14:45 EST

Install only on Apple devices where sliders for pin messages are not working. Tested OK on Android device. No logic changes, some settings changed from required false to true

How to Install

  • in IDE Smartapps, change source code options for SHM Delay to arnbme/SHMDelay/beta, or get code at this link

There is one (1) module associated with this update.

  1. SHM Delay (v2.2.7). Module should be Saved, then Published
  • Install via the repository (preferred), from the following repo.
    Owner: arnbme (in upper case that is ARNBME)
    Name: SHMDelay
    Branch: beta

Post Installation
When using an Apple device to maintain SmartThings, adjust global pin message settings and report back if changes remain after updating

Tag @Journeymnn

Hi arnb, looks like you have done a great job here. My Iris Keypad (3405-L) arrived this afternoon and after much reading, I embarked on setting up my ‘delayed Smartthings Security’ system.
So further I have published the Delay SmartApp, installed the (x5) others and can see my new keypad on my mobile. I have been running through the (mobile) app config settings but unable to create a New User Profile. “Sorry, but there was an unexpected error” in a red bar is all I seem to get.
Any ideas, tips or hints?
I looked through the string above but no one else appears to have encountered this issue. Thanks, Darren

Unfortunately, I have confirmed I am running 2.2.7 and the behavior is the same: if Log Pin entries is On/True in Global Settings, Log Pin to Notifications and Send Pin Push Notification will always be on regardless of user setting.

If Log Pin entries is set to Off/False, it will remain so until turned on again, i.e. exhibits proper behavior.

This appears to be only an issue for the app running on iPhones, based on arnb’s comments.

More insight on v. 2.2.7 beta. The “Send Pin Push Notification” (call it “A”) slider will mirror the slider for “Send Bad Pin Push Notification” (call it “B”), but not vice versa. So if I set “B” to Off, “A” will also be saved as off. “A” does not update when “B” is changed, but returning to Globals after saving, both “A” an “B” are off.

If I slide “A” to off when “B” is on, “A” will be on when returning to Global settings, even after a save. Hope that helps.


Made a minor change. Please reinstall 2.2.7 beta and retry.

If this does not work, try using the user profile pin override and let me know if that works

This issue was reported a few times. No real answer other than to remove and reinstall the app and modules. If you want try getting the actual bug, fire up IDE logging prior to the next attempt at creating a User Profile. It should not matter but insure you have at least one valid Delay Profile .

Hi arnb, I have created a valid delay profile (which sits at the top of the page).
I’ll try running the log from IDE while trying again.
Thanks for coming back. I note your Paypal details are available and will provide a contribution when I get this all up and running. :grinning:

1 Like

Please try saving the SHM Delay User module prior to the next attempt at creating a user profile.