[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

OK my settings were like that. But I am on the Beta firmware team, and an update didn’t take. Now they did another update and it is working fine. Thanks.

I’m also on Hub Beta and received two messages for two differing versions. Now on 20.14.
So what’s working, keypad, hub or both?

OK the keypad is working, it counts down and I armed partial with no problems. Yes two different versions of firmware in two days.

I completely uninstalled all the smart apps and DTH. I also unpaired the Iris keypad. I reinstalled everything making sure I had the latest versions and correct settings etc. I am still not experiencing an exit delay on ArmStay. I am also not experiencing exit and entry tones and nothing appears after “Updated:” in the device view.

I want to verify a few things:

-Should I be choosing “Centralite Keypad” in the IDE device type for this Iris keypad?
-Is it possible that my keypad needs a firmware update?
-Would I possibly get better results using SmartAlarm instead of SHM?

Yes, that’s a requirement. The keypad was manufactured by Centralite. BTW I’ve read someplace on the community site that older Iris keypads don’t work with ST, must be newer version.

Could be, but from what I understand not possible

No idea

That’s an indication that routines are not set in Keypad modue Globals, or the routines are not setting ST state and SHM mode. See instructions for Keypad Troubleshooting and How to use this app with lock manager in SHM Delay instructions

When you pair the keypad, if the DTH is installed correctly, the DTH will be automatically selected for the keypad, no need to manually select it.

It’s possible to do a firmware update using an Iris hub, but as far as I know, the only firmware update available is just a fix for battery life (There’s an issue with older firmwares where the lights stick on). Shouldn’t affect the pairing at all.

Since you’re not getting anything in the Updated: field, I’d more suspect that the keypad isn’t fully paired. This keypad has a 2 stage pairing, one to get it onto the Zigbee network, via “Add thing”, then the Zigbee alarm enrollment, when it sounds like isn’t complete.

If it’s on the network, but not enrolled as an alarm zone, it’ll report temperature and battery life, but won’t get status info, won’t send PIN / arming data, and won’t ack the arming/delay tones.

I’d suggest you remove the keypad from SmartThings, factory default the keypad, then re-pair.

After the factory default, they keypad should go into pairing mode (slow double-blink of the network light on the front). Once it’s paired to SmartThings (via the SmartThings add thing button), the network light should blink quickly, continuously.

At this point, you need to press and release the tamper switch on the back of the unit, to attempt to enroll it for alarm functions. I tend to press the button twice, for good measure, then wait 2-3 minutes, until the keypad beeps, or the network light goes on solid (It’ll only be on when the keypad is lit via motion). After the beep, and the network light is on solid, arming, disarming, and the entry/exit beeps should work.

1 Like

@zcorneli Thank you for your post about pairing a keypad with SmartThings. It made me remember all the trouble I had about 5 months ago getting my Xfinity keypad functional, and that sometimes it is truly a hardware issue causing the problem.

I appreciate the work and efforts of people like you, and may others expended getting the Iris/Xfinity/Centralite keypad operating with ST and SHM.

Perhaps one day ST will add keypad support and exit/entry delays, but my expectations for this are very low.

Zack I think you are onto something. Can you remind me how to factory default the keypad? Is it just simply removing from ST and pull the batteries?


I found what I think is the factory reset process which is basically putting the keypad back into pairing mode. I removed both batteries and waited thirty seconds. I put one battery in while holding the tamper button down. After 2 seconds I released and the keypad was in pairing mode. I added as a new thing and the status light began to blink continuously. After that I pressed the tamper switch again. It immediately beeped and the status light went solid. I put in the other battery and closed the battery cover.

It is still behaving the same way. It arms and disarms but I am missing some of the previously mentioned functionality. Did I do something wrong?

This PDF is for a Centralite keypad , and should likely work with the Iris also manufactured by Centralite. Scroll down to "Troubleshooting"

Correction: here’s the Iris Factory reset

The datasheet described the same process I used. I find it hard to believe that I have a hardware issue when I get some exit/entry delays and not others plus I am getting sound out of the unit in some contexts. Seems like if the hardware was failing it would be across the board. It appears I have hit a dead end… I guess I will have to live without exit/entry tones and no exit delay on ArmStay.

If it’s intermittent perhaps a Zigbee signal strength or interference issue. How far is it from the hub?

Try moving the device near the hub, then arming in ON mode.

Hopefully that works, I’m out of suggestions.

Can you please tell me the Owner, Name, and Branch of this DTH and Apps? I want to add it to my GitHub Repository Integration.

I completely appreciate your help Arn. The device is about 7 ft from the
hub in the same room (i.e. no obstructions).

Then perhaps interference. Are the HUB and Wifi Router separated by at least a few feet?

What’s really odd is the Updated field is not showing anyghing. That’s a sign of a software failure. Event if the Keypad app routines were not coded, it should show with a status of ExitDelay in the ST app device view when arming in On mode. If not the Keypad delay time may be 0.

I realize this sounds odd but go into Lock Manager Keypad routine and save all the profiles, then save when it returns to the Smartapp start page. Sometimes this has worked for me when things get “weird”.

It’s in the first post of this thread.

Thanks for the help.

@zcorneli YOU ARE MY HERO!

Thank you so much @arnb for your INCREDIBLY patient help. (You are ALSO my hero!)

This was the problem. I hadn’t done the 2nd part of this step. The keypad came with no instruction book and where I looked it up online it didnt mention (or i missed) that 2nd step.

So I did what you said here and factory restored it. redid the setup. including the VERY important second step and BAM. everythings funcitonal. Works like a charm includingetry/exit delay.

Again, and for real, @arnb… thank you SO much for your help in trying to chase this down. even though it ended up not being the thing, your dedication to trying to help folks get their problems sorted out is really what community is all about!

(I’m just arming and disarming my system repeatedly and having a blast :D)

1 Like

So I had some success. I decided to switch the “On” profile to the one that sets the mode to Arm Stay instead of Arm Away so my wife could get some functionality out of the keypad. My thinking was that at least I was getting exit delays when pressing On. (I also moved the Arm Away profile to Partial). Somehow that starting giving me exit and entry beeps??!! I am also finally seeing something in “Updated:”. So for good measure I deleted and recreated both of those profiles and switched them back to Away = On and Stay = Partial.

Away/On works as expected: Entry and Exit delays and beeps. However I am still not experiencing an exit delay on Stay/Partial. (I am getting beeps and an entry delay).