SmartThings Community

[(OBSOLETE See 1.1.10 or later) 1.1.8 10/11/16] Big Talker - Talk when events occur

Well I am only running the develope and getting dual speech. Any ideas.

UPDATE: The double speech is from Big Talker as I have an automation that does not use Big Talker and it speaks once.

v1.1.9.a4.1

Is anyone having trouble with GROUP 3 in the contact section of the app?
I have groups 1 & 2 working fine, anything I try to config in group 3 does not work - no notification.
Live log:

OK here is the proof of the double speak.

The only way I am able to reproduce this is if I put the same switch (or other device) in 2 different switch groups (or other device groups). The switch on/off event is then triggered in both groups. Can you please check that you do not have the same switch listed in 2 event groups?

Also, If you check the event groups and do not have the same switch in more than one group, then could you please turn on debug logging so that I can see the debug messages which will give a bit more insight.

To turn on/off debug logging: Open the BigTalker SmartApp > Configure Defaults > scroll to the bottom and slide the “Enable debug logging” switch to the On position and then press done.

I think I have the situation solved.Yesterday something happened to the ST database and all my GitHub integrations were removed. When you asked me to turn on DeBug, I thought to myself “I did that”. So I went into the app and toggled the switch and Big Talker froze. I quit the ST IOS App and repeated this crash again. So I went to the IDE and checked the code against the copy on my Mac, and found the code to be screwed up. Hard to tell exactly what happened, but I think the database problem affected the code. Just a guess. But anyway I replaced the code and debug went on. I looked into the Big Talker and everything seemed Ok. Tomorrow morning at 9:00 I will test again, but I think it will be OK. By the way support fixed the database and got everything back, and had me remove some entries as they nsaid it screwed their system up.

1 Like

OK, it still doesn’t work, still doublespeak. Here is the debug log:

More info. I am using Media Renderer (Connect) to find my speaker, Those are the only apps.

When I use CoRE to send a speak command only one iteration is spoken.

It seems SmartThings is sending 2 ON events for your switch device, the second one being a few seconds later than the first one (9:43:24 and 9:43:29) then the same on the OFF events (9:44:02 and 9:44:03).
Somehow perhaps BigTalker is subscribed to the same switch twice. Which Switch group is this switch installed in? Is it in any other switch groups or other device type groups within BigTalker?

I only have three things setup. Switches, Thermostat, and Water detectors. Below are three screenshots showing my switch configuration.This is crazy.

I am STUPID !!! I was looking in the wrong place for the problem and it has been staring me in the face all along. Big Talker is not the problem it is how I had Alexa set up. I had a room in Alexa called Family Room and in there I had one of the Living Room lights. While Big Talker was set up correctly Alexa which I use to turn on my groups was wrong there was the problem. Sorry for all the hoopla, I feel so DUMB.

1 Like

Thanks for the update. No such thing as a stupid question. Was just trying to help get to the bottom of it. I did check code and run tests here a few times just to be sure I didn’t miss some glaring bug in the logic. Glad you figured it out!

It was just amazing, I have gotten so accustomed to getting things done by using Alexa, I didn’t put that into the equation.

You can send any or all of your BigTalker phrases to your AskAlexa queue if you like now as well (If you’re using AskAlexa, and if not, you should try it out), just add %askalexa% to the phrase… It’ll be stripped out of the text spoken but sent to your AskAlexa message queue. AskAlexa will then play the message back when you tell it play your messages along with the timestamp. “Alexa, Tell SmartThings to play my messages”. I could see this being especially useful to people using SmartHome monitor, you could send notifications to AskAlexa when your states change between armed/disarmed modes and then you have a timestamp in your AskAlexa message queue

1 Like

I started installing Ask Alexa and got to almost the last portion and something went wrong. I tried twice and finally gave up. My wife complains about these basic functions, so I don’t think I will try again. I love what I have with Big Talker, and I have already filled the 3 slots. Still eventually will need more slots, when you get to that. I know there are loads of suggestions from other users, as I have been reading the posts.

It’s coming… I promise!

Version 1.1.8 and prior of Big Talker are now obsolete. Please update to 1.1.10.
Further discussion should be directed to this thread:

GitHub: https://github.com/rayzurbock/SmartThings-BigTalker

Fantastic!!

So now I’m showing the x through big talker in my smartapps. Never done this before but what is the method to update the program. I’ve navigated around ide and fumbled through some things but just don’t know how to do this. I can’t imagine I have to delete and re install.

Just update from repo and the X will be gone.

1 Like

If you do not have Github integration enabled, you can grab the latest code from Github and copy/paste it over your existing code for BigTalker. You then hit save and then publish for me.

Sometimes I have to kill the SmartThings app and relaunch it on my phone for it to recognize changes faster.

I use 3 devises for all my changes lol. Laptop tab and smartphone. One devise will do things that the other won’t, one devise will work at work but not home. Copy and paste on my tablet isn’t very good. Plus like your self my time is limited. I’m juggling devises while trying to program. Step by step, now lanouncer isn’t working seems like I’ve had to uninstall and reinstall twice now.