[OBSOLETE] Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)

This happens sometimes for some people so you’ve probably done nothing wrong.

What @TylerDurden suggested - manually changing to the right DTH while logged into your IDE is the correct way to “fix” it. Also, make sure you have the correct DTH added. What is the model of your Xiaomi device (normally listed on the battery panel)?

@TylerDurden that worked, thanks. Silly question but there’s no lux sensor in the Aqara Xiaomi motion sensors is there? For some reason i thought there was but playing around with them today, it appears not.

Do you mean the human motion sensor or the vibration sensor. The former (https://www.gearbest.com/alarm-systems/pp_659226.html?wid=1433363) does have the lux sensor. The vibration sensor (https://www.aliexpress.com/item/Xiaomi-Aqara-Shock-Sensor-Mijia-Aqara-Smart-Motion-Sensor-Vibration-Detection-Alarm-Monitor-for-MiHome-Aqara/32916169237.html?spm=a2g0s.9042311.0.0.18604c4d8Zls1x) does not.

I see a lux reading when I view my motion sensor in the Smartthings app.

Hello All,

I am hoping I’m posting to the right thread.
I’m super new to Smartthings and this forum, so might be missing something very basic. I’m hoping this is the place where someone can point me in the right direction.

I have a Smartthings Link plugged into an Nvidia Shield. The hub says it’s online. I have 8 Xiaomi Aqar door and window sensors in various areas of my house. All can be paired relatively easily from their doors and window locations using bsprangers device handlers, and they all work fine for about one hour. Then they become “unavailable” until I pair them again with the Smartthings Classic app. It doesn’t seem to be a range issue since all pair again with relative ease. I also have two wemo plugs and one wemo light switch that do not get disconnected from smartthings.

In some post somewhere I read that the problem may be that I’m using a Smartthings Link and buying a v2 hub would fix the disconnect problem. But now they have a cheaper v3 hub. Except I’m not sure if the v3 hub would fix the disconnect issue and the two different Smartthings app might further complicate things.

Would buying a v2 or v3 hub fix this disconnect problem?

Thanks for any help and tips!

I originally got into SmartThings with a ST Link for NVIDIA Shield, and ran into the same exact problem. Long story short, Xiaomi devices won’t stay connected to the Link because of its different firmware from the v2 hub. The issue lays on the side of the Xiaomi devices because they don’t conform 100% to the Zigbee mesh networking protocol.

However, most people seem to have relative success with Xiaomi devices connected to a v2 hub, but there are pitfalls where the use of Zigbee-repeating devices are concerned, as you’ve heard in your original thread asking about this.

I have a v2 hub myself, and the jury is still out on the v3 hub playing well with Xiaomi devices or not, so I will defer to any people on here who have tried it.

However, as mentioned in my other reply, you could also try getting a Xiaomi Gateway Hub for your Xiaomi devices and integrating it with SmartThings using this solution:

I should also mention that Wemo plugs and switches are WiFi-based, so that’s very different from Zigbee-based devices used with a SmartThings hub solution.

Thank you! Sounds like my best bet at this point is a v2 hub unless someone else can comment on the v3 hub. I’m afraid I don’t know how to begin to understand the Xiaomi hub integration (even with the link which is much appreciated), so I think I will leave that for later in case the v2 hub doesn’t work.

Thank you again!

Its a long shot, but reconnect your Xiaomi devices and keep them by your hub until regular batter reports are coming through, then try move them. I’ve no idea if it works with the ST Link, but its been more reliable for me with my v2 (UK).

If we are talking about https://www.aqara.com/en/motion_sensor.html then yes there is a lux sensor in it. However it only reports when motion is detected.

I’ve also found that while the reading is capable of gradually dropping down to 0, once it gets there it isn’t so keen to go back up again and doesn’t show changes until you get to about 50 lux. So I find it pretty useless in that respect.

You do have to make sure you have the model you think you have as there is a similar looking earlier model that might not have the lux sensor (sometimes advertised under the Mijia brand). The Aqara one comes with a stand, is branded Aqara on the top and has the model number RTCGQ11LM, though I have a suspicion I’ve seen something about there being a newer model around now. You also need to make sure you have the right device driver (i.e. the one that says Aqara in the name).

I’m happy to report that my issue seems to be fixed by the v2 hub. So far none of the Aqara sensors have dropped off and the Alexa integration works pretty well. Now I just need a Nest thermostat and the heat and AC will be automatically shut off any time someone opens a window! :slight_smile:

Thank you to all of you for the help!

1 Like

I’d certainly go along with pairing them next to the hub. They still pair when they feel like it (though I haven’t had one not pair yet) but they do seem more reliable. I’d like to think it is a case of preventing them connecting via a repeater that they don’t work properly with.

I’d say i agree, but with regards to repeating, anecdotal evidence from yesterday…

One of my Xiami Aquara motion sensors reported as unavailable - clicking it’s button did nothing - i tried this a number of times.

I then noticed one of my Zigbee Smart Bulbs in the same room was unavailable, and when i corrected that, and pressed the Motion Sensor button, it rejoined the network.

This suggests the motion sensors was previously repeating through the bulb successfully.

The bulb is an Osram Lightify E27 (UK). Details in Smartthings:

  • manufacturer: CentraLite
  • model: 3200-Sgb

bought seven of the window sensors, and they are incredibly temperamental. 4 have paired, 3 refuse, I’m at a loss as to why the other 3 are struggling. Gave up last night but will try again when I get home tonight

Sorry for the delay, I haven’t been ignoring your request but I was having a problem with my live logging, it wasn’t working. I opened up a support ticket with ST and just got a response that they were having an outage over the weekend and it should be restored.

Just checked it and got the log messages for you:

f66c85df-6efd-419b-9ac6-38291e352472 12:26:07 PM: error java.lang.IllegalArgumentException: Needs to be string or int, received null value: null @line 482 (changeSensitivity)

f66c85df-6efd-419b-9ac6-38291e352472 12:26:07 PM: error java.lang.IllegalArgumentException: Needs to be string or int, received null value: null @line 482 (changeSensitivity)

I can attest, at least through personal experience. I have a temp sensor. When paired away from the hub (in another room), it lasted about a day, then went offline.

I then reset it, and paired right next to the hub, waited for battery reporting, and moved it to its proper location (about 20 feet away, out the front door). It has been reporting regularly for a week now.

FYI to Xiaomi Aqara device users:

Thanks for that. The initial sensitivity level isn’t getting set up correctly. I will add a routine which will set it to “low” if the initial setup didn’t happen yet, by going into preferences and pressing save. I’ll post when the new beta code can be grabbed. Keep in mind I still haven’t confirmed whether the command to change the sensitivity setting is actually working, though.

I’m hoping the high sensitivity setting isn’t working yer! As in my tests so far, I’ve found these sensors aren’t as sensitive to tiny vibrations as the SmartThings multi sensors.

I have a few of the single wired wall switches installed (no neutral version). Interested to know if the button DH in this repo will work?


Currently using this DH

If anyone is in the Calgary area, and wants to pick up two of the aqara water sensors and a motion sensor (at cost) - send me a PM.

I have a connect hub (not the V2) and I have given up trying to get these things to stay paired.

Hopefully they fixed the issues as the firmware is rolling out soon