[OBSOLETE] Lock User Management (LUM)

Okay thanks, that was very useful, not a scenario we anticipated not having any routines in the system. By default ST comes with 3 routines, I’m assuming you’ve deleted them. Will put a check for it.

Can digestive help? I’ve got the DH and app installed. I am able to use the app to function the lock however when i go into the smart app portion it will not program codes. I’ve got three codes programmed according to the app but they are not working on the lock. The only codes working are the ones that were programmed by the previous app I was using.

I’ve turned on the mode that only programs one code every 60 seconds but it still isn’t working. We are going out of town in a week and I need to have this working for someone checking on our animals.

Delete all the codes from the SmartApp (remove all them all, hit done) and start over. Make sure that the lock is communicating perfectly with the hub, any communication errors are not retried by the ST platform.

Hey man. Thanks for the feed back. I’m assuming part of the problem was having the previously used lock manager still installed. I uninstalled it. Then removed this app then installed again and we are good to go. Thanks for your help.

1 Like

Yep, these systems are yet designed to have multi-tenancy unfortunately. There should never be competition for lock resources (either through multiple apps or manually). You should only use one app or do it manually for reliable results.

I haven’t updated my app in a long time, i updated the device handler and the app…all is working perfectly. Great work, as always!

1 Like


Looking for some guidance here (V1 Hub if it matters)

I’ve been trying to get my locks to utilize the code you implemented with the keypad Schlage button running of Routines / Modes but have been unsuccessful.

What is strange is that all 3 locks program / erase codes as they should. I assume this is because this a sent signal from ST (vs. a sent signal from the lock); however, the auto-lock feature has always been spotty and as I said, I’ve yet to get the Routine / Mode on lock working.

I’ve reset all 3 locks (by completely removing and adding them back to ST) and have beaming repeaters right beside all of them in my G.E. switches. My entire house has G.E. switches in fact. I also have IRIS Zigbee contact sensors which I’ve never had issue. For certainty I also installed Zigbee repeaters.

I can get auto-lock to work if I build a rule in CoRE utilizing all the same hardware…that works fine and is okay by me if it works there vs. through your app…but curiosity has me by the tail.

The Routine / Modes on locking the Schlage button is what I’m after. I would really like to figure out why I cannot get this to function. I can obviously substitute this functionality with presence…so again, not a huge deal…but now I’m so curious I cannot stand it.

The only scenario I have not covered is to uninstall / reinstall the app, but before I did, I thought I would reach out to see if you had any suggestions? If uninstalling, should I clear codes 1st then uninstall or will that matter? I would think that it would just write over top of what was previous just as it does in normal function.

Thanks for your time

Try this simple thing. Reboot the hub and then repair the z-wave network.
That usually works for us here in the lab. It’s a timing thing. If you open
live logging you’ll see what I’m talking about. The command is sent to the
lock but it never reaches it.

1 Like

Will do so this eve and report back when I’m able.


If selecting the Schlage button on the keypad, wouldn’t the signal then be coming from the lock to the Hub?


Did you mean reboot through IDE or physically unplugging the Hub then running z-wave repair?

Yes but the timing. If the command and response is too quick then it
doesn’t seem to be reliable. Rebooting the hub helps and so does repairing
the network

Oddly I have found the reboot command may not always reboot the hub. So when it’s bad I physically unplug it

Working on this as I type this.

If I am able to control the lock from ST…meaning lock and unlock, program codes, etc…is it safe to assume I am properly connected?


Front door works like a champ with running Routines and whatever else I program with lock / unlock.

It’s within feet of the Hub.

Back door testing shows that everything but the lock routines / actions work. I get notifications of the lock being jammed when I duplicate that scenario, lock / unlock notifications…everything but the lock / unlock routines.

It’s about 40 ft. away with 5 G.E. switches between the Hub and the lock.

I’ve removed the lock, reset the lock, added the lock back, reset the Hub, z-wave repaired the hub countless times, etc, etc, etc.

I’m at a loss…everything works but that.

They’re actually 2 different things. I’m talking about the network and hub
health. If the network is degraded or not optimal it will still work but
some commands may be lost or delayed. That’s when the issue with relocking
etc crop up. Also open live logging and ensure that the ST platform is
calling the methods to relock and take actions (scheduler isn’t failing).
Most of the times a hub restart and network repair improves the network
Health and things work as expected. I did make a suggestion to the
engineering team to detect degraded network / loss of packets / commands
and initiate an automatic repair. Let’s see how far they take it.

If 1 lock works great and the other 2 do not than I can only assume that it’s a distance thing no matter how solid the z-wave network and how close the beaming device.

I just cannot seem to get that function to work.

EDIT: I may have it licked. I got secure inclusion while it was in place…we’ll see how it goes once it fully programs

1 Like

Now that’s inovative troubleshooting method. I am not sure if I am ready to start licking my failed devices…buahhajaaa. Hope it worked for you…

I sooooo wanna be derragatory to furthen the humor; however, I shall refrain for the sake of forum goodness lol

1 Like

Are there plans to allow us to trigger a CoRE piston as an action to the user specific unlocks?


So I was able to get secure inclusion on the basement door (that I needed the most!) with the lock in place. This morning, when leaving and pressing the “Schlage” button on the keypad, my “Goodbye” routine ran as programmed…WOOHOO!

I was also able to get secure inclusion on my detached garage lock by removing it and taking it within 2 feet of the Hub. Strange how one could be so far away and secure include and another had to be practically on top of the dang Hub but whatever.

Unfortunately, once mounted, I could not get the the routines / modes to work for this lock. It will exclude in place but will not secure include in place. I have 2 G.E. switches right beside this lock that do just fine…it must be a distance thing for the beaming to work.

Thanks @RBoy for your time and suggestions. If you have anything more to add please feel free

1 Like

Updated to 4.6.5 and for some reason one of my temporary codes isn’t setting anymore, I have a user that I want to give access to house only on Thursday and Friday. Today it wasn’t set for her. The delete part worked as she didn’t have a code on the lock. What’s the best way to troubleshoot this. Live log isn’t showing the slamming of Codes to the lock like it used to.