[OBSOLETE] Lock User Management (LUM)

Since updating to this new Smartapp I am no longer receiving notifications (push) on unlock for my different users.

Yes that’s correct, now the notifications have been enhanced to allow configuration per door if using multiple doors so you would need to verify your settings and reconfirm them. Please see the release notes, quoting:

Please note this version has simplified the user interface, so please CHECK and VERIFY your notification settings. These are now on the first page under door lock/unlock actions.

I seem to be having an issue with the one time codes. I will set a one time code and 20 minutes after its first used it still is working. Any idea on what I may be doing wrong? I have the latest app and device handler

Couple of things to check:

  1. Your hub is on the same time as you. You can verify this by looking at the IDE Live logs, it will publish the hub time.
  2. Verify the date/time (typos etc)
  3. If the above two are done correctly then the ST scheduler is broken in your setup. ST has been facing problems with the scheduler not firing. See your logs and you should see the scheduler run every 5 minutes for housekeeping. If you don’t see it then it’s broken and you’ll need to report it to ST support.
  4. If you do see it running, see what the housekeeping logs say about that one time code (it will indicate the status, expired, etc etc).

Scratch the above, sorry, I read expired code instead of one time code.

Just open Live Logging in the IDE, it should do housekeeping every 5 minutes and just check what is says about the status of the one time code. It should mark it expired as soon as it is used.
It will be deleted the next time housekeeping runs which is every 5 minutes, so if housekeeping isn’t running then you should contact ST support since the scheduler on your account is broken. We’ve tried to build in a backup for the scheduler which kicks in every 20 minutes to kickstart the housekeeping task but again if the main scheduler is broken it may not help.

EDIT: So I was able to replicate your issue once and the root cause was the ST scheduler had failed, so the housekeeping wasn’t done. This problems with ST scheduler has been happening of late. As soon the scheduler kicked on it removed the code. Please report to ST support that you’re facing scheduler timers dying. They will investigate it further. @slagle just a FYI

Ok. Thank you for your help. I checked the live logging and it is working correctly showing that the code is deleted as soon as it is used. It seems to be working now though. Not sure if I was just having a glitch or not. But thank you again. Great app btw!!!

Ok maybe I’m wrong. When I have live logging open then it deletes it immediately after the one time code is used. If I do not have live logging open then the code still works after the one time use. Not sure if it’s a problem with the hub or if I need to have the logging open all the time.

It’s an issue with your instance of the platform, it doesn’t appear to be calling the scheduled functions which actually delete the code when you Live Logging is closed. Now I’m not saying that opening/closing Live Logging is the issue, it’s just a coincidence that when live logging it open the platform scheduler works fine and when it’s closed it’s having trouble with your instance. The scheduler problem has been known to ST engineers and they appear to be “working” on it. Please report the issue to them so they can look into your account and hopefully fix your scheduler issues.

@RBoy ever since I upgraded to 4.6.3 I am having an issue with actions based on lock/unlock. I used to have the lock turn on a light when the lock was unlocked. That option does not seem to exist any longer. When I go into the menu option labeled “Click Here To Define Actions When The User Lock/Unlocks The Door Successfully” all I see on that menu is this (see screenshot).

It’s an issue with your phone connection to the ST servers. Looks like they are running slow and probably timing out while rendering. You should report it to ST support.

Here is what I’m seeing (after a loading delay):

jesus man, ST Cloud is awful. The easiest fix is to deliver what they promised - local IDE. instead we get this half ass stuff with smart lighting. There is a huge market opportunity for someone to come up with a simply hub thats ST like with local IDE and they would win hearts and minds of everyone here.

Animus on Kickstarter. Runs groovy

1 Like

Sucks that animus will not be supporting zigbee, but seems to be really cool.

@RBoy I left that page open waiting for it to load and it never did. I deleted and re-added the smart app and it still doesn’t show up. Is there anything else I can do? I need it to disable my alarm and turn on that light, but without getting to that config screen not sure hoot do it. It worked great prior to upgrading to 4.6.3 so this is definitely an issue after I upgraded.

Are you on the latest version of the ST Phone app? Are the other pages opening? When you open IDE Live Logging and then open this page on your phone do you see any errors in IDE live logging?

###Multi User Lock Code Management with Notifications and Actions - Version 4.6.5

Recommend use the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung - #364 by RBoy) device handler version 2.10.3 or later for full SmartApp functionality

Thanks to DnCCrew for this step:

To set the hub Location, from smartphone app:

  1. Clicked on the 3 lines (top right corner)
  1. Clicked on gear icon (top right)
  2. Click area that says “Tap to set where home is on the map” and zoom in to correct location on map.

EDIT: Please note this version has simplified the user interface, so please CHECK and VERIFY your notification settings. These are now on the first page under door lock/unlock actions. Also NOTE that the user lock code based actions require the use of the Universal Enhanced Z-Wave Handler version 2.10.3 or later

I don’t see it on the website? Still shows old code.

Yes @RBoy I am on the latest iOS Phone App. All other pages are opening. In IDE live logging I don;t see an error but I do see a trace issued when I click on that menu option to open lock/unlock action items.

This is the line that showed up in IDE Live Log.

Unlock Action Page, user:, name:, passed params: [id:b184c888-d5ac-4657-972c-37fbf89434, name:unlockLockActionsPage, passed:true, user:null], saved params:[id:b184c888-d5ac-4657-972c-37fbf89a4434, passed:true, name:unlockLockActionsPage, user:null]

This looks good. Sorry I don’t have more ideas. Try a different phone or try contacting ST support. It’s working fine here on all our test phones.

@RBoy I figured it out. Might be a bug. If you don’t have any Routines configured that page doesn’t load. As soon as I created one routine, then the page loads. I don;t use ST Routines due to them not working 100% of the time, instead I use CoRE to trigger routine like behavior. Is this something you can fix so that one doesn’t have to have routines for that page to load?

1 Like