[OBSOLETE] Lock Manager

The “keypad” function in the manager is something different. You have a lock. For whatever reason, the Yale locks (I have one) do not transmit the actual code entered, but instead transmit 99 no matter what is entered. This prevents a lot of functionality in the lock manager app from working, functions that rely on knowing what codes are entered like burn codes. Ethayer reached out to Yale a while back about it, and they were supposed to get back to him. Not sure if they ever have.

In that case, how does my lock know that my gf opened the door? I get notifications “door opened by Ana” when she uses her code, so it must know what is used? unless it’s just returning what key number is used (1,2,3 etc)… either way, I’m definitely being told what code is being used - at least indirectly… I think smartthings is doing a beta at the moment with scenes which will do something similar to what I want, however I’m not sure how that will work with the lock… and the lock from smartthings definitely doesn’t have as much functionality as this smartapp.

I’ve been using this app for the past few months with a few Yale Real Living push button deadbolts, and it has been working great.

However I tried today to access the “menu” of one of the deadbolts today by entering master-pin and pressing "#"and it will not accept the code. It accept the code for unlocking the door (*), but I can’t use the code to access the menu.

Has anyone experience this issue before? The master pin hasn’t been changed since the initial setup, but as a test I went ahead and changed the pin for it using the Lock Manager app. The new pin has the same issue - can unlock but not access menu.

Not sure if this has anything to do with the app, but I’m seeing the same behavior across all 3 of my deadbolts - and I know I did not face this issue when initially setting them up.

Any help appreciated!

The Lock Manager app doesn’t have any control over the master code on the lock. The LM app can only set USER codes on the lock. The master code on the Yale Real Living Lock is initially set when you use the lock for the first time on the touchscreen. You can only change the master code on the touchscreen.

1 Like

Thanks-- everything is working as expected with my Yale Smart Living Lock! Solved a major annoyance…PayPal donation heading your way.

Anyone have any suggestions on how to increase the polling for unlock / lock on a Kwikset 910? I have a Webcore routine that uses the ‘unlock’ to trigger backyard lights after dark to let the dog out. Naturally, I would want ‘lock’ to turn off the lights, but it doesn’t seem to work? When I jump into SmartThings it still shows the lock ‘unlocked’ in the app so I’m assuming it just isn’t polling enough to get trigger it? Thoughts or suggestions are appreciated!

NM. Figured it out.

Thanks for the app by the way!!!

I just moved house and am re-setting up my Schlage Lever lock. I’ve got everything working with the latest code from github, but I’m worried I might have done something stupid and deleted something I need besides the lock manager apps and device handlers. (yes, i’ve read the manual entirely) Sorry for the dumb question, but do I need any other ST “base” device or app to run alongside Eric’s Lock manager? I noticed that the lock is working ok for my 3 assigned users, but it’s not always “re-locking” itself afterwards… which makes me think there’s something missing that I might have inadvertently deleted?

I just got a new thermostat for the winter and I wanted to redesign how I use my lock which is a Yale YRD240 (Keyless ZWave)

What my routine was before was once my cellphone left home, my home would which over to “Away” mode.
Now in an effort to save energy with my new zigbee thermostat, I wanted to input my code to lock my door to trigger “Away” mode which turns the thermostat down. Rather than waiting for me to drive down the street I want to turn down the thermostat as soon as I lock the down.

So I checked Lock Manager settings and under my user I set the “Hello Home Phrase on Lock” to “Goodbye” which turns down my thermostat as I desire. I tested it by closing my door and locking the door with my code but its not working.

I can get the “Hello Home Phrase on unlock” to work. It triggers the “I’m Back” routine.

In testing and trying to get this to work, I noticed that my lock/Lock manager was only sending out notifications for unlocking.

Is there something that my lock doesn’t support? Once again its a Yale YRD240 Zwave. Im using the "Zwave lock reporting "

Hello, how do you remove the Lock Manager from your Smartthings? I’ve removed the device handler but can’t seem to remove the mySmartApps piece?

Are you talking about the new SmartThings Lock Manager? Or are you talking about one of the other custom Lock SmartApps?

If you are talking about the brand new SmartApp that SmartThings just released, and you installed it from the Market Place and it shows up on your Dashboard page, you can do the following to remove it:

  • Login to IDE
  • Select Locations
  • Select Installed SmartApps
  • Select Edit (upper right hand corner)
  • Scroll down to Solutions
  • Select “Uninstall” next to Smart Locks

Then go back into the SmartThings Mobile app and it will disappear from your Dashboard.

To remove the SmartThings Smart Locks app you should also be able to go into the Smart Locks app from the Automation>SmartApps screen in the ST app, scroll down and select the red “Remove” button.


I wanted to ask about this, since it seems very likely this is going to come up - what happens if Lock Manager users also install this app and try to use it along-side Lock Manager? I installed the SmartThings Smart Lock app to get a look at it and noticed that when I went to the lock info screen it showed only one user/code (though I have six users). I didn’t play any more w/it and removed it in case it might mess up my current setup.

Should there be any cautions/warnings in the the first post in this thread, and in the Lock Manager installation docs, about trying to use both of these apps at the same time? Seems like “worlds could collide.” :slight_smile:

1 Like

@WB70 Thank you very much for the detailed description on how to install the new SmartApp. I realized there was a hidden binding to the Lock Manager for one of my locks (for some reason my lock had 2 connections to the Lock Manager), once I removed the lock from all the Lock Manager apps, I was able to remove the child SmartApps then the parent SmartApps.

The new Smart Locks and Lock Manager use different DTHs. The new DTHs required by Smart Locks are not compatible with Lock Manager. And the DTHs required by Lock Manager are not compatible with Smart Locks.

:joy: That would have been too easy.

I have helped a few users in the last couple of weeks have to manually uninstall some custom SmartApps because they were unable to do so from within the app, so I assumed that the new Smart Lock app got stuck from being able to be deleted, because pressing Remove is too easy.

I took the scenic route.

1 Like

Oh snap!! Is it any good? That’s confusing that they named it the same thing. Sorry guys. Should we pack it up? Is the reign of ethayer’s Lock Manger over?

I’ve been planning on ramping up production on my app this holiday since I’ll have a bit more extra time, may still do that. The web application is still in development too.

They told me like… 3 years ago that they were going to do this soon so I guess this is right on schedule LOL.

I’m going to check it out now.

EDIT: Yes, don’t use both SmartThings ‘Smart Locks’ and ‘Lock Manager’ at the same time. Looks like they named it differently. Sweet! They will conflict like mad, so don’t do it. Pick one. =)

1 Like
1 Like

Eh, I can’t get the integrated SmartLocks stuff to work right now. Maybe later.

I’ll just assume it’s not a viable 1:1 solution at this time and that Lock Manager development is going to keep on trucking.

Though yes, the DTH will not be compatible and you must choose between solutions.

1 Like

Custom apps are always far better then any thing smartthings puts out.