[OBSOLETE] Honeywell / Ademco Vista 20P Integration

I have the same error messages and contact status stuck on SmartThings. V2 Hub. Used to work fine, problem started recently. Hub reboot and actuating stuck contacts clears the issue but only temporarily - until the timeout errors occur again.

I’m on V2 Hub, and checked the server.log on my Pi. I traced that error message back to April 10 and saw that it lasted for a few days. Nothing since. Although at the time I didn’t notice the contacts left opened, it may have been resolved as I had to reboot the hub a few times, looking at other issues with zigbee devices not responding.

@dadanepal, Just out of curiosity, what is driving you to want to get this working in the new app? With the exception of having to ignore my entry/exit door sensor in SHM, this has worked perfectly for me for a couple of years in the classic app SHM. Just for fun, this weekend, I started tinkering with using webCoRE to allow for entry/exit delay in SHM in the classic app and almost have it working properly. I have one more kink to iron out and I think it will be perfect. Not sure if this kink is a limitation of SHM or a limitation of this integration. But, after reading your post, I started wondering if my time may be better spent transitioning to the new app and using your solution. I don’t want to waste my time fiddling with the old app if we are on the verge of having to use the new app.

The main reason why some of us began to look into making it work in the new app was because Samsung announced a while back that they were shutting down the old app. I believe back in January, they were talking in terms of months before that was to happen, although no specific date was ever introduced to my knowledge.

Okay. I see. I just wasn’t sure if you guys had found some feature of the new App that was better than the old app and wanted to change because of it. The STNP code, Device Handler code, etc. is over my head. So, I don’t think I will be able to contribute much to the new App integration. So, I will continue down the path of getting my version of a entry/exit delay SHM webCoRE piston working. My hope is that the questions that I have and answers that I will get will help someone else, or, indirectly help you guys get everything working smoothly in the new App.

Personally I use this to handle my delay: [Release] SHM Delay Version 2.0
It creates a virtual contact sensor that waits to ‘open’ X number of seconds after the selected contact sensors open.

I’m using the DSC version of Alarmserver but it should work for the Honeywell branch too. I just set my AlarmServer DelayExit Doors as the source for one delayed entry contact sensor and set the delay on this smartapp greater than the exit / entry delay on those three real contact sensors (also turn off ‘real’ night mode.)

Bonus - the virtual contact sensors should work with STHM as well as SHM.

I am still using my old app. I have both of them installed on my phone.

The door sensor fails to update for both in my situation. It is very intermittent…

Thanks @nathancu. I have looked at the SHM Delay release a few times in the past. But, it just seems to be overkill for what I want to accomplish. This integration from @redloro has been almost perfect for me for a long time. If I could figure out a simple way to add entry/exit delay, it would be perfect for me.

i should look into this. one of the things making me hesitant to dive in is the link integration between STNP and SHM. Even before I had added my contact sensors to SHM, if I opened my door, the Vista would tell STNP which would tell SHM that there was an intrusion. So I haven’t been sure that adding a virtual contact sensor would matter.

since rebooting my hub, my sensor states in SmartThings have been accurate again. Not sure how long it’ll last, given others comments in this thread.

What’s the best way to reboot the hub without pulling the power and batteries? I could only find the option in the IDE, not in either app. Is there a smartapp or a piston that I could trigger to do that?

i’ve been suffering from this issue but it went away for a few weeks when i upgraded Kurtsanders ambient weather station smartapp and the update broke the app so it wasn’t running. when i noticed it wasn’t running a few weeks later I found there was another update available which fixed it. but two days later my Ademco integration problem returned…
there is a connection…

@philh30 @redloro

With the new custom capabilities, how hard will it be to convert over and away from groovy?

Found an issue with the Water Leak DH I wrote. One letter wasn’t capitalized which caused the device to not know what state it was in, which was most evident by the missing icon in ActionTiles. I corrected it and tested it, and issued a pull request in github, as well as edited it here.

It’s possible, but it’s tough right now since it’s in alpha and they’re still working on documentation. I’ve been playing around with some of my simpler devices and am just starting to play with this one. It’s not pretty, but I’m able to get the basic functionality showing.

1 Like

Nice, @philh30. Keep us posted. I wasn’t aware that it was still in the alpha stage…ouch. Hopefully they’ll make it a robust environment and we (you) can port this app over.

I solved, or at least found a correlation, my ademco server problem. I changed kursanders ambient weather update period from one minute to two minutes.

Here’s where I’m at for now. This will give panel status and a whole bunch of buttons in the new app, without breaking the old app.


Thanks, Phil, for that work. I was looking forward to trying it.

I did replace the DH with this one, but see no changes in the options within the app. In other words, no buttons like in the examples you provided earlier. Like before, it gives me a “network or server error occurred” message, when I go into the settings with the new Smartthings app. I also updated the SmartApp from the Repo and rebooted the server, but still no change. The sensors are still responding, and the old app works as usual with all the buttons.

Did I miss something?

Try swapping to a different DTH and then swap back to this one (or make a second copy of this DTH and swap to it). Also, try force stopping the ST app and clearing its cache on your phone. The ST app doesn’t immediately pull a new display, so those things are the voodoo that seem to force it to do so. Otherwise, the app supposedly refreshes twice a day, so just check back later.

I force stopped both old and new ST app on the phone, and cleared the cache. Made a second copy of your new DTH and swapped it, but it still won’t play nice. So, I’ll check back tomorrow and see if any voodoo takes place overnight!

Just to make sure, does your new DTH replace the original (redloro-smartthings : Honeywell Partition)? Yours shows a slightly different name (platinummassive43262 : Honeywell Partition) in my IDE. As it stands right now, either having only yours or both makes no difference.