[OBSOLETE] GoControl Siren / Linear Siren / Vision Siren

@ILLI13 Did you find out how to reset the Siren? I did not get it to reset with 10 presses.

Yes. I had to login into my developer account and reassign the original DH to this siren. After that I was able to reconnect it to smartthings and then assign the upgraded DH again.

Works great! I have ZM1601EU, branded by Clas Ohlson.

1 Like

does anyone have issues with battery status. even though i replaced the batteries.
it seems to keep pinging me that the battery is low?

it works great but i want to make 1 small change, the auto off function has maximum of 120 seconds , what do i need to edit in the code to increase this time? i really want to do this directly in the siren code in case internet goes off or something, thanks
edit: it was actually easy, just edited the 120 case in device handler

120 seconds it he maximum value supported by the hardware so that can’t be increased.

You’re change didn’t do anything because if you try to set a configuration parameter to an unsupported value it will just ignore it…

WA105DBZ Manual:

ZM1601 Manual:

only that i tested and it works perfectly fine and i also made it to auto turn off only if both siren and strobe is ON as i need strobe to be on for more time in certain situations, and now default value is “disable auto off” , all by editing the custom dth
it now looks like this
case “120 Seconds”:
state.autoOffSeconds = 120
result = 1
case “180 Seconds”:
state.autoOffSeconds = 180
result = 2
case “Disable Auto Off”:
state.autoOffSeconds = 0
result = 3
state.autoOffSeconds = 0
result = 3

You said you wanted to make the hardware automatically turn it off and that’s not possible because the hardware doesn’t support an autooff value higher than 120 seconds.

That “state.autoOffSeconds” is the digital off so if you’re getting it to turn turn off after 180 seconds then that means the hardware setting is disabled and if your hub is down it will stay on until the batteries die.

i will remake my tests to make sure everything was off from software side

You should check the manual that came with yours to see if the “Parameter 1” options match what I posted above.

I’m positive the change you made had no impact on the hardware setting because it’s the “result” value being sent to the device, but it’s possible that a newer model has more options and if that’s the case then the handler could be modified to support them.

if i change
else if (message.contains(“strobe”)) {
cmds += (args?.size() == 2) ? customStrobe(args[0], args[1]) : strobe()


	else if (message.contains("strobe")) {	
		cmds += (args?.size() == 2) ? customStrobe(0,3) : strobe()

will it disable auto turn off for when using only strobe?
i want the autoff to kick in only when both strobe and siren are used but never turn off when strobe is used only

No, that change won’t do that…

It’s possible, but you’ll have to disable the hardware auto off feature so that the normal strobe command will make it stay on forever and use a custom message to turn on the siren/strobe.

In the first post of the topic there’s a section that mentions Smart Home Monitor and Speaker Companion so you’ll need to use one of those methods to execute the custom message.

The custom message you need to enter is both followed by the arguments “delay, autoOff, beep”

For example, if you want the strobe and siren to turn on immediately and turn off after 3 minutes you’d need to enter the following into the custom message field:

both 0, 30, false

this look way over my head
i want the auto off comand to be hardware but i want to take place only when siren and strobe is ON, if i select 120 sec auto off for example in smartthings settings and i turn on the strobe only, i want to go on forever and in the same time to work as normal for siren&strobe.
If is not too many changes that need to be done maybe you could do it for me and paste me the new code, ill buy you a beer with btc. thanks
ps: the responsiveness of this device is by far the worst from over 50 devices that i have. I gotta use while loops in webcore and sometimes to send 4-5 times the same command every few sec to actually make the siren do something.
ps2: for some reason, in the new app i dont get any history for the device, i can see the history tho in the old app and samsung ide

hello there
I just switched from wink to smartthings hub v3 and using the smart things app (not classic).
I have the gocontrol siren and cannot figure out how to get a battery status.
When i added the device and selected siren, there was no option for gocontrol.
I accidentally selected Aeotec and that paired as generic zwave switch.
While i can turn on/off the device, unfortunately there is no battery indicator.
any help appreciated…

Sorry, I somehow missed this post…

The only way to get that to get that behavior would be to modify the handler so that it changes the hardware setting to never shut off before activating the strobe and then changes it back to 120 sec after it’s turned off.

This device is extremely unreliable which is why it’s not possible to do what you’re trying to.

The change mentioned above will add 2 addition commands being sent to the device every time the strobe is turned on and off. That would make it even harder to get it to actually turn off and I’m sure that sometimes the auto off won’t get set back to 120 seconds like it’s supposed to.

I haven’t modified the handler to make it work in the new app.

They haven’t published the new mobile app documentation and they’re constantly changing things so it’s not worth messing with the handler until it’s published.

You need to install and publish the device handler in the first post of this topic and then open the device in the IDE and change the Type field to Uncontrolled siren which will be at the very bottom of the list.

Thanx a lot Kevin. I downloaded the device handler from your github and things are working fine.
a) where can i download the latest device handler for the gocontrol motion sensor?
b) I noticed the classic app shows me battery % indicator for the siren, but not in the new app?


You can find all my handlers here

I haven’t modified the handler to make it work in the new app.

They haven’t published the new mobile app documentation and they’re constantly changing things so it’s not worth messing with the handler until it’s published.

I read through - I don’t think I read anything that helps me.

I had no problem installing your device handler.
I have the following settings:
Disable Auto Off
Strobe Only
Always Set Alarm Type (ON)
Allow Siren Only Light (OFF)
Default Use Strobe During Alarm Delay (OFF)
Default Alarm Delay (0)
Default Length of Beep (0.0)
Checkin Interval (12 Hours)
Battery Reporting Interval (12 hours)

All I want this to do is strobe when one (or more) of 5 door contacts open, and then turn off when whatever gate(s) was opened, is closed.

I’m doing this by writing a piston in webCore. My problem is - it won’t turn off!

I mean, I can press the “off” button in the smartthings app to shut it off, but that’s the only way.

I did a test piston. “Turn on, wait 4 seconds, turn off”

It turned on… And stayed on.

When I looked in the logs it read:

¦¦ Executed [Gate Alarm].on
¦¦ Waiting for 4000ms
¦¦ Skipped execution of physical command [Gate Alarm].off() because it would make no change to the device.

So it’s showing as off, even though it’s not off.

Any help would be greatly appreciated.

The reason your piston isn’t working is that the device hasn’t reported that it’s on yet so WebCoRE’s thinks it’s already off and it’s ignoring the off command.

CoRE had an option called something like “disable optimization” which disabled that check and made it always execute the command. WebCoRE must have something similar and disabling it should solve your problem.

That being said, I’ve worked on handlers for a lot of sirens and this device is the slowest and most unreliable so you’ll be lucky if that automation works as expected 85% of the time.