[OBSOLETE] Fully Kiosk Browser Controller (DTH)

Haven’t had a chance to mess with the original tts box again yet, but I can verify that the TV box (android 7) seems problematic.

If kiosk browser is running in the foreground, commands from the dth are accepted. As soon as say, the homescreen is focus instead nothing gets intercepted. Which also means the ‘bring fully to front’ button has no effect either. I’ve searched for battery optimization options and these don’t appear to help.

Suggest contacting the Fully developers info@fully-kiosk.com

Good shout - although now I’ve realised it’s not down to fully. I’ve sent this email:


I’ve been a keen follower of this thread:

(I’m the poster djh_wolf, by the way)

I’m hoping you might be able to shed some light? In a nutshell, when I run fully in the background on my android tv box (android 7), it doesn’t respond to requests. Bring the app to the front, and everything works just fine. I’ve attempted to check out various options for battery optimisation etc to see if I can find why, but I’ve been unsuccessful.

In addition, if I open GooglePlay and click on ‘install’ (for anything), then bring the homescreen to the front, I could sit and wait forever and nothing will download and install. However, if I then bring playstore back to the front, the app will immediately begin to install. It’s as if apps not in focus are ‘paused’.

Could you possibly assist? I’ve exhausted my options.

Kind regards,

1 Like

Seems like triggerMotion() just simulates a motion event. I was hoping that it would turn motion detection on or off. I’d love to sync the motion detection status to my ST modes.

1 Like

I have not seen anything allowing the Fully app to report motion or turn motion on or off. If you contact the Fully developers, and it’s available, let me know and I will attempt to get it implemented.

BTW Fully uses the devices camera as its motion detector.

Looking at the website I see that the developer writes: // Change any of 200+ Fully settings, look in Remote Admin for keys

For motion detection it looks like it would be



I’m extrapolating from the javascript interface section on the website but I would assume the REST API uses the same calls.

In the Javascript section it also has a respond to events section. I’m not sure this can somehow be used in a device handler but there is a line:

void fully.bind(‘onMotion’,‘todo();’) // Max. one per second

Yup… that should work to turn on and off motion detection on the tablet.

That call is also used to set the screen brightness and kicks in right away once used.

While working on the smartapp I found the Javscript info, but never found the 200 keys as a list.

If you have the time and inclination, feel free to work on it. I am currently busy with other things.

Well, I’m stuck with this now. Whatever I do, one of my android tv boxes (actually, the higher spec of the two) always kills apps in the background. I can’t see a ‘currently open’ apps list (which I thought was pretty standard on these things), and if say, I open the smartthings app, then navigate back to homescreen again, if I click on smartthings again it takes a good few seconds to log back in again - it’s as if any background apps are closed down automatically whenever you return to home. I’ve Googled and failed. The old 2gb android box which I currently use for announcements is fine. Odd.

This looks/sounds amazing – cant wait to try it!

I’m having problems getting the MP3 files onto my fire tablet hd. I’ve used both dropbox and Google Drive from Silk, and click download. But the URLs are not working.

If you have a Windows machine, connect via USB, then look at the Fire device’s directories, when mp3 not available, transfer the file.

Otherwise you will need an app such as ES File Explorer to view the Fire’s directories.

I can turn the screen off but am not able to turn it back on, Is there a power setting that needs to be done on the tablet itself to allow for this?

Just tapped screen off tile, followed by screen on, worked as expected. Don’t know of any Fully setting that would impact these actions.

Should you be turning off power using the devices’ power off button, then tapping screen on, that won’t work.

I’m excited to get this up and running, but for some reason I’m not able to save the device settings. I’ve installed and published the device handler, created a new device as instructed, and filled every required field in the device configuration (and also tried filling every single field), but each time I hit save, I get a message from SmartThings (classic app) “Please fill out all required fields”. Very frustrating. I’m sure it’s something simple that I’m skipping over. Please help. I’ve tried on the Fire tab as well as the phone app.

Just set up a fully device and had similar issue. Try changing the Logging Level, and the port number. After it saves, change them to correct settings. No idea why this occurs.

That did the trick. Thanks!

1 Like

Still struggling here. I followed all the instructions and I’m logging events in each of my two TTS devices: “BigTalker2 sent speak command to Entry TTS” (and Laundry TTS). I’m in speech synthesis mode, double checked my IP settings (DHCP reservations, FKB IP, and TTS IP settings), checked server password, etc. Fully just won’t talk at all. Volume is all the way up on each device. I’m sure I’m missing something. Any suggestions?

I am having trouble getting the tone and alarm mp3s to work. Speech is working fine. I have the mp3 files in my ringtones folder of the Fire HD 8 tablet (2018 Version). When I use ES File explorer to get the properties of the file is says it is located in “/storage/emulated/0/Ringtones”. I entered “file://storage/emulated/0/Ringtones/alarm.mp3” in the Alarm Audio File URL field. When I click on the sound Alarm tile I get the following message “Failed loading sound: Wrong URL or unsupported format?” I get the same error for Tone. Am I entering the file location in wrong?

Try file:///sdcard/storage…