[OBSOLETE] Enerwave ZWN-RSM2 (v1 & v2) & RSM2-Plus —Smart Dual Relay Switch Module

Sweet! Course now my, uh, kids, yeah thats it, want them for Christmas! :wink:

1 Like

I had been using this device handler for a few weeks with no issues. Starting last night, control of the relay became very unreliable. Perhaps 10% of the commands I initiate from the app do not work. The state of the device in the things list will change, but the relay won’t execute the command. I don’t think it’s a communication issue, because if I manually flip the switch, the app updates the state within a few seconds 100% of the time. All other devices are working correctly as well. :pensive:

Flip the breaker on the circuit the relay is in. Leave off for 30-60 seconds, power back up. I’ve had to do this twice with six relays.

Also do a z-wave repair, maybe do that first.

I did try a z-wave repair and it gave me two errors from the relay - failed to update mesh info, and could not assign new route. I turned off the breaker for two minutes, and that didn’t seem to help. I tried restarting the hub, too.

One thing I noticed is that switch 1 seems more reliable than switch 2. 1 works maybe 30-40% of the time, and 2 is more like 10-15%.

Sometimes after a rebuild or power outage, the relays take MINUTES to come back to life, like up to ten maybe? They aren’t the quickest z-wave devices I have by a long shot, but once they come back, they work solid.

If you keep getting the failure, go to zwave tools and do an exclude, flip the light on the bum relay, should get a message that it’s removed, then re-add it.

Edit: In the app do a replace on the device, see if it says it’s not eligible, THEN do the remove/re-add.

I didn’t have time to further troubleshoot last night, and now this morning everything seems to be fine. My 10:00 pm schedule to turn off my outdoor lights worked, and I appear to have full control of both switches again. I guess a combination of resets (relay and hub) and time did the trick.

I’m starting to think my issue lies with the virtual switches and/or virtual device sync. Last night I completely lost control from the app, but state changes were still being updated when I flip the switches. I turned on switch 1 in app, then manually turned on the relay in the app, and switch 1 turned on then. My plan is to remove the virtual switched and switch sync and add them again; I haven’t yet because I have a lot of automations tied to those switches so it’s going to be a pain in the butt to do and I don’t have time right now. This is the life of a father with 11-month-old twins. Haha

Well, I think I’m giving up. I removed the virtual switches, removed the switch sync app, excluded the relay. Paired the relay, added switch sync app, created new virtual switches… and still only partial control. I think I’m going to return the relay and buy one from a different manufacturer because I definitely have a sour taste in my mouth from this one.

1 Like

Is this release supposed to support instant physical switch updates with the Enerwave ZWN-RSM2-PLUS (versus the ZWN-RSM2)? When I manually toggle a physical switch connected to the ZWN-RSM2-PLUS nothing shows up in the live logging area of the Smartthings Developer Tools. When a refresh is performed in the app, the status of the physical switch is correctly updated instantly.

The Enerwave documentation states that writing a 1 to parameter number 3 should enable unsolicited reports and it appears that this is being attempted by the device handler, but there are still no instant updates in the Smartthings app.

Using the following code in the device handler for the Enerwave ZWN-RSM2-PLUS I was able to get instant status updates working:

def configure() {
log.debug "configure() called"
def cmds = []
cmds << zwave.configurationV2.configurationSet(parameterNumber:3, size:1, configurationValue:[1]).format()
cmds << zwave.associationV2.associationSet(groupingIdentifier:2, nodeId:[zwaveHubNodeId]).format()
cmds << zwave.associationV2.associationSet(groupingIdentifier:3, nodeId:[zwaveHubNodeId]).format()
delayBetween(cmds, 2000)

1 Like

I installed a ZWN-RSM2-PLUS today in my Son’s Room for Fan and light control and used this device handler with your configure() method. Everything is working perfectly.

Thank you again.

For some reason, parameter 3 is not available on the plus despite what is mentioned in the manual. The work around is to associate the SmartThings Hub with association group 2 as you mentioned.

Does anyone know a code to do a siliar thing with the Enerwave Z-Wave Plus ZWN-RSM1 . I have one hooked up to my hallway light. It’s currently set up as a zwave generic switch. It works, however I don’t get status updates in the app if I use the wall switch, only if I use the app to turn it off and on.

You can try this handler. There is a special way that instant status updates are enabled with this switch. Use the following handler and hit the configure button a couple times.

1 Like

Do you still recommend using Physical/Virtual Device Sync or use the other one you created for the H801?

Use the one that works with the H801 “Virtual Device Sync”. It is an upgraded version of the one mentioned in this post. I say that in the Physical/Virtual thread, but I know it is easy to miss. :slight_smile:

duh… I sure did miss it. :rolling_eyes:

So I would like to use the ZWN-RSM1-Plus to respond to an ST motion detector to momentarily close a relay for about 1 second.

Can this device handler do a momentary on/off?

In another thread I see that there is a device handler to do that with Fibaro but I would like to avoid spending $60 on one and use the RMS1 since I already have one laying around.

There is a device handler that is a default to SmartThings called “Z-Wave Virtual Momentary Contact Switch”. It is very similar to what you are describing but momentarily opens a relay. You should check it out as it would be a great starting place for you.

1 Like

erocm1231 thank you for that tip.