[OBSOLETE] Does the Generic Media Renderer (DNLA Speaker) community app for WiFi speakers still work in 2020?


I have Fabriq WiFi speakers, RIFF, I am am trying to use in SmartThings.
I followed instructions at:

to install the MediaRenderer (Connect) SmartApp and the DLNA Player Device Handler/Type for it.
It shows as installed and published in my IDE.


But the SmartThings Classic App is not showing it in “My Apps.”

Is this app still working last useful comments/commits were in 2018.
Or is the Classic app now broken?
Is there an alternative way of doing TTS and DLNA in the new SmartThings app?

Please help,

It still works… for now.

  1. did you login to https://account.smartthings.com to install the custom code?
  2. did you try loading it from the new app, click on + in the upper right of the screen, choose smartapp, then scroll to the custom section and open mediarenderer (connect)? After you set it up, it appears in menu > SmartApps


Thanks for the response.
When was the last time you used it or installed it?

Yes to “1.”

For “2.” I tried loading it in Classic app and of course “My Apps” is empty.

There is no “… custom section …” in SmartThings new app.
Have you done this before in the new app?
I have never seen it.
Screen shot?

This is my screenshot in the new app:


In Classic app, look in marketplace > SmartApps > my apps

I am using the smartapp currently for a couple of fabriq speakers

Any custom Smartapps you have installed should appear in the new app in that location.


Excellent! Thanks for giving me confidence :slightly_smiling_face:
It is now appearing!
I went back and re-installed it.
I noticed that sometimes it would disappear from list of SmartApps in the IDE.
After re-installing it, I can see it in both Classic app and new:

New App:

The “Custom” section appears one you have at least one app :slight_smile:

Classic App:

The next question now how do I use Fabriq speakers?
From YouTube Music for example?


My first thought about this - you could be logging into the wrong SHARD. If you are not logging in at https://account.smartthings.com you would experience the missing code. There is another And much older URL found in the forum and still in many installation instructions that users find and encounter this issue.

I mainly use them With SmartThings for reading alert messages.

YouTube music can be selected from whatever device you are using to play the music from and would not require ST.

That is my plan as well. I just wanted to test them before I fire up Big Talker or Message Central or WebCore.

Just to conclude that everything is working now for me with BigTalker2 and the $19.95 Fabriq RIFF speaker announcing all sorts of notification in my house :slight_smile:
And I have been doing all the controls from new SmartThings app.

anyone having issues recently. Have been using fabriq riff with generic media renderer for years and stopped working this week. Logs show messages are being sent but nothing coming out of the speaker. I can control the speaker via the classic app but not the new app. Anyone else having issues?

My speakers worked earlier today so working for me.

My speakers still working with new app.
Try to re-install and try again.

Is this still working for you guys as of today? Looking for a workaround for my HEOS speakers.

This was a smartapp running on the old (pre-2023) groovy platform. It will not work with SmartThings now. :disappointed_relieved:

Pretty much anything dated before 2023 that references “groovy“ code will be obsolete now.

1 Like