[OBSOLETE] BI Fusion v3.0 - Adds: Blue Iris Device Type Handler, Blue Iris Camera DTH, Motion Sensing


No when I was referring to wait, the directions say to set minimum time between requests to .1second. That option doesn’t exist in blue iris 5. Also the active/inactive urls get set up in separate places where you can add a chain of things. The only way I could think to ensure we don’t send commands to fast is to always make it wait .1s before the http request.

Hope that makes sense lol I’ll try to remember to get a screenshot if not.

So got another question…

I’ve got a couple webcore pistions set up to turn on outside lights when motion is detected from the Blue Iris cams. Works great.

BUT… It’s a little too sensitive. I have my motion A zone extend right to the edge of my driveway and front yard, but some car headlights trigger it. I’m fine with those recordings and (false) alerts but I don’t want the lights coming on every time a car passes.

I’m thinking I can make a motion B zone that is a little smaller, and set the alert to trigger on that. But will having duplicate zones like that cause me to get duplicate alerts when it records? Still trying to figure this all out.

Hello JMZ, I’ve been using your app for almost 2 yrs and it has worked quite well for me. So, thank you for creating it and supporting it all that long.

With the old SmartThings app being deprecated in a relatively near future, are you planning on updating this app so that it will be fully functional in the new one? A few days back, you mentioned about having to install on the old ST, but working fine in the new ST. I find the experience in the new one quite limited and would love to see it updated.

Ah! I see what you mean on the timing. I’ll have to take a look.

For camera motion sensitivity, I’m not the best source. I haven’t played too much with getting them not to trigger too often. That’s part of why I made this app. I use ST to do the trigger to record. But if you check out the IPCAMTALK forums you’ll probably find some good answers.

I don’t know that’d I’d say “very near future,” the new app has been out for years and I haven’t seen anything definitive saying the old app is going to die anytime soon. It still lacks the bulk of what the old app does (regarding custom smartapps and devices).

As far as I know, there is no way to implement several of the BI Fusion features in the new app yet. I only have the new app so I know what it looks like, I never use it. The old app works great.

If you have any links to correct any of the above, please share and I can take a look. But you really shouldn’t have to interface with any of the BI Fusion components once you get it all setup. The devices should be available to function in other apps, and the syncing, etc., will still all keep going. You should only have to jump into the devices or settings if something has changed in your Blue Iris config. Right?

The link below refers to the “coming months” for identifying the exact date before they drop the app. I also got an email from Smartthings saying pretty much the same thing.

I agree with your observation on the old app, and it has worked quite well for me.

Hi all, I recently install Bi Fusion and it’s working for me as expected but I’m trying to figure out if I can make the bi profiles follow the shm alarm states. I’m trying to make my BI profile change when I arm/disarm my burg alarm system. Has anyone accomplished this?

Found a solution using web core

1 Like

Not sure if something changed recently, but my BI Camera motion detectors stopped receiving notifications. Same issue as seen posted about in Fed/Mar 2019, I see that the notification from BI is making into ST but the device isn’t recording it, getting that NullPointerException.

7:59:04 AM: error java.lang.NullPointerException: Cannot invoke method replaceAll() on null object @line 139 (active)

7:59:04 AM: info Cam5 Motion ‘active’

The previous advice was just to reinitialize the app, but either I don’t know how to do that, or reopening and saving isn’t working.
*I’ve also tried removing all BI ST devices and the Fusion app and reinstalling the app and cameras (w new codes), still getting the same issue.

Any luck with this problem you experienced FierceFish? I’d love to get this installed but seeing this has stopped me from progressing with it.


I would also love to install Blue Iris and a camera to ST’s, i see this thread is quite old dating back to 2017, does this solution still work ok, if so i’ll get started today :slight_smile:



Having a tough time getting the motion sensors to work. Following the instructions, saw some have changed, but figured it out from some comments above (where to enter URL), but still no joy. I am entering url below for Active (FYI I cut off the last 12 digits of token in case that is an issue showing here)…and of course changing for inactive. The only thing I can tell may be off is do I leave the ? after camera name? I am fairly new to smartthings, and just downloaded BI and BI Fusion tonight. All cams are added, and the work in ST app as I can initiate record. Just can’t get this motion going. Any help would be great.


Nope, it still works. Setup is a little finicky but it works.

I ended up creating two motion zones on the cameras that control the lights. Zone a triggers recording, and a smaller zone B triggers the motion sensor.

I also have motion sensor in my mailbox that triggers a camera facing the mailbox to record.

If you look up the DEV answered a question as recently as February - no the support may not be as fast and furious as it once was, but many of the questions one would have have already been answered above…just takes some digging (currently in that situation myself haha)

1 Like


Been at this for a few hours now, still trying to get motion but no luck. I thought I had it figured (forgot to change to https) but still no motion detected. So far

All cameras added, can trigger recording from App, can change profiles from app.
I have OATH server only, and published all but trigger per instructions. Secure Session unchecked.

Following steps 5-7. I have tried manually keying the URL provided from the app, double checked for errors. Changed camera name to cam1

OK_RATHER THAN DELETE THIS POST I WANT TO SHOW HOW DUMB ONE CAN BE…MY CAMERA IS Cam1 - not cam1 - hours wasted over capitalization lol.

You notice above I actually figured out my error as I was typing this plea for help :slight_smile:

Figured I would leave this here in caseanother unfortunate soul makes the same novice mistake


Thanks Chad , I’ll get started

Yeah you should. After my stupid mistake in lost above I got everything working. It’s pretty great, both Blue Iris, and Fusion App. Set my first piston in webCoRE to control my front yard flood lights when motion is sensed on my front door camera (my motion detector up there was way too sensitive so I disabled). Works like a charm. Blue Iris gives you a ton of motion control.

1 Like

Edit: looks like it’s the cameras. They are crashing and not detecting motion. Haven’t changed anything though.

Error in log

2:59:50 PM: error error 30: Camera Motion Received but failed to send motion to ST device. Error: java.lang.NullPointerException: Cannot invoke method active() on null object

@JMZ Since BI updated the instructions have changed from https://github.com/flyjmz/jmzSmartThings/blob/master/smartapps/flyjmz/blue-iris-fusion.src/README.md for the motion alerts.

Just checking if anything changed or needs to be edited. I used active for On Alert and inactive for On reset. I had to regenerate the API key.

When I paste the url string in a browser I do not get any confirmation (only a white screen). I assumed a success would show it the url was valid? (just troubleshooting).

My issue is I am not getting motion detection within the SApp (I am in front of the camera and BI senses motion but that isn’t carried on to BI Fusion).

New Screen

I have had an issue with the Blue Iris Server stating it is offline? I have removed the Smart App and Device handlers and reinstalled. In addition, I even uninstalled Blue Iris. I have created a new user account in Blue Iris and made sure it was admin. I had this working at one time. I am not sure if it was when I downloaded Blue Iris 5 or updated to the new Smartthings app that it stopped working. Has anyone been able to get Blue Fusion to work using the new app? I really want ST and BI syncing the profiles. I would appreciate any help.

Sorry I’ve been quiet, it’s been real busy. I’ll try help you out if there are still any issues.

I have Blue Iris 5 since it came out and BI Fusion has been working flawlessly with it. So it can work. The most common issues are things like upper/lower case letters and small typos that @cmderden had, glad you found it! Gets me all the time too, too many hours lost chasing my own error…

Also, I’m going to start working on making this all work in the new app. For now though, setup and preference changes must be done in the classic app.

@FierceFish and @SmartAdamThing can you PM debug logs? I’m not sure what is going on. Include screenshots of your setup screens. Best guess right now is something got messed up during setup. You need to setup the server settings first, click ‘done’ to save all the settings, then setup the cameras and click ‘done’ all the way out to save them, then you should be able to setup other things. It looks like your Cam5 is maybe named something different or got stuck in setup.

@Levanterman The thread being old just means it has worked for a long time! It still very much works and has been stable. Let me know if you run into any issues. Most setup problems have likely been answered in the thread or on the setup page.

@BBoy486 Yes, the instructions still show Blue Iris 4 screenshots, I’ll update the instructions with your screenshots, thanks. You shouldn’t have to change anything in your BI Fusion setup though, the changes are only in the new look of Blue Iris setup pages. Try deselecting “Extern” on the first screenshot you have. That creates a loop of camera triggering, and shouldn’t have been checked before. That may be the issue. I don’t think pasting the URL in a browser should do anything. Definitely nothing will happen on your screen, but it may trigger the active/inactive status in the SmartThings camera device. If deselecting External and double-checking your syntax in all your settings doesn’t solve it, please PM me your logs with debug logging turned on so we can follow it more closely.

@Jeff_Black Yep it works just fine with Blue Iris 5. It doesn’t work correctly within the new SmartThings app yet. BI fusion smartapp settings and the Server Device don’t display correctly, but everything is still working as long as you set it up in the first place. I run both SmartThings apps still (I just turned off notifications from the new one, and use the Classic app for everything still). But I’ll work on it. If it’s saying it’s offline in the server status, it could be that it just needs to sync again, so tap that (in the classic app). If it’s getting errors and saying it’s offline when the ST mode changes or something, then likely there is a typo in your server settings with BI Fusion, or something got changed when you set up Blue Iris 5 (unlikely). Double check all your settings, confirm you can still access Blue Iris through it’s app (which’ll mean your Blue Iris settings are likely correct), and let me know.

Alright, I think I got to everyone. If not, let me know.