[OBSOLETE] Ask Alexa 2.3.9 (2018)

I used the st-installation tool again but this time ‘trend setter’ and installation was superb

But NoGo on ‘ask alexa’ :’(

I recommend tagging @tonesto7 as the community installer is his app…developers have actually very little to do with the back end deployment of the actual app.

Worst case is that you install these in your IDE by hand, which can then be linked to GitHub. I am not sure if that is required as a prerequisite for using Community Installer.

What IDE github settings should i use? I did not see them in release post. Or i skimmed right pass them…

I would start here: http://docs.smartthings.com/en/latest/tools-and-ide/github-integration.html?highlight=git

Here But read the Docs21%20AM

1 Like

I have that ready to go.

Im referring to name and branch of github to do update from repo action for ‘ask alexa’

Thanks will read up on documentation.

Sorry…yes…that part is here: http://thingsthataresmart.wiki/index.php?title=Ask_Alexa#Advanced_Installation

1 Like

For those who are interested, found another obscure issue with the rooms extension. Only affects folks if they do a certain sequence of events before going into the room extension the first time. Thanks to @femwitjava for the work to help troubleshoot this!

We are now at version 1.0.4a of the Room Extension. Upgrade the IDE code in the usual ways :slight_smile:

Hi Michael, I sent you a message on Slack, when you have a chance take a look.

1 Like

I am trying to understand the functionality of “Ask Alexa”. Right now I am using an Android phone running LANAnnouncer to get voice notifications for various functions that I have in WebCoRE. Would I be able to use Amazon Echo devices for these announcements if I install Ask Alexa?

Short answer …no. The MAIN functionality of Ask Alexa is to suppliment or even replace the native SmartThings app to control and report on lights, locks, routines, etc. There is a Message Queue feature where you can have notifications either be played back to you on request on the Alexa or be announced in real time via speakers like Sonos or Bose. Right now Amazon does not allow 3rd party skills to “wake” the speaker. Think of the message queue right now like a mail box. You have to check for messages via voice to get them (unless you have a Sonos then the messages can be delivered as they are received AND remain in the mail box)

Amazon does have a notification feature coming (they say) for developers like me, but right now they have no ETA to release it.

Let me know if that answers your questions. Iveould recommend you check it out as Ask Alexa DOES have intergration to support running WebCoRE pistons and sending notifications to the Message Queue.

Thanks. That answered my question.


For those of you that are seeing truncation in your logs when setting up Ask Alexa, I have found the solution and will publish it soon:

I pushed out 2.3.9d to resolve the truncation issue for the setup. You will probably still see SOME truncation in the compound commands, but nothing that keeps the application from being installed or operational.

A little quick background:
I upgraded to 2.3.9d last night. I was having an issue with the older version that I installed last month and was about to post a question in the old thread when I saw your coming soon announcement about this version so I held off. I was crossing my fingers that the upgrade my resolve the issue but I it appears not to be the case.

Here’s the issue I’ve run into:
I was really looking to leverage the grouping function so I could have groups like “All Upstairs”, “All Downstairs” and then individual rooms such as"Living Room", “Master Bedroom”, “Kitchen”, etc. But I am only able to get a few of them to work.

I have Upstairs, Downstairs and, Master Bedroom working perfectly. But If I try to add any other groups they fail in different ways. For example:

I added a group called “Living Room.” It has 4 devices in it, two smart-bulbs and two smart wall switches. When I say “Alexa, tell Smartthings to turn off the Living Room” the echo responds saying it can’t find that group. But, If I ask it to list the groups it lists Living Room as one of them. I created another group that I called Kitchen. When I ask to turn it on or off the Echo just gives me the rapid flashing confusion ring and goes dark with no voice response at all.

I’ve tried different verbal command things like ask verses tell and several other variations but I get the same responses. I also renamed the groups in case there was some confusion with similar device names. I changed Living Room to “Fred” and Kitchen to “Martha.” Still the same result.

Am I perhaps misunderstanding how groups should work? If not, what trouble shooting steps can I take to resolve this?

It sounds like the groups like “Living Room” and “Kitchen” are not reflected in your developer areas. I recommend going to my brand new revision of the instructions and upload the JSON file to update your intents, slots, and everything else:


If that doesn’t work, PM me and we can get this going. The good news is that I have the same room names, so I can compare apples to apples.

That seems to have fixed it… I think.

I reloaded the JSON code before I realized that I hand left Kitchen and Living Room named, Fred and Martha. But they worked under those names, I went into the mobile app and renamed them Kitchen and Living Room and hit save on each screen and then retested. They would not work. So I repeated the steps to reload the JSON file again. It now works.

Should I have to reload the JSON file like that when I do admin in the mobile app?

For changing of names or adding devices you must update the developer site. In the future this will be done via the mobile app…until then it is manual.

1 Like

Half of my commands are not working via askAlexa. I can turn devices on and off but thats about it