[OBSOLETE] Advanced Button Controller (ABC)

First you will need to remove anything ABC related in your IDE.

Next, Install and publish this app.

And then install but DO NOT PUBLISH this child app.

Would I also be using this code below too, or just the top one? And is this is going to be copied/created into My SmartApps?

stephack/ABC/blob/master/smartapps/stephack/abc-child-creator.src/abc-child-creator.groovy

Thanks,
Steve

Yes, you would need to install BOTH apps (top and bottom) into IDE under My SmartApps. Just make sure to delete the old app first.

this doesn’t let me set the color of color changing bulbs. Anyone know what can?

For basic stuff you can use Smart Lighting…for advanced there’s always webCore.

Thank you @stephack and @Eric_Inovelli for all the help!! I came home tonight and did as you both have requested… The codes have worked and I am all set!! I couldn’t have done this without you two!!

YOU GUYS ROCK!!

S.REY @Chefsrey7

1 Like

Ok @Eric_Inovelli last question…Hopefully. Both codes have loaded correctly and on the ST app they work GREAT. But on the dimmer switch its self I can not get the scenes to function at all. Push to turn on certain lights and held to turn off the same set… ect.

Any thoughts I not sure what screen shot you would need to see tk help troubleshoot this one? But let me know and I can get it to you.

Thanks,
S.Rey

Hey Steve,

Let me know if the solution for using the Smart Lighting worked per our email. I’m not really sure what’s happening, but we’ll get to the bottom of it!

-Eric

1 Like

Hey Eric,
Just shot you and email regarding the the configuration we talked about. But that didn’t work. I was thinking may unpair it and then try to pair it up again?

Thanks,
Steve

Happy Sunday!
I went ahead and removed the switch completely
And then reinstalled it. I went back and followed the step-by-step set of instructions Eric suggested using ST Marketplace. No luck😞 I will have to agree with you it must be a defective unit I purchased from Amazon.

I also you a email with my address. I just didn’t want to blast that info in here in the community.

Thanks again for your help!
Steve Rey

Hello @stephack

I was hoping this would be the answer to my prayers and it still may be, I have a couple of Almond buttons and I have been trying to get the DH to work with other apps for double-press but I cannot seem to get it to work. Press and Hold seem to work fine. Is it the DH that needs to be worked on?

I have been trying for to see what I can do but I guess it’s a bit above me right now. Would anyone be able to help me? Thank you so much!

There is no official “doubleTap” support in ST. I have seen a few handlers that workaround this limitation by making the double Tap register a a separate button press instead. So in this case, the device will expose itself as a 2 button controller. Button 1 hold and press will stay as it is now. Button 2 press will be what ST sees when you double Tap. That way you can assign button 2 in Button Controller apps to execute automations when someone double taps the button. Shouldn’t be too hard to setup…I would request the author to update their DTH this way as it’s the easiest and will be compatible with any controller app.

Thank you. I’ve been trying for a few months with no luck. I’ll keep taking a crack at it, hopefully I’ll get it on day. Thanks again for getting back to me.

Hi there! AWESOME app,
I’m sure this has been asked before, how do I activate “scenes” not routines, via the smart app?

I had configured an Aeotec 4 button key fob using the default ST Button Controller Smart App. When trying to add a second one I was entirely unsuccessful and busted my first one’s set up.

It seems your software is 3rd party but more friendly. What would I need to do in order to use it?

Can’t get the new version to work, is there a problem with smartthings?

ABC will fire the first time and never again, as in double tap on but not double tap off or double tap on again.

I completely removed the old version. Uninstalled in smartthings and then removed from IDE.

i’m using Darwin’s DH 1.03 (11/14/2017)

Are you using a minimote? If so there appears to be a ST issue with minimotes:

No Minimotes. just HomeSeer switches, not dimmers. i was have a problem before upgrading on one of my switches where it wasn’t turning off a certain light using the ABC App, so i thought lets upgrade to the latest version. that turned out to be a bad idea as nothing works now.
i did convert over to the Samsung account about 3-4 weeks ago, i wonder if this is related?
I’m still using the SmartThings classic app, should i be using the Samsung version?

I’m at work, but i just checked in the app and it works now when hitting the double tap buttons. :smiley:

edit: now the one of the switches, Kitchen Lights, is not responding/registering to double taps or tripple or press and hold.

Edit 2: Seems smartthings sorted out the issues with ABC. The single switch I was have problems with where sorted out with a power reset.

BLESS!

Post must be at least 10 characters.