"No Network Connection" on iOS when saving a routine that changes a color

On my iOS app I am trying to create a fairly simple routine. If a switch goes high, turn on my Shelly RGBW2 and then change the color to orange. When I try to save the routine I get the dreaded “No network connection error”. If I remove the color change or change a different attribute it saves just fine.

So far i have tried:

  1. Deleting the iOS app and reinstalling
  2. Going to my.smartthings.com and trying to edit the routine. The web interface doesn’t even let me see the routine
  3. I tried installing Bluestacks on my laptop to see if I could run the Android version of the smartthings app, but the Google Play Store said that my device wasn’t supported.

Smartthings Hub v2
Shelly RGBW2
Iphone Xs

Version Info:
TAustin’s Shelly Device Driver V1.8b
Hub Firmware 000.048.0005

Please let me know if you have any recommendations on what to try next. Is there a different Android emulator that works with the Android Smartthing App? Should i try webcore? Anything I am not thinking of?

  1. I tried installing the Windows 10 smartthings app, but it doesn’t let me edit routines.

I am also now considering Tasmotizing it but let me know if anyone has any better ideas.

Webcore is long gone on the ST platform. I would suggest trying the free version of Sharptools.



Although tasmota would have probably worked, I have decided to try out home assistant. I was a little weary of sharp tools mostly because I had never heard of it and also because it is cloud based.

So far HA wasn’t too difficult to add to my synology but I haven’t tried getting z wave working. HA let me edit my light colors no problem.