New sonoff human presence sensor

Just got mine today in the mail. Sonoff posted the correct invite in the comments of that video, and it connected without issue. At least, I would hope. As of this moment, its not detecting motion, despite me being about 6-8 in front of it at most. Any guesses anyone?

After removing the device and adding it twice, it seems to be working now and responding correctly. I will see if this lasts


Try getting closer.

Because this only has a single zone, they tried to avoid the issue of it detecting through windows by giving it a pretty short range with the idea that that would keep the detection zone inside the room that it’s in. 🕵🏽‍♂️

8 feet would be right on the edge of its maximum range, so, depending on angle in any possible obstructions, 5 to 6 feet would be safer.

I have the same problem that it occasionally seems to be stuck and don’t report any changes for a long time.

Other than that, I find it to be too sensitive. For example, having a fan running anywhere in the room makes it continously detect motion even when it is pointing away from the fan. And another thing is that it sometimes picks up motion in an adjacent room. So they definitely need to add the possibility to change the range/sensitivity to the driver.

At the moment I’m using the presence sensor with a motion sensor rather than instead of. That’s not what I’d envisaged. Motion sensor better for turning on lights when you come into room and presence sensor better for keep them on while seated.

Most mmWave sensors address this by allowing for multiple zones per room. Then you tell it to ignore anything in zone x (where a fan is running for example). But those models also cost much more than the single zone Sonoff.


So at the Sonoff’s price point, I don’t think you’re going to get much adjustability, but the options do exist if you’re willing to pay more for a different model.

Best mmWave Sensor to Use with ST? (human presence sensor/occupancy sensor)


Indeed. However, since it apparently already has the capability of adjusting the sensitivity somewhat, it would be nice if their SmartThings driver would support that.


I have the same issue where it will work for.hours then stop. Just sits with no motion. Unplug and let it sit for a few minutes and it will work for a while then stop again. Tried multiple power supplies. Same result. Removed and added to smart things multiple times. Same result. Anyone else have this issue or a fix?

Just purchased two of these directly from Sonoff/ITEAD, and using their driver they supplied to Smartthings it will discover the device (as per the video), but seldom, if ever, does it report motion as I sit three feet from it working at my desk. I don’t have a Sonoff Zigbee dongle so I’m unable to configure directly through the eWeLink app to make any fine configurations per the Sonoff tutorial, which I think is only applicable to Home Assistant, anyway.

The other option that I’m having better success with is discovering the SNZB-06P in Smartthings as an eWeLink device, and selecting motion sensor. Since installing it this way it has been reporting motion detected, continuously.

This latter method (which is not in the video) I found (not explicitly) within the eWeLink app as a guide for pairing sensors across the eWeLink and Smartthings apps. I did previously enable the eWeLink/Smartthings integration within the eWeLink app, and gave it only the most restrictive access to Smartthings. I did not (as I mentioned earlier) install the SNZB-06P in the eWeLink app, so I don’t think it makes a difference if you have the eWeLink app installed, or not. I would have to backtrack and remove the eWeLink app to test that theory, but since I only gave it read-only access to Smartthings, I’m not inclined to go through the trouble at this point.

I will report back as I do further testing.-

Try experimenting with different psu. I first tried using a usb socket from a tv, which powered it fine to pair, but it never reported movement. I tried a usb charger that didn’t work before I tried another that did.


Also, move the SNZB-06P (and the USB cable) away from any other electronics that may generate electromagnetic fields.

This device seems to be too much sensitive to electromagnetic interference.

1 Like

Also, move the SNZB-06P (and the USB cable) away from any other electronics that may generate electromagnetic fields.

This device seems to be too much sensitive to electromagnetic interference.

That’s interesting. Especially, since Sonoff’s website pictures the device being used while the family sits and watches TV in the darkened room.

The result, so far, is that the SNZB-06P deployed by my workstation has remained triggered for motion since I last paired it, and has never changed, so that’s just opposite of the first trial. The one I deployed in the basement seems to be working as expected, but I have it about 5 feet from a TV, so that may cause issues once we have it turned on.

I’m really tired of paying to be a beta tester, and it’s not just Sonoff, or Chinese companies; it’s Big Tech as a whole – hardware and software. It’s been this way now for 20+ years. There was a time when it was not. We’ve done this to ourselves (tech junkies), being willing to shell out our cash and let these companies out of beta testing on their own budgets. I understand this would drive costs up for the finished product, but it would also maintain our sanity and we’d have fewer devices shelved due to being worthless.

Not sure how much more effort I’m willing to give this device. Looks like a rabbit hole…


I’m not impressed with these sensors and like @oldwindowsguy I’m getting fed up of buying half baked products. Sonoff started out really well but the last few products I’ve bought haven’t impressed.

There one “thing” this driver work on the cloud?
Because all routine that include SNZB-06p rely on the cloud not locally.
Can some one confirm that?


If you have the Sonoff presence sensor paired to a Smartthings hub then it will run locally. All other forms of pairing e.g. paired on another Zigbee hub like Sonoff, then will go through the cloud.

It is paired with Aeotec hub.
But allow me to discord from you, I will share two screenshots of routines, one with snzb-06p other without. And one the flag run locally and the other not. Also yesterday I unplug the Ethernet cable and specifically this routine doesn’t run.

The routine running a Lighting Group will not be local. Maybe the problem is here.



Thanks you are correct was the group…


Some how all days at the same time 15:38, my sensor become “no motion” and i’m just in from of them. Any idea how is that possible? There is no routine associated.


Since this sensor uses zigbee, it might have its messages drowned out by strong Wi-Fi nearby. Any chance that, say, a child is getting home from school around that time and firing up a bunch of Wi-Fi devices?

I had a problem several years ago where my Zigbee arrival sensor would fail every weekday in the afternoon. It turned out It was my neighbor’s kids getting home from school and using a bunch of boosted Wi-Fi devices all at the same time. For me, the pattern became obvious because the kids got out of school earlier on one day, and sure enough the Zigbee failure would be an hour earlier than the other weekdays. :bus: