New Official Integration: Samsung Multiroom Audio


#309

Try this for the for the abrupt cut off…

https://community.smartthings.com/t/r1-speaker-abrupt-volume-drop/62587/4?u=tgreenway


(Mario Fuchs) #310

Ok, so I have read the complete thread and have found this:

  • Assign the audio device a static IP in your router
  • Enable UPnP in your router
  • Check latest firmware

I have 1 Samsung R3 (WAM3500) that works fine using the Samsung Multiroom app.
Firmware version 3111. No multi room hub should be required, right?

Can’t get it to be recognized using the ST app no matter how long I wait. Have been watching the log for ages to see any sign of recognition, but nothing…

What sorcery is required to make it work?


(Joe Cribbs) #311

I had to do the manual addition to get Smartthings to recognize my Radiant speakers. Also, make sure that the speakers are in WiFi mode, and not Bluetooth or TV.


(Mario Fuchs) #312

Absolutely, it’s on WiFi all the time. Thanks.

So, how would I go about adding it manually? IDE + IP?


(Joe Cribbs) #313

I just mean that I use the “add device manually” button at the bottom when you try to “add a thing”.


(Mario Fuchs) #314

Are you referring adding a smart app?

Don’t have that option under Marketplace --> Speakers --> Samsung Multiroom Speakers (UK) --> + Connect now

All I get is the indefinitively spinning indication every 3-4 seconds, and the "Select Samsung Audio (0 found) never seems to find anything.


(Rajan Kannan) #315

I have the same exact problem too. I recently got a new R1 (WAM1500) speaker. I’m trying to add to ST since more than a week. Still no luck. Its not detecting my speakers always “Select Samsung Audio (0 found)”. My R1 speaker works fine with samsung multiroom app. Its always in wifi mode. I have even set static IP. I also changed my routers and nothing seems to work.

I emailed ST support and the steps they suggested which i knew already did not help in anyway. This is so frustrating to make it work with ST.

@Tyler I would need your help on this.

Thanks in advance.


(Stephan H.) #316

I had a similar issue when trying to re-add my R5. I had it setup previously and removed it. When trying to add it back, it could not be found. Strangely enough, I noticed that there was a speaker in my Things list (that didn’t respond to any commands). I deleted it and ran the Samsung Audio Connect and it found my speaker. I would verify there aren’t any unknown or speaker related “things” in your list.


(Rajan Kannan) #317

@stephack Thanks for your reply. Your posting helped me to solve my problem. After reading your post, i checked my things in the ST but i did not see any unknown speaker in the list. But I have already added my samsung soundbar to ST which was working for TTS.

All i did was removed my existing samsung sounbar from my Things list and did the step: Marketplace --> Speakers --> Samsung Multiroom Speakers (UK) --> + Connect now. It detected my R1 speaker now. :slight_smile:

You made my day. :slight_smile: I spent hours to troubleshooting this issue. Thanks a lot for your help.


(Stephan H.) #318

Np. Glad you got it working.


(Mario Fuchs) #319

No such luck for me, have never been able to add the R3 - hence nothing to remove.

For sh*ts & giggles I tried:
Things --> scroll to the bottom --> + Add a Thing --> Add Device Manually (Yeah, found it!) --> Speakers --> Samsung Multiroom Speakers (UK) --> + Connect now…

Result after yet another session of wasted 10+ mins: spinning cursor beckoning me closer to death.

sigh


(Joe Cribbs) #320

This is probably a dumb suggestion, but when I initially tried to connect with Smartthings, it couldn’t find it (endless spinning thing). While searching, I unplugged the speaker and plugged it back in. Then Smartthings found it. Could try that?


(Mario Fuchs) #321

Thanks for the suggestion. Just pulled the plug, waited 20 secs and plugged it back in.

  • Made sure WiFi mode was on without playing anything: nothing
  • WiFi while streaming TuneIn: nothing.

Event log: dab41c1b-31b7-4760-bd9d-050175689c18 19:40:21: debug getChildDevices(false), children=0

EDIT: added a new device in the IDE, set it to SamsungAudio and tried to use the MACid (with and without “:” between the octets) and IP address. No dice.

Starting to suspect the network. Is UPnP really supposed to be enabled on the router?


(Mario Fuchs) #322

I have been in contact with ST-support.

It would have been nice to have the information that the official integration does not encompass the devices listed, those are only for the US marked.

For UK, I was referred here: https://www.smartthings.com/uk/compatible-products/
only to find that 1 device is integrated, the HW-H750 Wireless Multiroom Soundbar.

Feeling bummed.

So, how do I go about to make it work unofficially? UK hub, located in Sweden.


#323

I run one r6 and 3 r1 lite in sweden with uk hub. No problems at all.


(Mario Fuchs) #324

Interesting. Did you have to do anything out of the ordinary to get the speakers connected? No the Multiroom hub?


#325

What is the multiroom hub? I only have the smartthings hub and the speakers. Try to remove the smartapps. Restart the speakers and then add the smartapps back again.


(Nick_S) #326

Hey there

When you say you got the R6 “running” - what exactly do you mean?
What do you use the R6 for?


#327

i did set up a text to speech when things happened. but turned it of after the test. Havent decided how to use it yet.


(Nick_S) #328

And the txt to speech did work?
That was my usecase, but I have about 20-30 seconds delay between the event and the announcement, so it ended up being pointless