Need to get zwave signal to my detached garage

I need some help getting reliable zwave signal to my detached garage. Both my house and garage have aluminum siding, so to try to get around that, I put a zwave plus micro switch behind the outlet on the side of the house facing the garage. That seemed to work for a while, but in any sort of rain or snow, or just randomly, both devices in my garage lose connection.

I’m throwing around the idea of buying a 2nd hub to put out there, but I really don’t want to spend that kind of money. I already spent $40 on the micro switch thing.

(I’ve moved this to projects so you can get responses based on your individual set up.)

There’s an article in the community – created wiki on how to automate an outbuilding that might be of interest. It covers most of the options:

1 Like

Would a real zwave receptacle work better than the relay switch behind a normal outlet with the antenna snaked to the outside of the box?

Something like this:

This is what I have now:

I think my problem is that the relay thing is OFFLINE in the ide, so it’s not sending the zwave signal to my garage.

How do I get this thing back online without tearing apart the box (it’s going to rain for the next couple of days)?

The receptacle still has an anntenna behind the face plate. At least for the relay you could sneak out the anntenna so it’s unobstructed. A repeater function will work wheather the relay is on or off.
Is your relay working properly? If it is, not much you can do besides a dedicated repeater. If it’s not, exclude and reinclude it. You don’t need to tear anything apart. You can do it from the outside switch.

OFFLINE status in the IDE means that the device has not been reached for quite a while.

That could be caused by a device failure or by it being out of range.

The first thing to do would be to run a Z wave repair and see if that brings it back.

If that doesn’t help, you can try adding an additional Z wave plus repeater, even just a plug-in pocket socket, fairly near the failed device, then run another Z wave repair, and see if that helps. For some technical reasons, I would specifically recommend using a zwave plus repeater device, not classic Z wave.

If that doesn’t help, then you’re going to need to look at the individual device. You need to check it physically to make sure all the connections are still good.

As far as switching to a receptacle rather than using an inwall micro, it might help, and it might not. It’s not that one style is intrinsically better than another, and in many cases the micro ends up being situated about in the same place as the built-in radio is anyway. But it may be that the all-in-one device does have a better design for getting the antenna closer to the front of the receptacle. It’s just one of those try and see things.

One other thing you might consider is whether you can move the micro that you have now to a different place on the circuit. There’s no reason it has to actually be in the receptacle box. If you can bring it into the interior of the house, maybe at a junction box, then it might be a lot easier to get signal to it. But that’s just going to depend on your specific wiring.

I do have the antenna snaked outside of the faceplate.

The device shows offline in the IDE, and in the app, it’s stuck at ON (I don’t even have it hooked to anything other than power, I only bought it to be a repeater.)

I tried a zwave repair, no go. How can I exclude and re-include without taking it all apart? I checked the manual and it only mentions pushing the button on the device itself.

I’m at work right now, can I do it remotely or do I need to be there?

No. Remote pairing is not possible. Ifnothing is hoocked up, no luck. If you had a switch connected to the input wire, that switch acts as programming button. Include/exclude involves tapping it 3 times.
Did you install a device handler for it? If not, this is what I used when I had it
I returned it on advice from their tech support as it didn’t perform properly.

It’s on it’s own breaker, so that should work, correct? I’ll give it a shot when I get home. I’ll try the new device handler too. I was just using whatever it was detected as, Z-Wave Switch Generic.

Only if the breaker is on.
Also, keep in mind that most devices have better device handlers released by developer. The one I linked to I modified it myself and it worked.

So couldn’t I flip the breaker on/off 3 times?

Unfortunately, no. That would cut power to the relay itself, which is not what you want to do when you’re trying to reset it.

When you have a switch wired to the relay, the switch doesn’t actually cut power to the relay, it’s just sending a pulse communication to it. The radio itself remains powered because of the way it is wired into the circuit.

So toggling the switch works the same as pushing the button on the micro itself, it’s a pattern that can be captured and recognized by the micro.

If instead you throw the breaker you are cutting power to the micro, so that it would only see one on/off each time rather than the multi tap pattern it needs to initiate a reset.

Gotcha. Looks like I’ll have to dig into it once it stops raining. I think I may replace the receptacle with one of those 1/2 switch deals, where there’s a switch and outlet in one in case this happens again.