Mobile Phone Presence 2022

Hi, Now that the latest updates have been rolled out could someone tell me the cheapest, easiest way to get two mobile phones working as presence sensors? I just want the tile on sharptools to light up when they are present and to go dark when they are out of range.

Brand and model of the phones? There are different options depending on the phone’s operating system.

They are both newer android phones, a S59Pro and OnePlus 7 Pro

So is it that the presence works fine to trigger smartthings routines, but you just want a visual indicator for it that will show up in sharptools?

Or are you saying that the presence detection itself isn’t reliable for you?

To get SharpTools ready for the transitions that are about to start taking place, you should migrate your account to the NextGen SmartThings platform, details here:

If the native SmartThings presence is working on your phones, then once you re-authorize your devices to SharpTools, you will see the phones as devices in SharpTools, so you can add them as Things to your dashboards. They will add a presence sensors, so you won’t have to tweak much, if anything, after adding. Perhaps the labels and the icons.


The presence detection doesn’t work. It shows the devices as always being home.

1 Like

I’ve been using this for some time (thank you @TAustin) and at least for me, it works well.

BTW, I know you don’t have iPhones, I’m not sure if this works for Android or not…

1 Like

Thank you so much, I’ve been searching for hours.

Sadly I’ve already migrated over and re-authorized the devices and my phones are still showing as being present when they aren’t.

I’ve followed their instructions before the migration and can see the phones on the IDE site but I can’t see them on my smartthings app. smartthings mobile phone as device - Google Search

So SharpTools simply picks up what SmartThings reports, so your hurdle is going to be getting SmartThings to report the location properly. Mine have always worked on Android, but it’s been hit or miss for others.

In the SmartThings app, select Menu (lower right), Settings (gear cog top right), Get Your Location from this Phone and make sure it’s turned on for your location.

In the Smartthings app, select the 3-dot menu (top right), Manage [your location], Geolocation. Ensure your home location is set properly. You can try expanding the radius.

In Android, from the Home screen, swipe down to open the shade and select Settings (gear cog top right), Apps, SmartThings and select Permissions, Location and ensure ‘Allow all the time’ is selected.

It seems they will not show the phones as virtual devices in the available devices list to turn them on and off with their geolocations so it’s useless until they do something to repair this. I will wait and see what they do before I am forced to download apps. Thanks for your help Bryan.

I’m running SmartThings version

To see the phones presence statusin the device list you will need to create virtual devices and link the phone with the virtual device through automations.
There are a couple options available for virtual presence sensors, just search for “Virtual edge”

1 Like

Thanks, I’ve already set up the virtual presence plus in IDE but the devices aren’t available in the app since the latest upgrade.

Did you try creating the virtual devices in the app using edge drivers?

Maybe I’m misunderstanding, but since your goal is to display the presence in a SharpTools dashboard, you’re only concerned with if the phones are exposed to SharpTools. You don’t need to see them in the SmartThings App as a device. And I don’t even think you need to toggle a virtual presence sensor.

Did you look in SharpTools to see if the phones are exposed? I have found that I can add my phones to a dashboard directly as things. When I do that, they add and reflect the presence status.

In my screenshot below, you see my phone twice as I have two locations authorized in SharpTools.


As a trick I use, I periodically resize the size of my geofence in SmartThings or move it completely. This seems to in my case keeps it working most of the time.

@Robin_Cross … my wife and I have iPhones and my son has the Z-Flip. I added all 3 of us to the ST app. What I found is that for the iPhones it works fine. But for my son’s (Android) the Wi-Fi HAS to be on for ST app to see that he is within the geolocation. Just a thought .

One thing i had to do with our phones (Samsung S20+ 5G) was to change the permissions for the SmartThings app to have location access all the time.

After that, they worked much better for presence detection.