Jasco ZWave Switch Exclusion Headache

After my headache with GoControl Motion Sensors last week and them having driver issues, It seems that I have 14 Jasco Light switches / Dimmers (Z-Wave) that have the correct ‘Fingerprint’ but do not show a driver. These seem to work in general, but are slow to respond and do not show up in the Favorites ‘Lights’ on the app to show what lights are turned on (All the Z-Wave Lights that show a driver, usually Z-wave Switch show up in the Lights section correctly, but the ones that do not show a driver do not show / list the lights.)

When I had the GoControl issue, it was pretty easy to delete them, exclude them one at a time, but these switches (I tested one) even though deleted, I cannot seem to exclude it, let alone re add. These are the first gen GE / Jasco Z-wave switches / dimmers with no reset options.

Could this be because I am doing something wrong, or because this one for example is on the far side of my house, if the distance is an issue, could I use one of the GE Remotes to exclude the device as I can put that within a few inches of the switch / Dimmer?


*** Note that I had hoped that Z-wave repair would have helped, but after running for over 3 hours it never seemed to finish. ***

First, we need to know the specific model numbers of the devices that are not excluding. Different Jasco models have different tap patterns. :thinking:


I believe it / they are a ZW3005. 12724. ST is reporting it as: 4944-3031 / 0063-4944-3031

The manual I have for this device (I have 3 of them at this location) says, “Once the controller is ready to add your device, press and release the top or bottom of the dimmer smart switch (rocker) to add it in the network.”

The instructions for removing the device from the network are much less helpful. The manual says, “To remove and reset the device: Follow the instructions provided by your Z-Wave controller.” What that means, I assume, is once the hub is in exclusion mode, (probably) use the same single-tap of the top or bottom of the rocker. My experience is sometimes you have to repeat it several times to get the hub to “recognize” the device wants to leave the network.

The manual goes on to say that while including the device, “Your controller may need to be within 10 feet of the device to be added.” That’s not usually the case with excluding a device, as the hub is already talking to it.

1 Like

I have tried everything to exclude and nothing, and it will not add back either. As for the hub being 10 feet away when the switches are 120 Volts and hardwired in, that is a big issue. ST should just allow us to manually edit all info, and select our own driver, but no, more ST Stupidity.

Not “adding back” implies it is already excluded? You can’t add a switch that’s already part of the network!

Did you try pulling the air-gap on the switch to cycle power and re-boot the switch’s electronics? That might help…


I have 92 Z-Wave devices, most Jasco and GoControl, over the years I have replaced numerous of them with the same devices. This will not exclude and wondered if it did not delete properly to add it back, as that has happened numerous times before. this however will not exclude or add back. I have done the Airgap, and the the two button push trick, but on this nothing.

1 Like

I think I have solved it.

  1. Turn off all lights and anything that makes interference in house. (if you can, disable smart lighting too as this seems to slow the system down a lot.)
  2. Delete device from the my.Smartthings webpage (not phone)
  3. Pull airgap for minute or 2
  4. Put airgap back in for 30 seconds, then select exclude. Tap up / top / on 3 times quickly on the switch / dimmer. If this does not work, pull airgap, wait 30 seconds or so, and place your finger to push in the airgap and press the bottom button at the same time, this worked 3 times for me.
  5. Put in paring more for scan, then press up 3 times quickly, pause couple seconds, and keep doing it until it reads. (Everyone seems to take 30 seconds.)
  6. Laugh when Alexa finds the device before Smartthings does.
  7. Have fun adding all device back to all the routines and automations.

(Note for part 7. Doing one device at a time is much easier to add back to the Routines / automations and stuff.)

TIP. Don’t stand in front of the device when trying to exclude or add it back, and don’t put you hand in front either, try and reach down with just a finger so it does not block the antena.