Iris Smart Button

Ok, here’s a device type for the Iris Smart Button (3460-L). Both temperature and battery reporting are now working.

8 Likes

I updated the device type on mine. This is how is shows up in the app. I won’t be able to actually test it until later this eventing.

Same thing here. And nothing in the logs when button is pressed.

Just got mine set up using Dennis’s device type.

Added custom device type, tried the hold button in while inserting battery trick to try and reset it, eventually moved it closer to the hub and it paired up.

Battery level is showing 77%. I wonder if it was a returned item or i really used 23% by trying to pair it.

Now that i think about it, is it possible the 77% is really the temperature? I am not seeing a value for temperature.

Maybe, but it sounds like a tier report:

2 Likes

Try resetting and re-pairing to hub. Don’t worry about deleting from ST or anything. That will make sure the configure commands are sent when it’s awake during the join process.

2 Likes

Yup had to exclude, reset, include. The battery latch sucks. It broke already. :frowning:

So I got this kinda working. I removed it from Smartthings and reset it up. After like 5 tries it finally found it as the Smart Button. I set it up using button one. The problem was with just a push it registered it as an push/hold. I went in and upped the time longer from 3 to 7 and now it sees a push as a push. It’s showing the battery now, but it still doesn’t look right and there is another tile with nothing in it. See the pics below.

That will be temp. It’s possible it just hasn’t reported that yet, but most likely the temp reporting in the configure didn’t get accepted correctly. As annoying as it might be, I’d try resetting and re-pairing it very close to hub and not pressing the button or anything for a couple minutes after it joins.

Alternatively, if you’re familiar with the simulator in the IDE, you could try triggering configure() from there. You’ll want to press the button to wake the device up and immediately trigger configure.

I have never used the simulator before. And honestly, I’m not that too concerned about the lack of temp. I’ve got it set up to when I push it I get a push notification and my Mac tells me someone is at the door. It’s really all I ever wanted to use this for. It’s fine for now.

1 Like

Mine looks the same way.

I was finally able to pick up my kit today. I’ll play around with it and see if I can’t iron out the issues.

2 Likes

I guess mine came with a dead battery… won’t pair up or show any lights.

Temperature reporting should be fixed. Github has been updated with the fixes. Link to original post (maybe this should be edited into the top post?):

4 Likes

You are awesome! Now if my lowes would just get the darn things in stock…

I just went up and updated my original post.

2 Likes

How do I open the battery compartment without destroying this?

I was wondering the same thing… It keeps losing connection and then draining the battery, I’m already at 55% after 2 weeks…

It’s a pain in the butt. On one of the sides, you will see a little tab sticking up. Holding the button so that the little tab is on the left, slide it to the right. After this, the best think I found was to grip the sides and make the motion like you were packing new cigarettes but don’t hit the device on your palm. You can also use a small knife to pry it out after pushing the tap to the right but you risk damaging it. Seriously it’s just a big pain in the butt.