I'm so new... claim hub

Hi, I’m a new user to Smartthings and I am trying to get started. I have my phone hooked up to Smartthings but when i log into my hub list, it says “You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub”

Any ideas?


Try logging in from this page…


1 Like

You should have gotten step by step setup instructions with your hub. If not you can find them here:

1 Like

Thanks, that worked!

thanks for responding. I went through the setup and have smartthings working, but when i logged into the API site it said it wasnt working. @arn357 provided a different link that helped.

Thanks again.

Glad to help out

Just for future use, your hub actually was listed under “My Locations”.

If you had clicked on the hub name there it would bring you to the correct login page which is the server your hub resides on https://graph-na02-useast1.api.smartthings.com/

I think this is because the original ST servers are “full” that the instructions refer to so all current ST hubs being setup are going to this latest server bank? Anyway for whatever reason it is a total confusing and poorly implemented kludge by SmartThings that causes unnecessary confusion. I’m sure it’s on the back burner to get fixed one day but I sure hope it comes AFTER they add entry/exit delays to Smart Home Monitor. Note to Self; file under “When Pigs Fly” :slight_smile:

1 Like

I am having the exact same issue. I have tested all of the posted links for different shards (as seen here FAQ: How to find out what “shard” (cloud slice IDE URL) your Account / Location is on?) and jumped between the different tabs. I still get the “You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub.” I get the same error under “my locations”. I added a location and it changed nothing.

The hub is working and controlling lights, a/c, locks, etc.
I want to update the system so I can use some MCT - 340E sensors.

Am I missing something?

EDIT: After loging back in and out a few dozen times (and creating a smarthing account as opposed to a Samsung account, which affected nothing). It seemingly worked out of the blue.

1 Like

I was having the same issue, so I went into my locations tabs, then edited the name of my location,
went back into my hub tab and their it was, not sure why this worked out this way but its worth trying
if you are having the same problem.