SmartThings Community

IKEA Trådfri


(Steve ) #503

Great so they weren’t fully resetting good to remember.
I would like some of these I just don’t fancy having loads of “things” just for 1 light fitting.


(Ben Erkens ) #504

Hi Stefan,

Buy a cheap lampholder with GU10 fitting, add a mains cable with plug and install a switch in the cable. Put that together.

Now you can bring the bulb you want to pair near the ST hub or reset a bulb.

Grtn Ben

images

download%20(2)


(Darren) #505

@Steveuk23 I did my gu10s one at a time using the existing ceiling holder. If you do them all together some join others don’t, then you try to remove some remove some don’t.

One at a time, slow and steady wins this race :slight_smile:


(gavinM) #506

Can you group the gu10 s together for control,rather than have 10 separate ones in a room? I know you can add all 10 to a single smartlighting function, but is that the only way?
If you have 100 in a house that is alot of single Things!


(Kenneth Eriksen) #507

U could create virtual switches that controls the bulbs - one for each room… And then just flip the virtual switches…


(gavinM) #508

Ah yes! Thanks.


(Darren) #509

@gjgm I use the trend setter community app to group my lights… Its great, check it out here… You can create all manner of light groups/groupings. Once you create a group name add whatever individual lights into it and one button on/off all lights in the group respond accordingly.


(gavinM) #510

Thanks… I ll take a look at that too.


(Steve ) #511

You can use all them but you will still have 100 things listed on your app for 100 bulbs :frowning:
I’d love the ability to hide a device from the list and also arrange the order to suit me.


(Stefan Slater) #512

The number of bulbs showing up is a pain! It’s a shame they can’t be grouped. I think you can reorder them by holding the thing you want to move…just pointless when there’s too many to scroll through.

The ease of use and GUI of the ST app does let down how powerful it is. shame really.


(Derk G) #513

Hi, I just got into the whole Tradfri + SmartThings game. I’m running into the problem where switching to a scene, that introduces both colour temperature and level change at the same time, results in the level change not being carried out. Oddly enough this seemed to be working yesterday, but after some mess-ups with the dimmer button I went and re-paired the lamps and now I’m having this issue.

What can I do to resolve it? The key seems to be to introduce a delay between the two commands, and the below bit already seems to be in the device handler to do just that:

  delayBetween([
    zigbee.setLevel(value),
    zigbee.setColorTemperature(colorTemperature)
  ], delay ?: 0)

However I do not know enough to evaluate the above and determine if I would need to change it, and to what. Or am I barking entirely up the wrong tree?

EDIT: Never mind, I discovered it is a preference that I can set for the actual device. HOWEVER even setting it to 5000 does not seem to solve the issue yet. Looking at the events log, as far as I can tell the delay is not actually included:

Date Source Type Name Value User Displayed Text
[ 2018-12-29 11:50:13.423 PM CET moments ago ] DEVICE colorTemperature 2703 Dining Lamp 1 color temperature is 2703
[ 2018-12-29 11:50:10.190 PM CET moments ago ] COMMAND setLevel setLevel command was sent to Dining Lamp 1
[ 2018-12-29 11:50:10.178 PM CET moments ago ] COMMAND SetLevel setLevel command was sent to Dining Lamp 1
[ 2018-12-29 11:50:10.168 PM CET moments ago ] COMMAND setLevel setLevel command was sent to Dining Lamp 1
[ 2018-12-29 11:50:10.154 PM CET moments ago] COMMAND setColorTemperature setColorTemperature command was sent

(URL’s removed in the above)

At what time are the new preferences evaluated? Immediately the first time I try to control the device?

[I did try the below, but that does not seem to make a difference: “For those that assign this device handler to an already added device and who experience problems with the UI not updating values, try pressing the reload button once. That should then fix the issue and the values should update as expected.”]


(Jack Whittaker) #514

Hi,

I am new to Smartthings and have recently purchased some Ikea Tradfri bulbs, which are paired via Edvald’s device handler.

However, the UI appears different to the screenshots I have seen posted. I am unable to use the pre-set colour temperatures and the colour temperature slide is not working correctly. I am assuming this is because I am using the new app, not the ‘classic’ app. Should the device handler work on both or only on the classic app?

I would just try the classic app, but because I never had it I would need to reset my hub to reactivate my welcome code.

Thanks

Jack


(Laurent Mikolajczak) #515

Hi all,

Playing with ST, Ikea Tradfri, Xiaomi Aqara, Osram bulbs,Trust zigbee, and other Z-Wave devices (just received my Sensative Strips). All is working quite well until now. I am surprised by the amount of possibilities offered by SmartThings alone. Add it IFTTT…

One thing would be awesome : I bought 5 Ikea Outlet kits (plug + mini on/Off Remote). The outlets are working fine. And the small remotes are just perfect (to me). Small, with clear ON / OFF indication.
But I did not succeed in pairing them with ST hub (V3).

Did anyone played and succeded with pairing them ?

thanks,

LaurentM


(Steve ) #516

Have a look here IKEA Tradfri Button -- help needed (DTH in post 36)


(Mehrdad Moshar) #517

Hi everyone
I would like to pair my IKEA trådfre lamps with both SmartThings hub & IKEA 5 button remote. I can easily pair IKEA trådfre lamps with SmartThings-hub, but can not pair IKEA 5 button-remote with SmartThings-hub.

Is there any device-handler for KEA 5 button remote?
Is there anyway to control IKEA trådfre lamps with both SmartThings hub & IKEA 5 button remote at the same time?

Thanks in advance…


#518

I’m reading through the whole (long!) thread, but as a lot is old can I ask for current status please on few questions?

  1. Adding the GU10 directly without Ikea hub works ok now? With inbuilt ST DH or which custom one please?

  2. Can you reset the bulbs easily without any Ikea remote or hub in case of problems?

  3. Can the bulbs get firmware updates direct from ST or would you need the Ikea hub for this?

  4. looking at the Ikea Tradfri iOS app reviews seem to be a few problems with disconnecting, not working, are they ok with ST direct?

  5. What size exactly are the GU10 £7 ones please? I’ve had a few smart bulbs that are too big for my fittings before.

Thanks


(Darren) #519

@R2D2

In relation to your queries, I have bother the £15 and the £8 GU10 ikea bulbs

1 - they work fine directly with ST hub. You do not need the IKEA hub. I have used both custom DH and recently move over to an inbuilt DH as it runs locally. As @JDRoberts likes to say, choice is good :slight_smile:

  1. Yes, just turn on /off the light 6 times.

  2. My understanding is you will need the IKEA hub , but the lights can only be associated with one hub at a time. I have had my lights for over a year and never upgraded their firmware.

  3. Yes work fine with ST.

  4. Like you i have had the GU10 bulbs extend from the socket. The cheaper £8 are light a regular GU10 halogen version. The £15 version does extend over so slighly , maybe 2cm, not a big issue but all depends.

In terms of difference, but versions dim and the more expensive one you can change the colour temperature , warm, cold white etc.


#520

Thanks for answers, looks like he’s fine then. Just sometimes having the Ikea hub is handy to update firmware, even just to begin with. Winner if there has been any firmware and what is done/fixed/added if anything.

They are LED according to this link on the website. I don’t want halogen.
https://www.ikea.com/gb/en/products/lighting/smart-lighting/trådfri-led-bulb-gu10-400-lumen-wireless-dimmable-warm-white-art-80365270/


(Darren) #521

@R2D2 sorry minor typo there, I’m on a travelling bus using the phone, that was ment to read like a regular halogen bulb in size. Yes both versions are LEDs.


#522

Hey Jack_W, did you add bulb via SmartThings Classic?
I’ve added my Floalt lamp via SmartThings Classic using Edvald’s device handler and it works fine. However when I open the new app, interface is a bit broken, light temperature is being shown as 100K.
I wonder if it’s something in Device Handler that needs to be changed to support new app, or it’s just incompatible.