Ikea RGBW Bulb suddenly not controlling color

Good evening all,
Late last week or early this week my Ikea RGBW bulbs stopped changing color.
Attempting to change the color in the ST App the shown color changes (not actually on the bulb, just visually in the ST App), but a few seconds later changes back to the default white color to match the bulb itself.
This has happened on two separate bulbs, and only started recently (prior to this they have been working perfectly).
They are currently using the “ZLL RGB Bulb DTH” (as automatically set). I tried ZLL RGBW Bulb, Zigbee RGB Bulb, and Zigbee RGBW Bulb, but the result was always the same.
Anyone else having this issue, and/or have a fix?
Sincere regards,

Hi @rcarmichael
If you can send the model of the bulb shown in IDE, we can see if it is in the stock edge driver beta smartthings zigbee Switch or it could be added to the Zigbee light Multifunction Mc driver

I was having issues with the colorControl capability last night on all of my devices, but it seems fine this morning. I’m guessing this was another Android app issue.

It only seemed to impact detail view. I was able to change color using a scene or routine. You should also be able to use Alexa.

Thanks for your reply @Mariano_Colmenarejo.
The model as listed in the ide is:
TRADFRI bulb E27 CWS opal 600lm

Thanks for your reply @philh30. Unfortunately not the same for me, even utomatons sing WebCore were affected…

This model is on beta stock smartthings driver Zigbee switch and un my driver Zigbee light Multifunction Mc.

Have you already used an edge driver instead of DTHs?

  • id: “IKEA/TRADFRI bulb E27 CWS opal 600lm”
    deviceLabel: IKEA Light
    manufacturer: IKEA of Sweden
    model: TRADFRI bulb E27 CWS opal 600lm
    deviceProfileName: color-bulb


This is the Edge drivers tutorial and link to Channel for smartthings beta Edge driver

This is the link to my shared Channel with all my Edge drivers

Thanks @Mariano_Colmenarejo I’ll see if it fixes the issue.
(I’ve used Edge Drivers previously but have not had a lot of luck, they didn’t seem to work with a lot of my zigbee devices).
I’ll report the outcome accordingly…

colorControl on my edge drivers still not working. Like you, it works in routines and scenes, just not from the detail view.

1 Like

Checking again and, yes, same for me. Edge driver device doesn’t do anything with colorControl. DTH/Hue devices mostly give a network error, but will very occasionally work properly.

Unfortunately I haven’t had a chance to test out the edge driver just yet.
However Ive noticed that a ST routine is no longer running; it is only controlling a virtual device. I can’t help but think these two issues are related…

And today all miraculously went back to working again!
Regardless, thanks everyone that commented!

1 Like