Ikea 5 button remote killing batteries

Sadly this is not the first time someone at Samsung has said they were “looking into this”
Regardless lets hope. that Samsung get this fixed.

If he needs my hub address too… I am happy to help.

2 Likes

It sounds like they have problems recreating the issue on demand. That I can understand. I’ve just had a button last four weeks then need two batteries in two days. That’s completely different to early April when all buttons repeatedly failed inside two days.

I’m increasingly convincing myself that if there is a trigger it is a change of route, and I remain suspicious of the IKEA Outlets.

2 Likes

I was surprised to get a reasonable response back from Ikea. Maybe if enough people report an issue the. Maybe they will be more likely to do something about it?

1 Like

I’ve been following this for a while, but first time commenting.

This may or may not be of help, but I’ve had one of the 2-button dimmer switches last over a week now after it had previously been chewing through batteries in a day.

After fully removing it from ST, I added it again, then changed it to a generic ZigBee Button in the My Devices section in the online portal. After saving and restarting the app, I then switched it back to what it should be in the online portal (IKEA button), and it’s behaved ever since. Been over a week now. I was trying to see if it would work as just a generic button, but it didn’t.

As a slight aside, the Tradfri Shortcut button, the single button one with the removable cover, works if you set it to a ZigBee Button in the online portal (think someone has already mentioned that). You don’t get press and hold, but at £6 a pop I don’t mind that it’s single purpose.

That’s part of the problem though. They can work for weeks then suddenly eat a battery the next day. When I first had the issue, a month or so before the Zigbee firmware update was pushed out into production, the failure rate of the batteries was 100% and none would last more than two days. It was also like throwing a switch. Firmware installed, wait an hour or two, buttons start failing. Couldn’t have been more correlated. So I was actually expecting the sky to fall in when the wider user base got it. It didn’t though. There was a slow realisation over a period of weeks.

I tweaked the IKEA Button handler to support it as a single button version of the On/Off Switch (which it is basically, it even uses the same firmware), even keeping the use of a component to avoid unnecessary refactoring. Can’t quite get the presentation to behave though. It claims to be using one presentation but what it is actually using is something different. Very odd.

For six squiddlies a pop, the buttons are a bargain (or were). The magnetic mounting is hopelessly weak though (or you could perhaps better argue that the magnet is fine but the mount needs a larger lip around the edge), and the buttons too easy to press. Many is the time the button has gone flying off the wall and pressed itself when it lands. As with the two button On/Off I’ve actually stopped using the buttons for cases where accidental presses would be a nuisance.

I agree, I have no proof, only suspicions. I have 7 IKEA blinds in my main bedroom. (weird layout) and my Smartthings hub is in the same room with them… 6 of the binds have normal battery life one drains every 30 days. The button in the room seems to work as expected… But buttons elsewhere in the house (that would need a repeater) ALWAYS have the drain problem.

The way that IKEA binds their buttons to repeaters and then devices is not standard and I think is part of the problem. I have removed ALL of the repeaters now. And will see if the battery issue improves… But this makes the buttons useless for anything other than driving a device within range of the main hub.

For smaller apartments that probably works… for bigger homes that is not going to be an option.

If “Blind 7” continues to have battery drain problems I will try deleting the device from Smartthings and then reconnecting it without any repeaters. I’m lucky as every other smart device in my house is ZWave, but if you have other Zigbee “powered” devices I think you can’t get around this problem.

I just changed out the batteries and replied to this. Hopefully I will hear something back from them. It’s nice to see someone from SmartThings looking into this.

I have deleted my remote control (Ikea) and connected it and updated it via Ikea Gateway. Then I set it up again in ST as a dimmer and right now, a day later, there is 100% power on the battery. I’ll probably write a new status July 7th.

Sorry but it took a long time to get approved for this forum. Two days after the batteries were replaced, they died.

Yep, the eventual rapid failure of the batteries is pretty much as sure as eggs is eggs. It can vary from hours to weeks but sooner or later it seems to catch up with you. If you have buttons that are susceptible the only way I know to avoid the problem is to use a SmartThings hub with the older version of the Zigbee firmware on it.

1 Like

I just wanted to say thanks to everyone who keeps this thread updated. Many may users may not post here, but I am sure a lot (including I) are still suffering…and waiting for some kind of fix :slight_smile:

5 Likes

More than a few of us have tried this… convinced that it really can’t be the complicated. Before you waste more batteries, every possible combination of pairing, linking, hubs, etc has been tried.

I even got a couple of Zigbee USB sticks and tried to use them on Home Assistant on a Pi4…

Sadly these buttons are useless on anything other than an IKEA Hub… and the Software on the IKEA hub really limits their use. To the point that they are useless there too… I keep my Ikea hub on the hopes that someday they will push out a firmware update… Or that IKEA will fix the useless software on their system.

This is a total shame, Smartthings could use these buttons to drive any smart device. They were cheap, nice to use, nice to look at, east to set up and install… The Smartthings (and other Zigbee hubs ) were updated over the last 6-10 months And now they are useless

I’m am working with one of the developers on this problem. I am going to be sending them one of my buttons affected by this problem so they can reproduce it in house and address the issue.

3 Likes

Sorry, I got it into my head that this started in early April for me. It was actually the evening of Thursday March 18th. I lost three weeks somewhere.

1 Like

Hi. I have read as much of this thread as possible, but, due to the number of posts, may have missed something anyway. :blush:

My question: Has anyone who uses the V3 Hub or the “Aeotec Smart Home Hub” also experienced the problem so far? (These should, as far as I know, be identical in construction.)

I’ve been using the Aeotec Smart Home Hub myself since late 2020, have over 10 Ikea devices in use - including 2-button dimmers, Shortcut-Buttons and Styrbars. The battery indicator is not correct for almost any of the devices, but I have not had to replace any of the batteries so far.

1 Like

Hi,
So, buying the Ikea hub and then updating the buttons to latest firmware won’t help? Should I bother spending the money on the hub to update them?

Thanks,

Correct, updating the firmware on the buttons does not help

Thanks, I guess will stop wasting batteries until someone reports issue is fixed.

Thanks.

1 Like

Here’s a update… I have received a shipping label from one of the developers at SmartThings. I will be shipping them one of my Ikea buttons affected by this problem so they can reproduce the issue in house and hopefully work on a fix for this issue.

I will post updates as I get them if I get them.

8 Likes

If they need more I have several across a few flavours (including blinds) and am really missing being able to use them :frowning:

2 Likes