HUE Sync box shutdown problem

Hi all,
as title says I have problem with Sync box (I think that is the problem). What I want should be very basic automation/routine, and it is, but it gets me headache :smiley:
I just want when I go to bed, to shutdown everything in livingroom.

I use Tradfri dimmer (2-button one), and I made routine (when I press button) to turn off all lights and a TV.
When I’m watching standard TV channels everything works fine. But when I’m watching anything on Nvidia Shield, and then push that “kill switch” :smiley: everything shuts down except Sync box. And that causes lightstrip that is working (and syncing) as TV backlight, to stay on.
I have checked all CEC settings, on all equipment, and to me everything looks fine. That includes Nvidia Shield (2017 I think), Samsung soundbar (HW-Q800AWWB-1009.2), Syncbox (HSB1), Samsung TV (UE65TU8502UXXH), and all apps asociated with that equipment. There is setting in HUE SYNC app “CEC power state detection” - Use CEC to detect your TV’s power state to switch the Hue sync box on or off accordingly - and that is enabled.

Connection is:
HDMI from Nvidia Shield to Hue Sync box, from Hue Syncbox to Soundbar, and from Soundbar to TV (eArc ports).

As I am really basic user of Smartthings, and would like to be average consumer type, plug and play out of the box :slight_smile: but whatever I touch in Smartthings, forwards me to some sort of programming that I am not keen on.

So as I realised I cannot turn off Sync box if I’m watching it, I have done next:
I set scene “turn all off” (including turn TV off), I set scene turn TV to TV (because when I do that, Sync box turns off). And then I tried to set routine when I press button, to run scene (turn TV to TV) and then to run scene “turn all off”. I did it like that because when I use TV in routine and want to do 2 things (1 of them is turn TV off) it doesn’t let me to switch to TV channels and then to turn TV off. If I want to turn it on, then I can do other actions but if off is included, nothing else can be set in this action. But even when I did 2 scenes, as they both include some TV action, it doesn’t let me use both of them.

For now I do it with to actions “press” and “held” but that is not solution, as when I want to go to bed, I’m usually tired, and thinking about what type of pushing that button I have to preform first is not good way of quickly slipping to bed :smiley:

So, any ideas how to solve this simple action, without WebCoRe (as I said, I really don’t like to spend hours of learning how to do it for 1 simple action, and I’m not much of a programmer), and without IFTTT (as I really don’t like to pay them monthly fee just for shutting everything off before going to bed)?

Sorry for long post, and thank you for any ideas.

As the Nvidia is the source, does it turn off in this case when the Sync box doesn’t?

Maybe you need to check the CEC settings in the Nvidia Shield. It could keep awake the Sync box if it doesn’t power off. (Just guessing…)

Otherwise is the Philips Hue integration brings in the Sync Box as a device?

Do you get any option for the TV to use in an automation?

You could build an automation if the TV turns off, then turn off the led strip…

Or if the sync box is part of the Hue integration maybe to turn off the sync box.

After few days of playing with this, I finally managed to solve it. I’m not completely satisfied with end result, but for now it will work.

So, if you want to make 2 actions (and one of them includes “Turn TV off”), ST doesn’t allow second action. If you want to create 2 scenes (and one of them includes “Turn TV off”), ST doesn’t allow to add second scene into a routine.

What I ended up doing was creating 1 scene where all “things” turn off, except TV. In this scene, I set TV to switch to “TV” (so standard terrestrial channels) because in that way it looses connection with HUE sync box, and box goes to sleep. After that I created routine where I set, when I press button, run that scene, and 2 separate actions, turn off TV (with few seconds delay), and second action is turn off led strip (with few more seconds delay).

I had to set delays because if there are no delays it will not be enough time for original scene to switch to TV channels, and I had to set longer delay for led strip to turn off because I had to “give time” for HUE sync box to turn to sleep mode so I can turn off led strip.

As I said, I’m not 100% satisfied with result, as I have delays, but at least it works :slight_smile: