Honeywell RTH6580WF options to trigger eWeLink fan?

Could I be directed to a webpage that provides such information?

I wish there was some better information, but following links may help.

It’s not official, but There is a community FAQ in this forum that explains how to do it:

FAQ: Can I trigger an Echo Action without Speaking to It?

This may seem like a real dumb question, but again, I’m totally new to this:

Does SmartThings require an actual physical device (hub) to operate? I thought it was strictly software.

1 Like

No a hub is not required for WiFi devices, but a hub is required for Z-wave, ZigBee and Lan devices using Edge Drivers. My right up assumed you had a hub.

I don’t have a hub. Given that, is my original scenario possible?

1 Like

Yes you can. You can create a virtual lock and use it to trigger Alexa routines with out a hub.


I added the information about virtual locks for those who don’t have a SmartThings/Aeotec hub to the FAQ on triggering Alexa routines from SmartThings :sunglasses:.

I created the Virtual Lock. Then on the ST app I chose “Automations”. Was that correct? I set up a time span, but then when I went to “Device Status”, it’s greyed out, so I can’t choose my thermostat or the virtual lock.

Also, I can’t find the FAQ about triggering Alexa routines from ST

It’s the one I already gave you upthread:

FAQ: Can I trigger an Echo Action without Speaking to It?

Thanks - I now understand about the Virtual lock triggering an Amazon action. That’s set up and ready to go.

What I don’t yet understand is how to make the Virtual Lock tie in with the thermostat on ST (both are recognized and assigned to the same “room”). I assume I should set up an “Automation” on ST, but it never allows me to select a device - “Device Status” is always greyed out.

1 Like

It sounds like both need to be initialized to SmartThings.

For the virtual lock, try locking and unlocking it in the Alexa app and see if that does anything for the status in the smartthings app.

If not, maybe @Paul_Oliver knows how to initialize that one.

For the thermostat, I don’t know the details of that particular integration. Can you post a screenshot of the routine that you were trying to create in the smartthings app? Also, can you post a screenshot of its details page in the smartthings app?

I just created this routine. My thermostat is a Honeywell T5 and uses the Honeywell Home app, so there is a difference.

1 Like

I, too have Honeywell thermostats and am set up with the Total Connect Comfort integration to SmartThings. With the TCC integration, there is no access to thermostats on the IF part of a Routine, only on the THEN part.

Tried to add the Honeywell Home integration but my VisionPro 8000 WiFi thermostats are not supported by the integration. I do control them via the Resideo app. Honeywell is so annoying.

Edit: seems like Honeywell has improved the TCC integration. I now have a good selection of attributes of my thermostats available for trigger conditions in Routines. Not sure if the issue of refresh time is addressed yet, when I look in history for thermostats, I see a once daily update.

1 Like

Is there a reason he can’t control the fan directly from SmartThings using the “Ewelink” linked service?
I have a very early Wi-Fi sonoff switch which I can control directly through SmartThings using ewelink linked service without having to resort to an Alexa virtual switch?

Thanks for all the comments here. Judging by HalD’s experience with TCC integration, that explains why I can’t access my thermostat on the IF part of the routine, which makes this whole endeavor a non-starter.

And, like HalD, my Honeywells are not supported via Honeywell Home integration - although I can control my Honeywells via that app, if I try to link Alexa to the app it says that no devices are found.

The fan is controlled by the Sonoff iFan04, which is not recognized by Sonoff or eWelink service (I have a number of Sonoff devices, including 8 iFan04 units - eWelink recognizes all Sonoff devices except for any of the 8 iFan04s.

It seems I picked the wrong smart devices to try to work together…

Paul_Oliver: I see the top of your screenshot says “Routine name”. I see no option in my ST app to setup a routine, only “Automation.” And as I noted earlier, I can’t even get past “IF” because “Device Status” is greyed out.

Also, when you state they should be “initialized”, I’m unsure what that means, as SmartThing operates my thermostat just fine.

“routine” is the official term for the type of automation you can create through the smartthings app.

There are two ways to do this, they eventually take you to the same part of the app.

  1. from the favorites screen, choose the + in the upper right

Then choose “create routine“ from the next screen

  1. from any screen, choose “automations“ from the bottom menu line

This will take you to a screen that says “automations“ at the top.

Choose the “+“ and then “add routine” from the pop-up.

You can ignore that comment. It doesn’t apply in your situation. Sorry for any confusion.

Thanks for that info. Sure enough, when I got into the “Sleep comfortably” routine under “Temperature Control,” it shows no supported devices.

Pretty frustrating, since all I want ST to do is to take action when the thermostat’s temp gets to a certain point, which is readily displayed when I access the thermometer via ST.


Finally got it to work! Based on posts from around 2020 in this forum specifically about my thermostat, I downloaded and installed an earlier version of ST (1.7.43-22). Everything after that went fine and all has tested OK.

Since I wanted ST solely for the one function of starting a ceiling fan when the room reaches a particular temperature, I’m fine w/ this earlier version.