SmartThings Community

Harmony Home Control

In fact I picked up the remote couple of days back and there was a prompt on the remote itself for firmware update. This was a first for me.

The Android app just updated to 4.7 build 11 which may avoid the issue. They changed the color theme for activities.

Just wanted to mention that sometime in the last few days a brand-new official smart app, “harmony control” (not “harmony connect”) showed up in my account all on its own and broke my harmony/SmartThings integration. It appears to be a replacement for “Logitech Harmony triggers”

It did assign itself to my trigger switches, but I wasn’t signed into harmony from its credentials page and so nothing worked.

It may have been somebody in support pushed it out to me as I have a couple of open tickets. But I did just want to mention it because it was a hard problem to track down but easy one to fix. Details here:

1 Like

Now I need to go looking. I might even be to blame since I have open ticket regarding not being able to remove a ghost switch from ST, " in use by harmony". Even though that switch was never used or authorized for Harmony I can’t remove it without removing Harmony/ ST integration completely.

Hi everybody - this is an amazing thread filled with tons of information. I worked on connecting v2 ST hub to my Harmony hub and finally got it connected by updating the firmware and then adding it to ST by selecting Connect New -> Entertainment -> Remotes & Buttons -> Logitech -> Harmony Home Hub

This worked but then after about 2 hours all my zWave devices stopped working. I removed it and rebooted the hub and they all started working again. Weird - I assume this was caused by some type of fatal hub error or maybe by Harmony trying to take over the zWave network. So based on various articles in this thread I am going to try one of the following alternative methods:

  1. indirect using virtual switch and IFTTT
  2. send event to a HarmonyHubControl service running on a PC (from @swindmiller )
  3. add ST to harmony hub to enable cloud to cloud (I think)

All I really want to do is turn on one of four different activities and turn all off so 5 virtual switches should do the trick, so I am leaning toward #1. I already have Harmony added as an IFTTT channel

By the way, I wrote to support and they gave me the same standard answer about a new integration being in beta and that I should just wait, but I read so many posts that suggest that it is working fine now.

Any advice?

Do you own an Amazon Echo? You can do voice control through IFTTT and avid creating the virtual switches.
Here is a thread where you can get all you need from the first post.

Edit: Added the link for another thread

Yes - of course - any self respecting ST junkie also has an Amazon Echo. Good idea - I will try that next. By the way, I tried adding ST to my Harmony Hub on the Harmony side since that is something I had not tried yet. The hub was found and was added easily but the same behavior happened - after adding none of my zWave devices would respond to the ST app. So I am now removing it and rebooting my hub. I guess I am stuck with IFTTT integration options for now. Thanks again for the suggestion.

Edit: But this still doesn’t solve my need to turn off the system when I trigger from ST the go to bed action. I still need a virtual switch for that.

1 Like

I have my Harmony hub connected to ST by the official ST connection. I never experienced that problem. If you add it through the ST hub, there is a possibility it will generate that behavior. What the Harmony hub does is it acts as a secondary controller for your Z-wave stuff, but only if you have the Harmony Hub Extender as well. Maybe someone with more knowledge than mine can help you on this.

If you still can’t connect it, you can create a momentary button tile and tie it to your “go to bed” action, and have IFTTT to turn off the Harmony when that switch is turned on.

Thanks man… well I tried adding it both ways and both times it generated the same behavior of disabling all my zWave switches. Oddly enough the system still recognizes my zWave motion detectors but it doesn’t respond to switch on/off commands from the app. Last time a hub reboot brought it back to life after removing. I am in the process of doing that now and hope it comes back. This is too important to muck with since we have become addicted to automated lights but not yet to automated TV. I will try the momentary virtual switch and IFTTT next but only after I bring my main features back to life. It would be more settling for me if anyone else in the ST community has experienced this same behavior.

Update:
Okay - got my system working again after a reboot and repair zWave action. And I got the IFTTT virtual momentary buttons working. They works fabulously well so I am all set. The full integration will be nice to have but quite honestly I am pretty happy with this IFTTT solution which also works with Alexa/Echo as an added bonus.

1 Like

There’s no logical reason why the Harmony integration should affect Zwave at all. It’s not the same protocol.

That said, it doesn’t mean that there isn’t something in the SmartThings architecture that is causing your local network to get out of sync with your cloud account when you do the harmony integration, Or something like that. People have been reporting that a bunch of zigbee devices will go out, or a bunch of Z wave devices will go out, when they shouldn’t. Nothing to do with harmony, just you change one thing, and suddenly you lose half of one of your local networks.

And forcing a resynch with the cloud account by taking the hub off-line for about 15 minutes often seems to fix it, even in situations when it shouldn’t.

So I do suspect some synchronization issue between the cloud and the hub but who knows?

I’m glad you got something working. :sunglasses:

1 Like

JD - as usual you are right. The problem has persisted even though I no longer have any Harmony integration points. I submitted an urgent request for support. It is annoying that there is no phone support and that chat goes offline before the documented time. Anyway I am hopeful that someone at ST can look at my logs to tell me what is going on.

In case anyone else has any ideas, the problem is at random times my hub stops responding to commands from the mobile app. Events from sensors continue to generate responses as expected and commands from the mobile app that are related to IP devices like Sonos seem to work fine. A hub hardware reset puts the system back in working order.

Edit: Apologies to anyone’s app who I thought was the problem - including Harmony and SimpleRuleBuilder - looks like I have a bad hub.

ST is helping. Looks like my hub is bad. Bummer - have to redo all my sensor again.

There is a new known issue that just cropped up in the last week or so where a number of people are suddenly losing control of all their zwave devices or all their zigbee devices. Engineering is aware of it and is looking into it. Your situation may be a different problem with the same symptoms, but just wanted to mention it.

http://thingsthataresmart.wiki/index.php?title=Bug:_all_zwave_devices_fail_or_all_Zigbee_devices_fail

1 Like

Any suggestions or to look where to start would be appreciated…I had to get away for a few days as integrating all the things was making a little cray.Now I have an issue I was wondering if anyone has any ideas.I was informed by ST support I had too many things going on.

I have a ST motion sensor that triggers my harmony home activity ‘Watch TV’,‘Activity off’, and a virtual momentary switch to turn all the things off also have added a lights off to this switch.

Now when I say to Alexa to turn all things offf.Sometimes it works and sometime it doesn’t.I was told by ST support that harmony is not updating the state to ST.

Is there anything that be done to solve this issue?

Are you using the Harmony SmartApp or the Alexa Helper SmartApp? Maybe you can try the other and see how it goes???

I am using Harmony Smartapps.I spent a lot of time figuring things to work:cold_sweat::cry: I just need to be sure its going to work i might be willing to try.But thanks for your input.

Remember that Alexa can now have specific trigger phrases via IFTTT. It is very easy to set up. Easier than creating virtual switches and going into the ST app. It won’t help for the motion detection part, though.

I was interested to know how are you guys setting up a virtual switch to control an activity. For example, i can set up a virtual switch to turn an activity on and off. Thats the easy part. But what if I use the harmony remote to start activity and then want to use virtual switch to turn it off. One way would be to update the virtual switch status within harmony activity as well… But what I’ve found is that sometimes Harmony goes crazy it goes into a never ending loop of starting and ending the activity. Has anyone observed this? Any solution to make rhis work reliably?

That will loop if it’s a binary switch.

Instead, use two momentary switches. One for activity on, one for activity off. That way each switch is always ready to use the next time, and no loops. Much discussed in the echo and harmony topics.

Same switch selection protocol applies no matter how you’re getting to the harmony activity.

So which means that if I had to use Alexa to turn off an activity, the actual voice command will be “Alexa! TURN ON Media Off”…something like that?