SmartThings Community

Haiku Fan/SenseME two-way assistance


(Gerald N) #21

Seeking for guidance on the steps to connect the Haiku fan to SmartThings.
I am probably doing something wrong, as SmartThings was not able to “Discover” the Haiku fan.

After saving the code by System48 and clicking on “Publish”,
I see the new item called “System48/Smartthings/Haiku : Haiku Fan Control” in my list of Device Handlers.

I went into the Smartthings App and did the following, but could not find the Haiku Fan. The steps I did to connect to the fan were:

Tapped My Home
Under Things, tapped Add a Thing at the bottom of your Things list
The app says Looking for devices…. It does not find the Haiku Fan automatically.
Tapped Add device manually
Tapped all the device categories, but (Light Bulbs, Locks, Outlets, Thermostats, etc.) but could not find the new device

Seeking help - After doing the step to publish the device handler, could someone can help share on the next steps in to connect to the Wifi Haiku Fan?
Thanks!


(douglaspitman@me.com) #22

I can’t seem to get this to work. is their a new version I should be using?


#23

@douglaspitman - when you say, “I can’t seem to get this to work” - can you elaborate on what part exactly isn’t working for you?

FWIW, I’m still using f7c98af0, which was last updated almost two years ago and it’s still working for me.


(douglaspitman@me.com) #24

I copied the code and can create the device with the fan but I think I am missing where to put my fans information in the code.

Thanks

Doug


#25

@douglaspitman - The device handler has input fields specified here:

preferences {
	input("devname", "text", title: "Device Name", description: "The devices name",required:true)
	input("destIp", "text", title: "IP", description: "The device IP",required:true)
 }

After you’ve added the device, you can see these preferences in the IDE. Click on the “edit” link and you can change these two:

Hope that helps.


(Carolina007) #26
  1. Add Device Handler and Publish it
  2. Click My Devices and select New Device
    3.Name of your Haiku Fan.
    4.Network id: enter the ip address of Haiku Fan (It’s in Haiku App Fan Configuration)
    5.Type: Haiku Fan Control
  3. Select your Location, Hub and Create it
    7.Open the Device you have created above.
    Preferences (edit)
    Name Type Value
    destIp text 192 IP address
    devname text MAC Address

try below, Once above is done.

Under Things, tap Add a Thing
The app should say Looking for devices and it should list your Haiku device.


(douglaspitman@me.com) #27

great thanks it now is working great


(Erwenger) #28

Ok. I think I did all this. I added the device handler. I edited the preferences. I discovered the device. But when I change the brightness or the speed in the app, the actual fan doesn’t change how it is operating. Any ideas?


(Eug) #29

I too, cant get it to work.

Is this the format for the ip and mac ?

Preferences (edit) Name Type Value
destIp text 192.168.2.49
devname text 20F85ED6B3E3

(Ron Verstappen) #30

This worked great for me - within the known limitations of not getting status.

Note to anyone having trouble. The device name must match the device name you configured in the Haiku app.


(Brandon13ke) #31

I haven’t had any luck with this after a few hours of tinkering. Can someone assist and possibly point out what I am doing wrong here?

I created a new Device Handler, copied in all of the code from here with ZERO edits: https://github.com/System48/Smartthings/blob/master/devicetypes/system48/smartthings/haiku/haiku-fan-control.src/haiku-fan-control.groovy
Saved and published it.
Next I went to ‘My Devices’ and created a new device, name and label = ‘Ceiling’, device networkid = ‘HaikuCeiling’. Type = Haiku Fan Control from the drop down, version = published, hub = smartthings hub. Zigbee ID and group are both blank.

Once created I edited Preferences and set:
destIP to 10.20.30.41 (I’ve also tried straight mac address 20F85EF1A693)
devname = Ceiling


Icon populates in my ST app, but always reports as on. Connection errors. Please help! :smiley:

My goal would be to have 2 virtual device buttons, one for the light and one for the fan, both that have percentages/dials.

My info:

ST hub v3
SmartThings new app (Not the classic version)
Alexa (Voice integration works great, no issues)
Ecobee3 also tied into haiku without any issues either
Haiku Ceiling Fan & Light
Device Name: Ceiling
IP: 10.20.30.41
MAC: 20F85EF1A693


(Benji) #32

Is your hub and the fan on the same subnet?


(System48) #33

It looks like it does not work in the new SmartThings app. It appears to be an issue with the fact that it can’t read the status of the fan.