Google Home

Thanks for the suggestion, but I already checked that out. Looks like my DNS settings are global for the router. I can’t see a way to configure it one way for the main network and another for the guest network. The xfinity access point of one of my neighbors does show up but its just weak enough the home won’t latch onto it.

So I’ve added a few ST momentary push buttons to my set up. What is the correct voice command for Google Home for these? I’ve tried “turn on”, “start”, “toggle”, and “push” and now I’m out of ideas.

“On” should work…Hey Google, turn On {switch}…be sure to check the log of the device…momentary switches do revert back quickly so you may not be seeing the change.

That’s what I thought. But GH just keeps telling me she isn’t sure how to help.

hmmm…that is odd…but regular switches work ok?

I thought so too. Yes, regular on/off switches work fine with my GH.

Ok…and you are ‘discovering’ the switch within the Google app? I have never had an issue with virtual switches…will need to try this tonight…

Yeah, the GH app picked them all up automatically. They are being used to control my Roku TV: [RELEASE] Roku Virtual Buttons

I was thinking of going into the IDE and changing it to an on/off switch, but I don’t know if this will work with device handler that these guys set up for Roku.

Try setting up a virtual on/off instead of a momentary switch to see if that helps.

Update: Yes changing it to a “On/Off Button Tile” did the trick. The GH worked no problem.

Now I’ll just use webCoRe to set the automation to what happens when the switch is turned on/off.

Thanks for the input. If you DO happen to play around with and get the momentary switch to work, I’d be interested in the solution.

I will play around with it.

Any update on this? Google Home Mini can be a perfect match for notifications with SmartThings

Check out Elliotts python script, it will do what you are looking for but requires some time/effort to set it up.


We need a funcional tts implementation/integration by St Team on Google Home/Assistant

Has anyone found that their Home doesn’t reconnect to wifi if you reboot the router? When I reboot I have to go manually power cycle the Home to get it to reconnect. I have a new Mini which reconnects just fine. Tried surfing around the web for a similar problem and can’t find an answer. I could reach out to Google support but isn’t painful enough to make that worth it yet.

Have not had this problem so far with mine.

No issues here with my original GH and the Minin GH.

Guess I’ll just have to reach out to support. Sadly I think I’m out of warranty (assume a year) if it’s a hardware issue.

@farlicimo I had that issue and I think they pushed out and update just recently. I’m not having any issues now.

1 Like

Thanks for the tip. I just rebooted my router and seems to have reconnected fine.

1 Like