SmartThings Community

Geofence issues


#1

I am having a lot of trouble getting my alarm to disarm using my phone as a presence sensor. I have increased the radius up to 700 ft now and I going to try that. It just doesn’t want to set change the mode and SHM status fast enough. Any ideas.


(jkp) #2

#3

What phone do you have? Are you using the latest version of the app?

As of the last update on iOS the presence has been working perfectly for me. I had issues with it before but haven’t since and run it on two different phones.

If you are having issues I recommend submitting your presence logs via the app. They added that recently and it will help them to improve it.

The links above will also help. But I highly recommend you submit a report to them.


#4

I read through the post above. I am going to try leaving my wifi on and the larger area today and see how that works. I may end up going the route of having both presence sensor and phone geofence. I am using an Iphone 7 plus. I have the latest IOS


#5

I have the same phone. iPhone 7 Plus and I have no issues at all.

Also make sure that in your settings the app has access to the location settings set to “Always”.


#6

Me too.
I set the “I’m back” routine to use 2 cell phones, if either is back it should disengage, However if only 1 is back it has a tendency not to disengage. Also the Good bye routine only activates randomly after we left sometimes hours after so I tend to do it manually. Very unreliable indeed.


#7

One other thing to make sure of is that in your Routine where Everyone leaves, the default is 10 minutes. Make sure that you reduce this down to 0 or 1 minute.

EDIT: This is for arming when everyone leaves. Not for arriving.


#8

I have mine set up to 1 minute and it does not work any better.


#9

It could be any of the 50 different issues around mobile presence as a whole. There isn’t a single source of these issues and it’s difficult for some. Multiple phones added for presence, flavor of IOS, Geofence sizing, settings on phones (battery optimization, high accuracy), gps sleeping when phone locked, incorrect location detected, location last reporting days ago. I know they have their beta going on and they have been working in this for years so I don’t know how close they are getting, given the multiple differentiating factors that don’t add up from one user to the next. Fortunately I have only ever experienced a couple of minor issues around this (Android 5.0 through 7.1 and only 1 phone added in ST). It’s one of those never ending battles. Hopefully they get it more dialed in with the latest beta, on IOS anyway. Seems to be a larger majority of IOS users versus Android based on posts/threads.


#10

I use Android 8 but it’s besides the point, some days it works, some days it does not. The inconsistency so characteristic to ST makes it difficult to troubleshoot, I think it’s just part of the usual unreliability of ST as a whole and will remain until Samsung takes that business seriously. Once they do take it seriously however, and it is reliable, I would not be surprised if they would charge us a monthly fee for the service because selling $50 hubs (when on sale) they can’t make enough money to sustain and develop the system.


(Mark) #11

Do you mean you were having issues with presence while the WiFi on your phone was turned off?

If so, you gotta leave wifi turned on if you expect to use mobile presence. With WiFi off, your phone’s geolocation is almost certainly less precise, and that could be the sole explanation for your problem. No guarantees though because mobile presence can be tricky.