GE Switch button's reversed


#1

I have 4 of the GE 12722 switches and until a few days ago all worked correct.

On just 1 of the four, the physical buttons are now reversed. To turn it on i have to push the button rocker (by the blue led) and to turn off I have to push the top. It still works correctly from ST though. The switch is installed correctly and worked fine for a while until a few days ago.

I found instructions on Jasco’s support to invert the switch It looks like there is a value to change that would fix this but I can’t figure out how to do this in ST. Any suggestions?

From Jasco support:
Invert Switch
If the switch is accidentally installed upside down with “On” at the bottom and “Off” at the top, the default On/Off rocker settings can be reversed by changing parameter 4’s value to “1”.

Parameter No: 4
Length: 1 Byte
Valid Values = 0 or 1 (default 0)


#2

Unfortunately, this has happened multiple times before when smartthings has made a change to the stock device handler. :disappointed_relieved: So it may be that in the most recent update an old version of the DTH was installed. They have already said these DTHs were updated in the release.

It should be easy to fix. Find the switch in the things list in the SmartThings mobile app and open it to the details screen.

There should be a small gear icon near the top of the screen. Tap on that and it should allow you to change the parameters.

You have to do this for each affected switch.

If by chance that particular parameter is not available through that device handler, you can use the Z wave tweaker to fix it. But first just try the gear option.

Unfortunately I can’t show you screenshots because VoiceOver navigation is broken on the app right now so I can’t get to the screen.

Definitely report this to support as well.

https://support.smartthings.com/hc/en-us

@slagle


(John C) #3

Here’s the parameter setup screen for a generic on/off switch. Mine is a Zooz, but I believe the GE/Jasco uses the same DTH. My GEs are all dimmers (and look the same as this).

So, the Z-Wave Tweaker is perhaps the best choice, as @JDRoberts points out :sunglasses:


#4

Thank You @JDRoberts and @Barkis !

I used Z-wave Tweaker to set Param 4 to 0 and it worked again instantly. Problem Fixed.


#5

Glad to hear you got it fixed. Definitely report to support, though, along with the fix, as this is a platform change on their side and they need to correct it or it may return with the next firmware update. :disappointed_relieved:


#6

Thanks again. I have shared the issue and fix with support.


(HousePanel Author) #7

I recently had this same problem with a custom DTH I wrote years ago to add icons to my things. A lighter weight fix for me was to put this in the DTH where the lit when off and lit when on routines were run:

zwave.configurationV1.configurationSet(configurationValue: [0], parameterNumber: 4, size: 1).format()