GE 12727 In-Wall Smart Switch Fried?


#1

I have installed a couple of these switches successfully in other locations, but now one location is giving me problems. This troublesome switch controls the pressure switch (this switch is not the actual pressure switch) for the well pump. I’ve tried two GE 12727 switches and neither would trigger the well pump to turn on using the toggle. In fact, they both now appear to be fried since I can’t get them to turn on the light in my living room after I gave up on the well pump and tried to install them there. To see if the switch location was somehow causing an electrical overload, I installed a regular standard light switch (dumb switch) in the switch location and it works perfectly. The original switch in the location is labeled as a 15 amp/120 volt switch. I hesitate to try another device here until I can figure out what is causing the problem. I have checked the load/live/neutral configuration is the same as the other switches I’ve installed. Any ideas?


(David) #2

Hi @ludicris44,

What is the draw on the switch? The only thing that comes to my mind is that the GE is rated to a max load of a 1/2 HP.


(Lee Ross) #3

Most wells I’ve dealt with are 220v and either 40amp breaker or 50amp breaker. Even if your putting it on 1 leg I definitely think your overloa ding it.