Frustrated Lock Situation


(TFG) #1

I am not looking for a complex lock, yet it seems like I cant find what I want:

  • Lock face with a Touchscreen

  • Creation of virtual lock codes via app

  • Notifications that someone opened the door AND which code was used via SMS text or App

  • No physical key

I bought the YALEYRD120ZW0BP Yale Lock already, but it, as a standalone device, does not push notifications.

I connected the lock to ST and tried to set up the notifications in the SmartThings app (new one) but it doesn’t do it.

I bought the RBoy access, but it’s just code (at least that I can see) and seems super confusing/techie.

Can anyone help? Should I get a new lock? Am I doing something wrong with ST?


#2

Tagging @RBoy


(www.rboyapps.com - Make your home your butler!) #3

Looks like you’re on the right track and that’s a very decent high quality lock and can do all you’re looking to do.

Unfortunately, for now, SmartThings requires all custom apps and devices to be installed manually hence you see code instead of an install link. You should download the SmartThings Classic App from the Apple App Store or Google Play Store to install custom apps (once installed you can go back to the new ST app).

Seeing code can look a little daunting at first, but it’s fairly easy (most a copy paste job) to install a SmartApp or a Device Handler. We’ve put a step by step instruction guideline in place to assist first time users.

Here are the instruction to install a SmartApp (in your case Lock User Management) http://www.rboyapps.com/InstallSA.htm


(Nate Schwartz) #4

I have the new kwikset lock that meets all those things. I use ethayers lock manager and device handler and get notifications when my son gets home from school. It’s pretty sweet actually…


(TFG) #5

Thanks @RBoy . I installed and can see it on my classic ST app, but it says “something’s wrong. we can’t load your screen right now”. Can you help?
Thanks


(www.rboyapps.com - Make your home your butler!) #6

That means the ST mobile server isn’t rendering the page or there is a connectivity issue. Try to restart your phone/check connectivity, if not it’s probably a mobile server issue which will resolve itself.


(TFG) #7

Really? See image below.
1 - Lock app has loaded multiple times
2 - Logs shows it is connecting (code below)!
Screenshot_20180916-120814_SmartThings|243x500 .


(TFG) #8

@RBoy here is the screengravb that didnt load


(www.rboyapps.com - Make your home your butler!) #9

Yeah, it looks like you’ve installed the app over and over again instead of opening an installed instance.
Check the last step of the instructions again, this a common mistake due to the layout of the ST mobile app.

It also looks like you may also have missed a few lines while copy pasting the code. You need to copy paste the entire page of the code.

I would recommend removing all the multiple instance instances, delete the code all together from the IDE and start over following the step by step instructions. http://www.rboyapps.com/InstallSA.htm