FortrezZ Water Flow Meter

Thanks for the quick response. Just to make sure I understand, are you saying I should NOT delete the old Fortrezz Flow Meter DTH?

Is there any way to remotely monitor the Flow Meter in the interim without purchasing an entirely new ecosystem? Is there any inexpensive way to monitor the flow without using ST?

No problem. If you’re using the DTH provided by FortrezZ and their SmartApps for notifications, I would not delete a thing. While the mobile app may not display everything correctly, I believe their apps should still work. I can’t be 100% about that because I use my own DTH and modified versions of their SmartApps.

If you haven’t tried my DTH, it will let you monitor flow (in WATTs instead of gallows), as well as still work with automations using “power” capabilities in the rules. Like I mentioned earlier, it isn’t pretty, but it can get you going until a newer DTH is put together. You will need to go into Settings and set up a few parameters that FortrezZ DTH does not have.

Unfortunately I don’t know of an inexpensive solution right now. Everything I’ve seen isn’t cheap.

I believe I am using the Fortrezz DTH:


  • FortrezZ Flow Meter Interface

Ok, then you may want to try mine, but wait a little bit. I’m in process of updating it to remove all the stuff that’s not needed anymore for the new app.

Also, it looks like charting has stopped working on FortrezZ’s end. Even though data is still sent to their site through the DTH, no chart image is available. Perhaps the data is still used for their old subscription solution, but it’s not showing a chart anymore.

I’ll reply back when you can try my DTH after I make some changes. Stay tuned.

Thanks. That will be a great solution!

1 Like

Hi @mwmacy2,

Below is a link to a new version of my DTH for this device that works with the new app by leveraging existing power and energy capabilities. Here are several important things to know:

  • Because I’m using ST’s existing power and energy capabilities vs creating custom capabilities (for now), flow (gpm) displays in the Power Meter section as WATTS. Energy consumption (total gallons used since the last reset) used to show as kWh, but ST hosed up the capability to show in GWh. That means it won’t show up until they fix this issue. The good news is that you can still see these values in the IDE, and you can see these values and history in the mobile app within the device’s History section.

  • FortrezZ’s gpm and cumulative capabilities have been preserved so that their legacy SmartApps work.

  • The reset capability exists and can be called by a SmartApp, like my Power Meter Reset Manager app, or WebCore.

  • After installing my DTH and changing the device to use it, you must go to the device’s settings in the mobile app and configure 3 settings: Debug Mode, Reporting rate (6 = 60 seconds, 1 = 10 seconds. Options are 1, 2, 3, 4, 5, or 6), and High flow rate threshold.

  • After installing this DTH and changing the device, you will want to force close the app and restart for things to show up right. For some reason that did not work for me and I had to remove and rejoin the device, which is a PITA. If you go this route, remove FortrezZ’s DTH, or comment out the line in their code with “fingerprint”. I believe it’s line 36.

I can’t think of anything else offhand right now that you should be aware of, so let me know how it goes if you decide to try this out.


Screenshot of the device in the new app:


Hi John,

Thanks for sending the new DTH. I installed it with no problem. I then was able to add the device using the mobile app, with no problem. The new device showed up on the mobile app, and I filled out all the info you mentioned. I then set the threshold very low and ran water to test it. No matter how long I ran the water, there was no alert sent and the energy and power consumption continued to show “0”.

Any idea as to what went wrong?


PS: Here are screenshots. They don’t look the same as the one’s you sent.
Also, I added the FMI device using the IDE with the DeviceNetworkID of 0x2101. When I tried to add the device using the mobile app, the only “suggested” devices were the water valve, moisture sensor, and siren. The FMI was not an option. So that is why I used the IDE to add the device.

Hi @mwmacy2, you’re going to want to start over. You shouldn’t provide your own ID for zwave/zigbee devices like these because that won’t work, and you didn’t need to discover the device again since it’s already there. All that needed to be done is to have changed the DTH of the existing device.

The big question now is did you delete/remove the device from ST before trying to add it and changing the DNI?

If the device was never removed before giving it that new ID, try giving it the old DNI back again. If you don’t remember what that was, watch your hub’s event log for something like this:


The device is still “talking” to ST via the original DNI, and in the example above, it’s 07. If you have many of those events with different DNI’s then you have some work on your hands. You’ll need to figure out which is which by turning on some water and refreshing your event log to try and correlate the meter sending something to the hub and one of those events.

Once you figure that out and give the device it’s original DNI again, you should be able to go back to the mobile app and set things back up again. It technically should now work, but quite honestly things by now may be beyond repair and you want to just start completely over again.

If you don’t remember the old ID and you can’t figure it out, then you will want to remove the device from ST and start fresh. You won’t be able to delete the original DNI from your mesh since you don’t know it (it’s now a ghost device in your mesh), which means all you’ll be able to do is delete the DNI of the one you created. Go ahead and do that anyway. To completely remove the device from ST and your mesh, you must do a general exclude. That should be done through the mobile app, or better yet, the IDE via the View Utilities section:


Once you kick that off, make sure nobody else anywhere in your house is doing anything with a device, like turning on a switch, because a general exclude will exclude that instead.

Also, bring the device (just the FMI module) close to the hub when doing an exclude. If I remember right, you’ll start the general exclude process via the IDE and then press the button on the FMI. After it excludes it will blink 4 times in a row pretty quick.

To correctly add this device to ST, you’ll want to make sure that either my DTH is the only DTH you have for this device, or edit FortrezZ’s DTH to remove that fingerprint line I mentioned in a post above so only mine is detected.

When adding the device, there will not be a suggested device. You will need to add it via the “Scan nearby” option. When you do that it will take a little bit of time for the app to recognize that you have your own DTH for this device (that’s what the “fingerprint” in a DTH does).

As soon as ST recognizes you have a DTH for this device, it will add it with the name “My FortrezZ Flow Meter” and then it will give you the option to give it a different name and move it to a Room. Once done will all that, go to the device’s setting and set things back up again.

As for those settings and how notifications work, the DTH doesn’t send any notifications. Notifications are done through Automations and SmartApps. Remember, Reporting Rate Threshold is just how often the meter reports gpm. High Flow Rate threshold is what value should the meter trigger a capability that’s monitored by an automation/smartapp.

FortrezZ’s legacy smartapps use the Water Sensor capability. It monitors a “wet” or “dry” state. When the flow rate exceeds your threshold, it changes the state of the water sensor capability to “wet”, otherwise it’s always “dry”. Their smartapp can then send you a notification. I don’t use their SmartApps, so I can’t recall how to set that up.

The other thing you can do is create a simple Automation that watches that device’s water sensor state to send you a notification, like this:

Other automations that can be done could also include watching for power usage during certain conditions or modes. Remember, this is a power meter in ST’s world, so you could create an automation that says if power usage is over 0 and your home is in Away mode (not STHM away mode), send you a notification that water is running when nobody is home.

If you want to be notified of water running to too long over a period of time, or after a certain about of usage has happened, you will want to use FortrezZ’s legacy smartapps. Their smartapps will also control a valve or switch under certain conditions.

After many trial-and-errors, I finally got it working perfectly!

Thanks again for your help!

Excellent, I was really hoping to hear that news. Glad I could help.

So, with the movement to the New App, I was having some issues getting things working. I installed the new Device Handler and most things are working but one thing remains a puzzle. On the History Tab I see Energy and Power Meter results as things change. However on the Controls Tab I do not see any Power Meter displayed. I see Battery, Energy Consumption Image Capture (Which does not work) Temperature and the Water Sensor (Dry or Wet as things change). What am I missing to get the Controls page to look like the one with the Power Meter?

The one in post 396?

Sounds like you may not be using my latest DTH, or more than likely just need to try those steps in my 5th bullet point in that same post. Sometimes just changing to any other DTH and then back again will do the trick.

I am having a slightly different problem. I have added the handler in post 396 and published it. I see it in the IDE with no problem. However on the new app, there is no option to add this device; at least I am not able to find it. Any pointers? I do have multiple locations and one location has multiple hubs, not sure if this matters.

Once you have the dth with the fingerprint, you should be able to just do a generic nearby scan and it should join with that dth.

1 Like

I don’t know what to say. I thought maybe it was a radio dead spot, but just a couple feet away is the fortrezz water valve with I was able to include into the network in a jiffy with no issue.

I am still perplexed why the device handler is in the IDE but not the app. Other handlers I have installed show up in the app.

I’m not sure what you mean by that. DTH’s don’t show up in the app.

Once you start the join process for the FMI, it will join using the DTH you’ve set up in the IDE. I highly recommend joining the device very close to the hub and then moving it to it’s final location.

OK. Got past that - brought unit close to the hub and it found it. But it was too far (even at about 30 feet) to stay connected, so I got an Aeotec Extender 7 which solved that. I am now seeing it online and seeing messages. Like, when I unplug the power, it immediately reports AC Power Loss in the app.

However, I am not seeing any flow data. I turned on a spigot and flow is considerable (maybe 3 gpm), but nothing is shown on the app. Also, peculiar temperature reported.

Received Messages From Device: 110
Received Messages From Device (Duplicates): 9
Messages Transmitted to Device: 76
Messages Transmitted to Device (Failures): 15
Updated Time: 2021-01-17 9:01 PM EST

energy: 0
battery: 94 %
powerSource: AC Power
checkInterval: 3720 s
temperature: -9 F
cumulative: 0
alarmState: Mains Reconnected
gallonsHighValue: 0
gallonsLastUsed: 0
flowHighValue: 0

What events are you seeing in the IDE within Live Logging for that particular device?

So who will be making their water sensors, multisensors? or those just going to drop off the face of the planet?