Dim with me not dimming

Ok this should be the most basic thing in the world but for some reason I cant get it working.

I have a RF9500AW battery powered zwave dimmer switch remote and I want to control the on off and dimming of a plug in lamp dimmer module.

I’ve been trying to use Dim With Me to make the dim level of the lamp module match the dim level of the remote. It turns on and off fine but doesn’t dim at all.

For troubleshooting purposes I made a virtual dimmer so that I took the RF9500AW hardware out of the loop… again the virtual dimmer turns on and off the lamp module but no dimming… And to make sure its not the lamp module I also linked a GE wall dimmer switch to slave off the virtual dimmer… again on and off work fine… but no dimming. Am I missing something here? I have a V2 hub… if that matters

Remove the dimmer devices from the “Slave On/Off Switch(es)” section. That section is for switches that have only On/Off. They dimmers will follow dimming and on/off.


1 Like

Yea I tried that before and again this morning… This is just the virtual dimmer and the GE dimmer switch… Again on off work but no dimming

Just for test purposes, try this virtual dimmer:

Let me know if that works.

Hey that worked!!! yay so now I’ve got lights following the better virtual dimmer level…

Unfortunately when I swapped out the BVD for the RF9500AW in “Dim With Me”… again no dimming following… sigh… Unless I can get the RF9500AW working for dimming it’s a useless device.

I wonder if I can use rule machine to make the BVD match the dim level of the RF9500AW. I really need hardware control on the wall for wife acceptance factor.

1 Like

No, Rule Machine can’t do this. It doesn’t have a way to capture a specific dimmer level to then apply it to some other device.

Yea so I’ve discovered… Sigh. Clearly someone is using the rf9500 or there wouldn’t be a driver for it. Can anyone think of a solution other than “dim with me”? (Since it doesn’t seem to be able to read the dim level on the device)

Try changing lines 82 and 91 in the Dim with Me SmartApp code from:

subscribe(masters, "switch.setLevel", switchSetLevelHandler)


subscribe(masters, "level", switchSetLevelHandler)

See if that works with your rf9500 as the master.

1 Like

YAY!!! YOU ROCK!!! what a royal PIA!!! but it totally works now. Awesome help. thanks so much!

This fix seems to work for me too – “switch.setLevel” should just be “level”