Devices controlled by momentary button tiles no longer work in the new app

has anyone else noticed this?

none of the ‘things’ i have set up as momentary button tiles in the old app work in the new app. just says ‘cannot connect to device’ when i tap them in the new app.

It has been a while since I looked at them. I seem to recall that although the stock Momentary Button Tile handler played up, a custom handler using the Momentary Button Tile handler code available in the community repository worked OK. Which seemed odd …

The Momentary capability works fine in itself.

so i have a light set up as ‘momentary button tile’ which no longer works in the new app.

do you know which custom handler works in the new app? can you point me to it please? thank you very much!

It was a few months ago and my memory might be playing tricks, but I was thinking of

That is, of course, supposedly the same handler that is misbehaving. If that doesn’t work, I’ve got something that will.

hi, that doesn’t work… i still get the ‘can’t connect to device’ error when tapping the icon in the new ST app.

I’ve got this thing which I think has the same functionality:

hi, this sort of works. it gives the device a on/off switch which doesn’t work, but i have to tap the device to get to secondary settings which show a momentary icon that i can tap to make it work.

if i change the momentary tiles to alexa switches it works in the new app, but the switch stays on.

Ah right. I’ve not been actively using that handler myself and it slipped through the net. It won’t take long to update …

The action on the dashboard tile should now be a working momentary button. I settled on the momentary attribute for the status. The switch button on the details page also triggers the momentary action.

1 Like

this seems to work properly now, thanks!

It’s been a really long time since I messed with these switches. Everything was working fine until I am trying to migrate everything over to the new app. I did not “migrate” yet, but I am just running the new app (with the old app still working and installed) to see what is working and what is not. One thing that is not working for me is a momentary switch created by Alexa Virtual Switch Creator v 1.0.1 which uses Alexa Switch version 2.0.7 and Momentary Button Tile Version 1.0.3.

The switch says it is not connected so I believe it is a similar problem to yours. please dumb it down to help me get this working. Which handler do i use and how do i use it? Create the new handler and then go into IDE and change the device to use that handler? What about future momentary buttons created by the Alexa virtual Switch Creator?