Delay changed, am I crazy?


I searched the forum for awhile but couldn’t find anything saying that delay had been changed or broken recently, so if it’s there and I missed it I apologize. I did find a post from last year where it wasn’t working for < 60 sec delay, and the devs got it fixed.

What I noticed was that over the last couple weeks my Photo Burst When was only ever taking the first pic and not continuing on to take the following bursts. After much troubleshooting and testing, it appears that the “delay” parameter now takes real seconds instead of milliseconds? In testing in the IDE “camera.take([delay: 5000])” wasn’t doing anything, so on a whim I changed it to “delay: 5” and it returned in 5 secs. Tried a full burst of 5 pics with 5 secs between and it worked great (aside from it ranging between 4 and 6 seconds).

Is that just a quirk in the IDE simulator or did it really change for everyone? I haven’t changed/published my app to test it because I’m not home to trigger it. The docs still show milliseconds.

Side note: is there a way to kill off any delayed commands that are scheduled? I’ve been testing this thing a bunch with high delay numbers, including using light switches… I’m afraid my lights are going to start turning off and on randomly over the next few days.

9 posts were merged into an existing topic: Delay not working?