CT101 schedule and adjustment by smartphone

I got Smartthings and CT101 recently, still learning.
What I want is: have a weekly schedule, but I can use smartphone to make adjustment once a while so I can remotely control the thermostat when something unexpected happens.

After I played with CT1010 for a while, I realized its weekly schedule feature is only supported when not connected to Z-wave network. After I connect it to smartthings, the program menu is gone, and I have to program with Smartthings.

Is there a simple and reliable way for this? like time/day based programming, Don’t want to manually toggle mode (e.g.home/night/away) every day.


You should consider using SmartApps to control the thermostat. If you have access to RBoy Apps check out this SmartApp, it has a temporary hold feature which allows to override the daily/weekly schedules for a temporary period.

1 Like

Hi RBoy,
Thanks for quick response.
I installed 5-2 Day thermostat app in website and tried to program it in my samsung S7 phone. After finish programming, and press save, I got an error message:
An unexpected error occurred.

I am not using outside temperature. As initial test, all heat temp is ~68, and cool is ~80.

Probably a platform error, just uninstall and install it again. If enabled the remote sensor option make sure you’ve selected it in and set the temperature swing.

Tried, does not solve the problem.
I read the other thread, and followed your suggestion to use simulator. It throws exception:

ad9f10ad-879e-43e9-af24-8f6b32bbab9a 5:46:52 PM: error java.lang.NullPointerException @line 144 (initialize)
line 144: def today = calendar.get(Calendar.DAY_OF_WEEK)

I comm

I replaced this line with the following to continue debug
def today = calendar.FRIDAY

then the error becomes this line:
log.debug(“Current time is ${(new Date(timeNow)).format(“EEE MMM dd yyyy HH:mm z”, location.timeZone)}”)

Looks like you haven’t set your hub location and consequently the time zone. The app itself is fine. The error is being thrown because it can’t get the time zone of your hub.

Did you set your hub location in your SmartThings mobile app?

1 Like

I remember I set the location when I created the account a few weeks ago. Now I check it and it does not feel right. After I clean up a few things and set location again, the app works now. Thanks for your help.

1 Like

I moved over to SmartThings from Iris and have 2 CT101s in my house. Fought them for 2 days, knowing that there had to be a solution. There was: I loaded the SmartThings Classic App and they loaded immediately.

Now, if I could only find a convenient way to just program a 5-2 schedule I’d be happy. I hate to create a scene for each change in temperature because it’s not tied to any other action. But that’s a discussion for another thread…

There’s a free app available on the first post here: [RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

I’ve been using this for about a year and it’s great. I’ve had one issue. I bought external temperature sensors so that I could, for example, have the sensor detect temp in the guest bedroom (which has poor circulation) instead of the thermostat control in the MBR. Whenever I connect the external temp sensor, the program drops the AC to 60 degrees, and does that repeatedly until I remove that external sensor from the chain.

That’s normal when using an external temperature sensor. See the first post on the link above, it explains how the thermostat setpoints are used to control heating/cooling until the remote sensor achieves the desired temperature. There are options for temporary override, closed loop feedback control (to compensate for mesh errors) and many other features in the premium version of the app.