Can't get routines to work by time setting!


(James L) #1

It seems simple enough. Tell it what to do after a trigger and it does it, just like Smart Lighting I thought. I am testing a simple routine to turn on 1 light at a certain time but nothing happens. It works if I have the routine run by turning on another switch but not by time. The rule works fine via Smart Lighting. What am I missing?

Thanks,
James


#2

Have you waited 24 hours? The routine will get scheduled to run the next time that time occurs beginning the next day.


(James L) #3

No I did not think you had to wait 24 hrs. You don’t with Smart Lighting. I’ll try that.

Thanks
James


#4

When you’ve created the routine, you can look in the IDE and see when it’s scheduled to run next.


#5

I have been having trouble with turning on/off a SmartPower Outlet (CentraLite 3210-L, either a SmartThings outlet or an Iris one) using smart lighting. It used to work, but now it doesn’t.

The “recently” tab on the app shows “Turn on xxx at 11:00 PM and off at 7:00 AM sent on command to xxx” at 10:59pm, and it shows “Turn on xxx at 11:00 PM and off at 7:00 AM sent off command to xxx” at 7:00am.

The IDE shows:
2017-08-22 7:00:14.482 AM PDT 10 hours ago APP_COMMAND off
2017-08-21 10:59:59.492 PM PDT18 hours ago APP_COMMAND on

So it is trying to do the right thing, but the device doesn’t actually turn on or off. I can manually turn it on or off using the app. When I do, I see a log saying “xxx is On” and then it starts sending power readings. When I turn it off, I see “xxx is Off”, followed by a power reading of 0 Watts.

This time automation used to work great, but it stopped working sometime in the past few weeks.

Any ideas?

Thanks,

  • S

(Ron Talley) #6

webCoRE and never look back!


(James L) #7

JDRoberts,
That would help but I’m not finding it in the IDE. I hate asking but where is that located?


(JBrown) #8

In the Smartthings IDE select My Devices, then select the device in question, scroll to the bottom of the page and you should see “In Use By” then select then select Smartlighting.


(James L) #9

Jason,
I found it and I think it explained the problem. For example I would set it at 10:05. According to IDE for some reason it would set it for 10:05:55. I’m assuming I never waited the extra :55 seconds for anything to happen, before I started again. Tested it 3 times and it worked. Just :55 after the time I gave it.
Does yours do that? If so I wonder why.


(JBrown) #10

Not sure why that is, my next run times show :00.


(James L) #11

Strange. Every time it shows me :55. Smart lighting shows me :45. Even changed switches still the same. Strange!!


(JBrown) #12

Here is mine. Not sure what to tell you.


(James L) #13

A bit strange. Always something! Still works! But I’ll figure it out someday.

Thanks for your help
Have a good one,
James


(JBrown) #14

Some thing you you might try is deleting it, and redo it. Also try e-mailing support good luck.