Cannot get TPlink plugs show up in smartthings even after 24 hrs

Hi, all. I used to connect the TPlink HS105 mini smartplug with Dave’s code (on Github) in Smartthings classic app. The plugs has been working fine with the implementation of Dave’s code.

2 days ago, I noticed there is a migrate button in the smartthings classic app and so I tap on it and start the migration process. Everything works fine except all the TPlink plugs do not show up in the new Smartthings app.

I already linked the KASA account to the Samsung account, but the plugs just never show up on my new app. I googled this issue and found the old post saying that it took 30 mins up to 24 hrs for the plug to show up in the app. In my case, 36 hrs has passed and still the plug does not show up in the app.

I logged into smartthings account on desktop, I could see the plugs are in my device list, but the type is a placeholder. I tried removing the Dave’s code, unlinked the KASA and re-linked it to samsung and wait for 24 hrs. But still, the plugs does not show up in the new app. The plugs is still a placeholder in the my device list on desktop.

What can I do now to get it to show up in the new app?

Placeholder is the term used for non-groovy cloud-to-cloud integrations so that is expected.

  1. in the new app, click on menu (3 bars in the upper left of the screen) and select devices. Check if your Kasa devices appear there.
  2. if not showing there, go back to menu and select settings (The cog) and find Linked Services. Open the Kasa integration and just click through it again. Then check the device list.
  3. if they are in the device list, then they are most likely just hidden on the main dashboard. It is easy to unhide devices there. click on More Options on the dashboard (3 dots in the upper right of the screen) and select Edit
  4. last thing to try… remove the Kasa integration from settings, login to IDE and remove the Kasa devices if they are still there and remove the Kasa smartapps/device handlers that you previously used in the classic app. Then add the integration back

Thanks for your reply. I have already tried 1-4 before posting here. So I don’t know what to do.

Contact ST support