Can you dim a group of GE Link light bulbs?

My first time using my smartapps and have followed Todd’s instructions to Zack’s question from the start. Good job guys!, thanks it worked for this newbie.
I don’t see that this question from John was ever answered…or I can’t find it. I need to get the virtual dimmer control into the switches section or my wife will never find them. Is it possible?

I’ve combed through this thread several times trying to make sure I’ve followed all the steps correctly (it’s a bit scattered). I can turn on/off a group of GE Link bulbs, but no dimming, only the master dims. Here’s what I did:

  1. create smart app “dim with me” from github code, save and publish
  2. create new device type “Wackware GE Link Bulb” from github, change two GE Link bulbs to new type
  3. install “dim with me” smart app, set one bulb as master, 2nd bulb as slave for both on/off and dimmer

On/Off works, but the dimmer works only for master bulb, not slave. Can anyone tell me what I missed? It seems like I’ve done everything that others on this thread have done, but without dimming. I believe I have the latest code because I went to github to get it. Could there be something newer?

I’m beginning to lose faith in these bulbs, at least for my application.

I currently have three GE Link bulbs in one overhead fixture. I’ve tried various setups ranging from the suggestions listed here to having three separate motion triggers (one for each bulb). With every setup, eventually, only two of the bulbs will light up. What makes it painful is that it’s always random which bulb doesn’t light up. If it was consistently one bulb, I’d simply swap that out. Is controlling three bulbs too much for the hub to handle? My ST hub is only one room away in a modest 1350 sq ft home (with an open doorway between the two rooms.)

Here is my current configuration:

  • Latest “Dim with Me” installed with the “Better Virtual Dimmer” set as the Master and the three GE Link bulbs set as the slaves.
  • The “Better Virtual Dimmer” and the three bulbs all have the latest “Wackware GE Link Bulb” assigned as Device Type.
  • An Ecolink motion sensor triggers the Better Virtual Dimmer on motion and is set to turn off when no motion is detected.

Having the bulbs turn on at various dim levels does seem to work. However, as mentioned above, eventually, only two of the three bulbs will turn on. Viewing the bulbs in the “Connected Things” window shows that ST thinks that all four lights (1 virtual, 3 GE Link) are on. I thought these things were able to report there status back to the hub… maybe a SmartApp could check the status and correct it?

Additionally, there seems to be a reset issue with one of the Smart Apps. If I walk back into the room immediately after the lights turn off (after not detecting motion for 4 minutes), no amount of motion will turn them back on. However, according to “Connected Things”, the motion detector is seeing the motion and the hub thinks all lights are lit. This issue isn’t quite as pressing though…

I’m considering either returning these bulbs or assigning them to various locations where they won’t need to be used together. My current house wiring prevents me from using a dimming Z-Wave switch for this 3 light fixture. I may have to install a simple on/off switch that doesn’t require a neutral wire…

@DITPL I believe that GE make a dimmer that don’t use a neutral wire. Here a link.

http://www.lowes.com/pd_339578-1353-45639_0__?productId=3707738&Ntt=ge+zwave+dimmer&pl=1&currentURL=%3FNtt%3Dge%2Bzwave%2Bdimmer&facetInfo=

@llcanada Thank you! I’ve noticed that this switch doesn’t work with LED or CFL bulbs, but I wonder if it’ll work in my situation because it’ll be running three bulbs (3 x ~12 watts)… Thanks, I’ll give it a try.

@theamzngq try using the Better Virtual Dimmer as a virtual switch to be the master and put both GE Links as slaves.

@DITPL and @theamzngq you may want to check out the device type in this thread for the GE Links. It built on the Wackware version to add additional status updating. You can use them with Pollster to get frequent status updates. Also adds transition time into dim level and on/off.

It won’t solve the issue of one bulb being missed. I still haven’t found a good solution for that.

Thanks for the tip, @Sticks18. I have tried using the Better Virtual Dimmer and it didn’t seem to work as expected, but I’ll try it again (you know how your brain gets fried trying a thousand varations of something?) And thanks for pointing out the newer device type for the GE bulbs, I’ll definitely try that as well.

Thanks. I updated the device type and it’s generally better. Now, instead of a random bulb not working 50% of the time, it’s more like 20% of the time. However, I did notice that even when I refreshed the bulbs manually, ST thought that the GE Links were ON even when they weren’t. Even after waiting more than 3 minutes and with Pollster running. When I manually looked at the “off” bulb that thought it was “on”, I noticed that it’s dimmer slider was set to 0%. Manually putting it to 100% brought the bulb to life.

So… I went into the “dim with me” app and also selected “turn on with” for the three bulbs. So now, all three bulbs are selected to dim to 100% AND turn on. (There isn’t an option to just turn on, you need to set a dim value for the “dim with me” SmartApp.) I haven’t had time to test, but will report back.

Just an FYI, the “on” command returns the bulb to its current dim level, so you can turn the bulb “on” when it’s dimmer is set to 0% and it won’t light up but will think it’s “on”. It’s the one scenario where the bulb is tricked about it’s actual status. That’s a function of the way the zigbee on/off and level clusters interact. The level cluster can trigger on/off status, but on/off only returns to the current dim level. For instance, zigbee is smart enough to know that moving the level to 0% when “on” will trigger the “off” status, and smart enough to trigger “on” if the bulb is “off” and a level above 0 is sent.

Your solution to dim to 100% and on, should solve that issue.

@Sticks18, the new device type worked! After changing the device types, I set up the Better Virtual Dimmer as the master. Overall the dimming works well now, but there is one odd behavior:

  1. I turn the virtual switch on - lights go on
  2. I drag slider down to 30% (for example) - lights dim
  3. I drag slider quickly up past 90% - lights do nothing
  4. with slider still past 90% (and bulbs having not reacted), pushing the “dim up” or “dim down” buttons causes the lights to dim up/down based on a starting point of 30%, not 90%
  5. if I drag the slider back down to 30%, then drag the slider up past 90% slowly, the lights will ramp up

Has anyone else experienced that behavior?

@DITPL That is the old GE switch that does not require a neutral. The new ge dimmer and on/off switches are in a packaged in a black and green box, while the old dimmers and on/off switches are in clamshell cases.
@DITPL From my research and experimenting if your switch does not have neutral then a common rule of thumb when using low voltage bulbs is that the load of the circuit has to be minimum 40 watts so for your setup with (3x-12 watts = 36 watts) could work (meaning work without flickering when off, and without humming) or it could not work correctly and flicker when off and hum. A way to fix this is that make sure the load of the circuit is at least 40 watts or more, which can be demonstrated when you remove one of the 12 watt leds in your circuit and replace with 40watt incandescent which fixes the flickering problem.

Here is my results when testing.

Bedroom (Dimming switch without neutral, 2 bulbs/1 switch)

  1. (1) GE Link 12W = FLICKER Circuit load = 12W
  2. (1) Ge Link 12w + (1) Ge Link 12w = FLICKER                   Circuit load = 24W
    
  3. (1) Phillips 11w = FAINT HUM, NO FLICKER GREAT BULB
    (only hear hum when ear is next to bulb) Circuit load=11W
  4. (1) Phillips 11w + (1) Phillips 11w = PERFECT                    Circuit load = 22w
    
  5. (1) Ge Link 12w + (1) Phillips 11w cone = PERFECT          Circuit load = 23W
    
  6. (1) Ge Link 12w + (1) Incandescent 40W = PERFECT Circuit load = 52W

From my tests and research the best and cheapest dimmable LED bulb is the phillips A19 dimmable led bulb (the ones in my tests) and can be found cheaper at Home depot for $12-13 dollars versus Amazon --> http://www.amazon.com/Philips-424382-11-watt-Household-Dimmable/dp/B00APTS03K/ref=sr_1_4?ie=UTF8&qid=1422503122&sr=8-4&keywords=phillips+led
CNET even names phillips best dimmable LED as of 2015: http://www.cnet.com/topics/smart-home/best-smart-home-devices/best-led-light-bulbs/

Sorry if i got a little off topic, hope someone can make use of my experiences :slight_smile: Good luck!!

1 Like

@tenzingsherpa

Will the Phillips bulbs dim lower than the GE’s? I see they show down to 10% as well? The GE’s are just too bright at 10% for my liking.

@Drewbert34 I just went down and tested the GE link bulbs I have and compared next to the Phillips A19 replacement led. The phillips clearly earns its title as the best dimmable led. The GE link bulb i dimmed down to 10% in the “things” menu of ST and it is equivalent to 30%-40% on the phillips led. The phillips can dim much further than the GE Link bulbs and does a great job. I am using the phillips led in recessed lighting as well and it give the house a very modern look and great dimming capability. You will not be disappointed with the phillips leds, they are amazing and I am using them from everything from recessed lighting to table lamps.

1 Like

@tenzingsherpa

You Rock! Thank you very much for your reply…that helps me out quite a bit!

@twack / @wackware (same person?)

Okay, trying to implement Dim With Me and the virtual dimmer. Like some of the others, I’m trying to use a physical Z-wave dimmer (a GE/Jasco 12724 with no load connected) to control six Philips Hue flood lamps in my ceiling. I have a few questions.

First, I’d like it to be a bidirectional thing - if I mess with the virtual dimmer, I would like the physical one to match, and then, if I mess with the physical one, I’d like the virtual one to match. Then, of course, the virtual would serve as the master for the Hue bulbs. So, would I need to have three instances of DimWithMe going? One with master as physical, slave as virtual; one with virtual as master and physical as slave; and finally one with virtual as master with the six Hue lights as slaves? Do I need the virtual switch at all?

I’m also noticing, like some others, that the physical dimmer’s level is not really setting the Hue bulb levels (i.e. having DimWithMe set the physical as master and the Hues as slaves). Seems like the physical dimmer’s level isn’t being read or something.

So all that being said, how do you recommend I set this up? And of course, all the same complaints about the Hue bulbs working with SmartThings apply (like the on/off is only recognized if SmartThings initiates it).

Thanks!
Christopher

1 Like

FWIW, I’ve kind of abandoned the idea of having a physical dinner paired to the virtual dimmer. The dim level of the physical one just isn’t being read. Instead, I’ll have Big Switch link the physical, regular on/off switch with the virtual and vise versa. Then DimWithMe from the virtual to the six Hue flood lamps. Solves the problem mostly and is understandable by my wife.

Does anyone know if the new lighting controls in the updated smartthings app allow for grouped dimming? I’m able to group four GE bulbs in my bedroom to turn on/off all at once. But dimming as a group isn’t obviously available.

It doesn’t. You can group them and set the dimmer level when they turn on, but you can’t adjust them as a group.

Well that’s a bummer. Seems like a pretty basic function to have available. @twack any chance this will be added to SmartThings’ built-in lighting control?

I finally figured all of this out so powering on/off and dimming works. There were too many posts to read through.
I’m really surprised this isn’t built into the app. It should be.

Step 1: Sign in here: graph.api.smartthings.com.

Step 2: Go to “My SmartApps” and click “New SmartApp” then “From Code”. Paste the code from here.

Step 3: Go to “My Device Types” and click “New Device Type” then “From Code”. Paste the code from here.

Step 4: Go to “My Devices” and click “New Device”. Name it “Main Light” (or whatever you want), give it the Network ID “1234”, change the type to “Wackware GE Link Bulb”, then set the Hub to your hub. Click Create.

Note: Don’t change the original light bulb devices to “Wackware GE Link Bulb”. Leave them as the original “GE Link Bulb.”

Step 5: On the app on your phone, go to the Marketplace -> SmartApps -> My Apps (at bottom). Click “Dim With Me”.

Step 6: First scroll up some if you don’t see “Master Dimmer Switch”. Set the master dimmer switch to “Main Light” (or whatever you named it earlier). Set the slave On/Off and Dimmer Switches to the GE Link Bulbs that you want to follow the virtual device you made. Name it whatever you want, then click Done.

Now under “Things” on the app, you will see “Main Light” and when you make a change to it, the other lights will follow.

2 Likes