SmartThings Community

Amazon Echo

I should be aittle clearer. The trick I’m asking about has to do with redusxovering the Hue bridge in ST. Every time I try to do that and finish the integration I get the bulb discovery error

My set up is the other way around: I do not tell echo that the Phillips bulbs are smartthings devices, even though that same Hue bridge is also associated to smartthings through the smartthings mobile app. I let echo control those bulbs only through the Phillips bridge connection to echo. That gives me parallel lines of control which work fine. Echo can control them and smartthings can control them.

Since echo can combine lights from different services in the same group, I get the same result anyway. So I never deleted the Phillips bulbs from Echo.

This is what I did:

One) added the Phillips bridge and its bulbs to smartthings using the smartthings mobile app in the regular way.

  1. added the Phillips bridge and its bulbs to echo using echo “discover devices” in the usual way.

At that point I could control the bulbs from either smartthings or echo, no problem. This was before the new smartthings/echo integration was available.

  1. use the echo app to link smartthings to it using the new integration. When I was given the opportunity to select the specific devices that I would control through echo, I did not select any of the bulbs that were attached to the hue Bridge.

  2. at some point, the IP address for the Hue bridge got zeroed out in both the echo app and the smartthings mobile app. I don’t know exactly when that happened. When it did happen, the IP address showed as zero in the Hue connect smart app under smartthings labs in the smartthings mobile app, and the bulbs attached to that bridge showed as unavailable in the Echo app.

  3. to fix it, I began by simply using the Hue connect smartapp to discover the bridge again. Not the bulbs, but the bridge. This did require pushing the physical button on the hue bridge.

  4. as soon as I got the IP address showing in the Hue connect screen, and I had saved all of that, I then discovered the bulbs attached to that bridge using the Hue connect smart app. I don’t know if that actually did anything or not, I just let it run for a minute or so and then saved it.

So at that point when I opened the Hue connect smartapp through the smart things mobile app, I could see the hue bridge IP address and the names of all my bulbs.

  1. Time to fix things on the echo side. I opened the echo app. I pushed the physical button on the Hue bridge. I chose settings, connected home, and then tapped “discover my devices.” Echo showed the status bar updating, and when it was done, all of my bulbs attached to the hue bridge were again available to echo.

  2. I confirmed that I could reach the bulbs and control them either with an echo voice command, or through the smartthings mobile app things page, and that a group in echo that combined some bulbs from that Hue bridge with a Z wave switch worked fine.

So I never did delete any devices from either echo or smartthings. I just did a Discover on both sides. But I also never tried to define a bulb on a huge bridge as a smartthings device to echo.

FWIW

@JDRoberts I spent some time setting this up tonight and you are right, this works pretty good if you strictly use the Echo. The problem is, if I start using the physical remote, it becomes out of sync because the virtual switches don’t update. If I modify the Harmony activity to turn on/off the virtual switches, I end up with a looping effect because than IFTTT triggers occur and begin powering on and off activities. I realize you might only use the Echo, but was wondering if you had any ideas on how to resolve this? I am using On/Off Virtual Devices, not the Momentary ones.

I had a set up which took care of this (my housemate uses the physical remote), but just today there was a harmony firmware update and they have changed the way their IFTTT channel works. You can now only issue an end activity for the current activity. That breaks a lot of my set up. So I’m having to redo a bunch of recipes.

The good news is that the new set up should take care of any issues getting out of sync when you sometimes use the physical remote and sometimes use voice. But it means you have to set up an activity whose only purpose is to substitute for the “all off” power button. And you have to have two momentary switches for that exit activity. And all the other activities have to be momentary buttons.

The end result will be fine, but it’s going to be a lot of work to redo everything for me.

Detailed discussion in the harmony topic:

Thanks…I didn’t receive a firmware update. I am on 4.6.71, what are you on? Anyway, I am confused now on how to set this up? I see you switched to Momentery tiles. Can you provide screenshots of your config for perhaps one of your activities?

With screenshots:

Thanks. Looks simple enough now, but the problem is there is an issue between IFTTT and Harmony and it keeps saying my hub is offline, when it’s really not.

Yeah, that was one of several Harmony problems I had today, they’re clearly doing some kind of cloud update. Hopefully it will be better tomorrow.

I finally got it working, you just need to keep trying! Nice FAQ as well @JDRoberts. Everything seems to be working perfect now. The only difference from last night when I was trying and the physical remote was throwing things off was I switched from On/Off tiles to Momentary Tiles. Nice work and I am sure this is very useful for you.

I wish now I can have the Echo actually turn on FireTV content. My son watches it constantly, and it would be nice to say “Alexa, turn on SpongeBob”. I know I can set Harmony Activities for specific channels for my Cable though. The most useful one for me, will be “Alexa, Turn off the TV”.

1 Like

Instead of “turn on red” could you do “code red” as the keyword to trigger that sequence?

I could, I just like to keep everything as short as possible.

Thanks for your reply. I found out quickly that it does get confused and tells you to remove the duplicate entries or rename them. So in order to make sure my ST hub always stays in sync w/ the WeMo switch status, I removed the WeMo devices from Echo. Works great…until a few hours later when they suddenly show back up.

Anybody else having issues getting Echo to truly forget a device?

1 Like

Mine was doing the same thing with devices on the Hue Emulator hack. I had my ST switches on that until ST was working with the Echo. I ran a discovery to get my ST switches added through the new native ST/Echo integration and wound up with duplicate switches (Hue emulator and ST). I “forgot” the devices on the Hue Emulator which fixed everything then later on I noticed they were back.
I removed them from the Hue Emulator altogether, did a Forget all Devices on the echo and then rediscovered. Been working fine ever since.
You will have to unlink the WeMo or remove them from the WeMo, I think, for this to stick.

Hope that helps,
Scott

Hmmm…

The Phillips hue bridge does not offer a way to individually authorize the use of bulbs to echo. Basically as soon as you have echo discover new devices, if you have physically pressed the button on the bridge, Echo will discover that bridge, and the Hue bridge will pass along all bulbs attached to it. So bulbs attached to a hue bridge Will get re-added to echo every time you read discover that particular bridge.

The smartthings integration works differently. for that one, you go through the “link the service” step in the echo app, and you individually authorize devices for use by Echo. And only the devices that you authorized will be added to echo during discovery. I think the same thing is true with the Wink hub. I’m not sure exactly how WeMo works in this context but probably something similar.

So devices could reappear in echo but only if you discover them again. If they are bulbs attached to a hue bridge, they will be rediscovered anytime you rediscover that Bridge. I’m guessing wemo devices probably get rediscovered as well.

The first thing I would do is open the echo smart app under convenience in the smartthings mobile app and see what devices show as being authorized there.

What was weird about mine is that I did not re-discover and they still showed back up. I discovered initially and saw the duplicates, then “forgot” the duplicates. Later on in the day I went to turn a light on and it (Echo) said there were multiple devices so I checked on the app and there they were again. I thought originally that maybe I just did something wrong or forgot to do something. I would have never mentioned it if @Geckotek never posted because I thought it was just me and something I did.
What I will say is I do have 2 profiles on my Echo, mine and my wifes. I “forgot” on my profile, is it possible they still remained in my wifes profile and added back to mine?
I know it sounds weird but I did witness it too :frowning:

The multiple profile thing does sound like it might be a factor, but I haven’t seen the behavior so I don’t know. I would contact Amazon support and see if they have any insight. (Pun intended. :wink:)

LOL…honestly I was a little embarrassed to even bring it up because I thought I was just losing it :blush:

Mine was easily fixed by just removing them from the Hue Emulator, I don’t need them there anymore since the ST integration.

Only one profile here, so I don’t think that’s it. I think it’s likely a bug in the Echo software.

1 Like

I had the same issue with the hue emulator. I went and click “forget device” for everything that said Hue and a few house later they all were back. I had to unplug the RPi. It’s as if the echo does an auto discover of devices without knowing. I agree with @JDRoberts about contacting support

1 Like

My daughter’s name is Alexa. You are correct, saying Amazon is awkward. I’m really hoping they’ll add an additional name eventually. This is complicated by the fact that any time an Amazon commercial comes on the TV in the room, the Echo gets really stressed out.

4 Likes